How to enable logging on the hub?

@Andremain 39500 is open, 9495 is not.

Any idea why the logger port is closed on the hub?

Okay, that sure sounds like you’re definitely hitting the hub. IIRC, the only thing that should be required for the server to start is the hub firmware update. If you’re okay with me pulling your hub logs (different from these driver logs) so I can see it it’s spitting out any errors internally, please PM me the email address you use on your account and the name of the location & hub if you have more than one.

1 Like

Thanks, I grabbed your logs, I’ll let you know if I can find anything. In case you haven’t tried, also try rebooting your hub. (Hadn’t suggested that yet because it deletes logs, they’re not stored to disk.)

1 Like

@psbarrett Thank you. I tried to delete all drivers and restarted the hub. Then tried to start logging without any luck. Then installed the driver and tried logging again. Nothing helped.
The FW on the hub is 000.038.00010, could you please confirm that it is the latest one?
Regards,
Yakov

Yes, 0.38.10 is the latest release. I also see that version reported in the logs and the IP address you mentioned above. As far as I can tell you’re not doing anything wrong.

However, I’m also not seeing any errors in your hubs logs, so I’m not sure what to think. Unfortunately I think we’ll have to until Monday when I can get some more opinions from coworkers.

2 Likes

@psbarrett Thank you for your help.
Is it possible to get the logs from the hub to take a look?

Sorry, but I don’t think I’m allowed to do that. :frowning:

1 Like

We think a coworker of mine found the problem. Assuming I’m right the logging service should suddenly come up on your hub some time between now and 1 hour & 15 minutes from now.

1 Like

@psbarrett ,
Thanks, the logging service come up. Could you please elaborate what was the problem?

Still, no luck with logging. Now I get

   Error: Request failed with status code 403

Well, that’s progress.

Embarrassingly, we didn’t switch the feature flag on for all users. The “enable all feature flags” in our release checklist apparently meant different things to different people. :man_facepalming:

That seems like a bug that we’re seeing in newer (unreleased) firmware, but just to rule it out can you try changing the “location mode” of the location your hub is in and try again.

:houses::gear: Manage Locations → Select the location this hub is in → Location Mode → Tap one of the modes that’s not currently selected

2 Likes

@psbarrett Awesome! Changing the location mode did help, I now have the logs.
Thank you very much for your help!

3 Likes

:grin: but also :fearful:

I’m glad it’s working for you now. I really didn’t think that was a bug in the currently released firmware though.

Thanks for helping us find this bug!

3 Likes

I seem to be having the same issue, I am able to ping the IP, also able to Telnet into the IP using port 9495 and 39500.
The error I am seeing seems to relate to the OPs issue.

@Benjamin_Ginders ,
If both 9495 and 39500 ports are open, I’m not sure you have the same issue.
However, try to change location of your hub, as described above, just in case

Hi @ygerlovin I have tried changing the location mode several times but it still shows the same error :frowning:

@Benjamin_Ginders Have you checked that you have the latest hub firmware and cli?

I have the latest 39 firmware

and the CLI version is:
image

Hello, @Benjamin_Ginders. Is your network connection stable? this command takes 5 seconds approx to run, if your network is not stable, that could cause the issue…

Hi @nayelyz , yes my network is stable, see below ping to the hub from the CLI device:
image

Thank you for your confirmation. I’ve reported this issue, as soon as I get feedback, I’ll share it with you.