How to enable logging on the hub?

I also have similar symptoms as ygerlovin described. I can successfully build, publish and install drivers to my hub and can verify they are running by using them with my custom device, but the logging tool can’t connect although I’m on the same wired network and can ping the hub.

~/code/xbeeduino smartthings edge:drivers:logcat --hub-address=192.168.0.177 --all
 ›   Error: Connection to 192.168.0.177:9495 timed out. Ensure hub address is correct and try again

~/code/xbeeduino ping 192.168.0.177
PING 192.168.0.177 (192.168.0.177): 56 data bytes
64 bytes from 192.168.0.177: icmp_seq=0 ttl=64 time=0.253 ms
64 bytes from 192.168.0.177: icmp_seq=1 ttl=64 time=0.249 ms
^C

~/code/xbeeduino nmap -sT -p443,8889,8890,39500,9495  192.168.0.177
Starting Nmap 7.92 ( https://nmap.org ) at 2021-09-18 19:17 PDT
Nmap scan report for 192.168.0.177
Host is up (0.00033s latency).

PORT      STATE  SERVICE
443/tcp   closed https
8889/tcp  open   ddi-tcp-2
8890/tcp  open   ddi-tcp-3
9495/tcp  open   unknown
39500/tcp open   unknown

Nmap done: 1 IP address (1 host up) scanned in 0.08 seconds

Port 9495 actually is open on my hub (per nmap), so my underlying issue is perhaps different. The ‘Change location mode’ fix doesn’t seem to be doing anything for me in any case. I’ve tried restarting and using the tool without arguments and entering the ip address as has been suggested here also. I don’t have a firewall active. I’m on the 0.038 firmware (is there a way I can force upgrade to 0.039?):

Hub ID D052A8A7FC2B0001
Status ACTIVE
Firmware Version 000.038.00010
Hardware Version hub v2, US customer Rev E
IP Address 192.168.0.177
MAC Address D0:52:A8:A7:FB:64

Any thoughts?

Hi, @ygerlovin and @stevenlovegrove. I sent you a DM to get some information.
I’ve been able to replicate this error and created a report but in order to check if it’s the same issue for all, please provide the info requested. Thanks! :smiley:

3 Likes

Hi @nayelyz ,

I don’t see your DM.
Anyway, with @psbarrett 's help my issue was solved.
Please let me know if I can be of any assistance to analyse the issue for others.
Thanks

2 Likes

I have the ST Wifi Hub and it’s been updated to 38.11 so Edge drivers should now work. I don’t get any devices discovered for the drivers I’ve installed so I’m trying to get logging messages, but I"m getting this error:

bep@debian10:~$ ./st edge:drivers:logcat
? Enter hub IP address with optionally appended port number: 192.168.1.71
Error: write EPROTO 140163198814080:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:332:

Code: EPROTO

Ports are open:

bep@debian10:~$ nmap 192.168.1.71 -p-
Starting Nmap 7.80 ( https://nmap.org ) at 2021-10-18 14:11 PDT
Nmap scan report for SmartThings_Wifi.attlocal.net (192.168.1.71)
Host is up (0.0055s latency).
Not shown: 65528 closed ports
PORT STATE SERVICE
53/tcp open domain
8889/tcp open ddi-tcp-2
8890/tcp open ddi-tcp-3
9495/tcp open unknown
39500/tcp open unknown
53351/tcp open unknown
58888/tcp open unknown

Name SmartThings Hub
Hub ID D052A8ACA3C60001
Status ACTIVE
Firmware Version 000.038.00011
Hardware Version SmartThings WiFi, Plume US

Any ideas?

Thanks!

P.S. After a little playing around, I was able to connect to the Edge Drivers Log on port 9495 using a browser. However, the only thing that seems to be logging is connecting and disconnecting from the log page. Also, the Download button doesn’t seem to do anything.

1 Like

I get the same error EPR0T0
@nayelyz

ok, let me verify some details with the engineering team and let you both know @mvevitsis, @h0ckeysk8er

Any news on this front?
@nayelyz

@h0ckeysk8er
Have you been able to get the CLI logging to work?

Haven’t been able to try. Been traveling for the last week.

@nayelyz is there any news on a fix for this?

Sorry for the late response, @mvevitsis, @h0ckeysk8er.

Our team is aware of some behavior that is preventing some Edge functionality on the Samsung Connect Home and SmartThings WiFi devices from working as intended. We are working on correcting this behavior and hope to have it resolved in a future firmware release for these devices.

Hi,

Same issue here :frowning:

image

@nayelyz, I would bet that the error is caused by using https at
edge-cli-plugin/live-logging.ts at c3bfd601807407d8911e71e9c6de47cd5c95a41b · SmartThingsCommunity/edge-cli-plugin · GitHub when the hub does not support https for logging (at least this firmware)

Hi @nayelyz

I changed, compiled and linked the cli code, and I was able to connect to log server. I created a github issue with instructions to a tactical fix for the issue.

Best regards!

@nayelyz has this been fixed yet?

I am having the same issue: “Error: Connection to 192.168.1.243:9495 timed out. Ensure hub address is correct and try again.” Tried all steps above to troubleshoot.

It’s not the same error, you’re receiving a time out. (unless you have a Wi-Fi Hub)

Also, please check the following:

  • If your network is stable. Spotty networks could cause the CLI to send this command.
  • If your Hub is connected directly to your main router, sometimes, the middle devices can interfere with the connection
  • If no firewalls could be blocking the connection
  • Which OS are you using?

My network is stable. I even tried an ethernet connection instead of wifi. Pings are very consistently below 1ms and telnet properly connects to the port. MacOS Catalina.

telnet 192.168.1.243 9495
Trying 192.168.1.243...
Connected to 192.168.1.243.

Has anyone gotten logging, or even an edge driver itself, to work on a SmartThings WiFi hub?

Sorry, no news has come up about that, so it is still expected strange behavior using drivers in that kind of Hub.