Honeywell Thermostat not (completely) responding

I’m having some mysterious issues with my SmartThings app controlling my Honeywell Thermostat. The routines will no longer trigger the heat settings on the thermostat, not at the configured time, nor when the routine is selected manually. The lights do work.

When I go to the thermostat in the app and change the temperature manually the thermostat DOES respond.

I have re-authenticated etc to no avail.
When I add the thermostat to my Google Home directly or works with voice commands.

Any ideas?

Same here. Started about three days ago.

Just chatted with support. Apparently they know about it and they found out day or two ago. Can’t control the heat setting or the cool setting with an app. Or routine. You have to go to the actual device in the list of things and change it that way. Working on a fix I guess. @slagle @destructure00


Thanks, Eric! Mine started acting up around the same time. Maybe an update messed it up. I will wait for them to apply a fix.

Same here. Just driven myself mad removing two thermostats and re-adding them, plus resetting the routines. I can change the thermostats in the app okay, but they don’t respond to the routines or smart apps.

1 Like

Me too! It’s super infuriating. This started for me about the same time as you. Something similar happened a few weeks ago but cleared up on its own. Tech support says other users have reported this problem and a fix is in the works, but I haven’t heard back for a few days.

1 Like

Interesting. I can “raise” the cooling setpoint but I can’t set a specific setpoint. Also, “resume” works.

1 Like

Haha, I’m in Seattle. I wish I would have to worry about a cooling point on my thermostat. But yes, sounds like the same problem.

So I am back to being able to set my heating and cooling point using a core piston. It’s working again. But what’s still not working is doing through an official ST routine.

I’ll have to test mine. I’m still waiting for them to fix the operatingState updates too.

**Edit looks like cooling and heating setpoints are working for me too now, just need that operatingState update!

setPoint is now working for me, also. But now, resumeProgram is not. I’m getting spurious “status is Check Your Thermostat WiFi Connectivity” messages even though I see no sign of connectivity problems.

1 Like

I will have to give it a try again tonight. I’ll update once I do.

I did still get these log entries as well, but it wasn’t actually working. I’ll give it another go tonight.

I just checked my set temps from the Honeywell app and they are being set by the webcore piston correctly when I’m not home.

1 Like

Same here. Resume program is not working but setpoints are.


1 Like

Any word from the folks at Smartthings when total functionality will be restored? I still can’t use resume program.

1 Like

Resume program is working for me now. How about you guys?

Yes, maybe. Probably. Ran my test piston four times; succeeded twice. But it’s late, so it might just be me.

A minor update on “resumeProgram” on my Honeywell thermostat. It generally worked to raiseSetpoint before issuing the resumeProgram, but I didn’t like messing with the setpoint and maybe unnecessarily turning the compressor on or off. So, I tried a couple of commands to see if they would similarly jog it to accept resume. I found that setting the mode to cool or heat worked, so now my webCoRE piston checks for mode and redundantly sets the same mode before issuing the resumeProgram. Testing so far shows it works.

1 Like

Sorry for the delay on my update. Things seem to be working again. The schedule works, voice commands work, I should check the logs like you guys I suppose.