Honeywell / Residio Issue

Odd issue I am seeing over the last month or so.

Regardless whether my thermostat is set to auto, heat, or cool, I’m unable to change the temperature settings for heat or cool from the device controls within the SmartThings app. however, if I go into the advanced SmartThings dashboard on the web, I can issue commands there and they’re accepted. I noticed in the logs that commands entered through the device within the SmartThings app are not reflected on the console through the Web interface.Instructions given by third party apps like Google Home which is connected through SmartThings, as well as sharp tools, all work fine. it seems like the driver is okay, but something is wrong with the user interface controls within the SmartThings app. I’ve tried removing both thermostats and reconnecting them in the SmartThings App through linked services and it has not corrected the issue. any ideas? They worked fine for months prior.

Android or iOS app?

I am seeing a similar problem on both the Android 14 mobile app and the Advanced web app.

Android 14.

Using the commands portion for the device @ Samsung account controls them fine.

I’ll also add the ST device controls act like they are working, but in a forced refresh (pull down on device) it reverts to what it was prior to the new setting.

I have three Honeywell VisionPro 8000 WiFi thermostats that are connected to Honeywell Total Connect Comfort. TCC as a cloud-connected service is linked to SmartThings.

My thermostats respond to settings changes in the Android SmartThings app, no issue. It takes around 10 seconds from when I change a setting in the ST app to when I see the thermostat update.

FWIW, I’m running a SharpTools loop to refresh the thermostats in SmartThings every 30 minutes.

The Resideo app and the TCC app are both broken on my Google Pixel 4a-5g phone running Android 14. Both those apps work fine on my Samsung Galaxy Tab S5e running Android 11. Resideo support said “gee, guess it’s an Android 14 issue. Wait for the next app version”…

Thanks, Hal. Yeah, the thermos respond fine to commands from every app/interface except the controls within the Smartthings app. Residio app, Sharp Tools, Tablet running Android 13, web interface all work fine.

1 Like