Honeywell TCC (Connect) not working as expected


#1

Hi, wondering if anyone else experiencing similar problems or are using a different app to monitor their Honeywell WiFi thermostat. I have a Honeywell RTH9580WF and have added it to my ST hub by adding the Honeywell Wi-Fi 9000 Thermostat device. This in turn installs the SmartApp that I can use to monitor my thermostat. The SmartApp shows current indoor temperature and humidity as well as cool and heat set points; however, the app never seems to show the current operating status of the heat pump connected to the thermostat. I simply have a small rectangle in the SmartApp that continuously shows ‘waiting for equipment’. If instead I use the TCC app provided by Honeywell I can see whenever my heatpump is heating (‘heat on’) or cooling (‘cool on’). I debugged the Honeywell app from a browser and noticed that a request is made periodically and a JSON response is received with one particular property ‘EquipmentOutputStatus’ set to a number value depending on the current equipment status. However, it doesn’t appear that ST SmartApp sees this value when polling the Honeywell cloud service. I would really like to get this status information as I am using another SmartApp to periodically upload device statistics to an InfluxDB to plot device utilization throughout the day. Any ideas? Also, when going in the ST IDE website and looking at the events reported by the device I notice there are outdoorHumidity and outdoorTemperature being triggered. Is there a way to include this information on the SmartApp as well since the device is reporting these?


(Zack Whaley) #2

I’m having the same issue with my RTH6580WF. Displays operating status normally, but doesn’t support changing the set points anymore. Tried deleting it as a Thing and uninstalling the SmartApp, but when I went to re-add the app it doesn’t appear to be in the marketplace any longer.


(Scott) #3

I have a RTH9580WF thermostat and have recently been having a similar problem in that it has not allowed me to change the set point within SmartThings while all other commands (fan on/off, mode) work just fine.

When I tap on the up/down arrows to change the set point, one of two things might happen: 1) the arrow darkens to show that I have tapped it but the set point number does not change or 2) the number changes, but a few seconds later it will change back to the original number (without changing the set point on the thermostat itself). When the number changes back I see a notification within the SmartThings device handler app screen that says “not reachable, check your thermostat WiFi connectivity”. I know that my thermostat is connected via WiFi because all of the other commands in the app are transmitted just fine and I can also control everything (including set point) using using the Honeywell app or the online mytotalconnectcomfort.com portal. It is only the changing of the set point temperature value (including by automation) that does not transmit from SmartThings to the thermostat. I have tried reinstalling the Honeywell TCC (Connect) automation app from within SmartThings (must remove thermostat devices first) but this does not work. These thermostats are worthless to me if this feature does not work.

I have emailed Honeywell and will share any responses I get here.


#4

Just to chime in here. I am also having issues with the Honeywell TCC Connect app. In the last week it has become unresponsive. I have also tried to remove the smart app via the smartthings app and then again in the SmartThings API site and in both places I get an error when I try to remove it.

Has anyone been able to at least remove the app?


#5

Hi, I don’t seem to have the same issues as others have reported as I still seem to be able to update my set points from ST. That said, we are not all using same model number thermostat and even if we were I’m wondering if we are all at same firmware version. I have an open ticket with ST support, but have not received any update in a while. If the devicehandler or smartapp source were made available I might be able to troubleshoot myself. Anyway, if anyone else has some ideas I would appreciate it.


(Scott) #6

I was able to remove the Honeywell TCC (Connect) SmartApp from within the SmartThings App environment only after removing both thermostat “Things” first. Reinstalling the SmartApp did not solve my problem.


(Scott) #7

Ok I figured out a solution. The SmartThings Device Handler for this thermostat includes 6 tiles, 1 of which displays the heat setpoint, 1 of which displays the cooling setpoint, and 4 that are arrows allowing you to adjust these values. It shows all 6 of these tiles regardless of whether you have set up your thermostat for heating and cooling, only heating (which I had), or only cooling.

The thing about the RTH9580WF Thermostat is that I don’t believe it supports separate setpoints for cooling and heating. It is either in heating mode or in cooling mode and there is only one setpoint value that rules them all.

In the setup menu for the Honeywell RTH9580WF Thermostat I had only specified that “this device handles heating”. I went back into that menu and checked the box next to “cooling” as well and now it works!

Enabling the Cooling Thermostat Mode has changed the details for the device within the SmartThings Web Console, where I see the available “Current States” now include one called coolingSetpoint and another current state called “thermostatSetpoint” that wasn’t there before. I believe that the device handler app was poorly written and only tested to work on a thermostat that has both heating and cooling modes enabled. I bet that the RTH9580WF API only responds to changes in the thermostatSetpoint values which is why the app was not getting a response when it tried to adjust the heatingSetpoint value, which is the only state that was enabled earlier. The error message was that the device was not responding and that it could be a wifi connectivity problem but I bet it simply wasn’t responding because it was getting a “No such value exists” response from the Honeywell API. That’s my theory anyway.


#8

Thanks.

Adding the cooling option from the thermostat fixed it for me.


(Jason Hamilton) #9

What about those of us who don’t have the super fancy one with menu settings and whatnot. My thermostat is this one https://www.newegg.com/Product/Product.aspx?Item=0FJ-009M-00002
There is no menu options on it or anything fancy. Up until recently its been obeying WebCORE just like a good little thermostat but like everyone else on this thread I keep getting that the device is not reachable. I’ve tried everything with it and nothing seems to work correctly. Any help on this is greatly appreciated.

BTW the only reason I got this model is my previous thermostat which was a Honeywell Zigbee that I got as part of a trial thing from my power company was identical to this model. So had the same mounting hardware just had to swap it out

BTW when you refer to the web console are you talking about the IDE?


(Jason Hamilton) #10

So I just changed my device in the IDE to be a Honeywell TCC Thermostat and it changed the UI back to what it was before they decided that I have a 8000/9000 series and now it looks like I"m back to a functioning state. Wish I would’ve caught this earlier but nothing was alerting me that it wasn’t talking to the thermostat anymore.


(Rick M) #11

Add me to the list of Honeywell users with connectivity issues. I have the RTH8580, which isn’t listed under supported devices but is supposed to work using the 9000 DTH. Anyway, none of my manual input or automated routines are working with the thermostat. In both my app and IDE, I get the message “not reachable, check wifi connectivity”, however my unit is connected to WiFi and can be controlled with the Honeywell TCC app just fine. I’ve messaged with support, and they insure me they are working on a fix…as usual.


#12

Thank you, DuhDude. We have a Honeywell RTH9580 Wi-Fi thermostat. As you described, all that was necessary is to check Cooling in addition to Heating in the System Setup (it is on the fourth screen). Thanks again.


(Tinsheep) #13

Rick - i have the 8000 series as well - any luck here? I’m about to junk it. Thanks for any help - not sure what else to do. There aren’t any ‘device handles heating/cooling’ settings on this one. Shows correct temperature reading and humidity but it wont accept any automation commands from ST. Like others - the Connect app works just fine. :frowning_face:


(Bob Wise) #14

Adde to list thermostat will display correct temp but app not able to control says check wireless connectivity

Smartthings support say they are aware but going on almost a month it has been broke

Also i able to control thermostat via honeywell website

Bob


(Rick M) #15

Tinsheep,
No resolution so far. I’ve had a couple inquiries from ST staff, but still not working correctly. It still amazes me how often things that are working perfectly seem to randomly quit working on this platform.


(Tinsheep) #16

Thanks for the reply… frustrating


(Agus Soewita) #17

I have to create a virtual switch in ST and use IFTTT to trigger it


(Klent) #18

Add me to the list. Honeywell app works perfectly with the stat but when Smart things sends any command tot he stat it returns the no connectivity error. The whole system used to work fine until a couple of weeks ago.

T


(Tinsheep) #19

Hey things started magically working for me today all of the sudden … I didn’t change anything and this is the first time it’s actually worked but note that I just started the Life360 and Honeywell integration just last week. Ayone else having luck?


(Klent) #20

No joy for me yet. Still gives the “Thermostat unreachable” when a command is sent. However, the Hub pings the stat almost every minute and gets the temperature back.
T