Honeywell TCC RTH6580WF works then it stops working

Hi, I have two Honeywell TCC RTH6580WF thermostats. I can add them both into Smartthings, see the temperature, change the temperature, and then setup all of my routines. They work great after all that. But then a couple of days go by and while I can still see the temperature, I can’t change the set points anymore on either one. I get “A network or server error occurred. Try again later”. (This is all in the newest version of the Smartthings app, and the Honeywell TCC app works without issue.)

I had this happen before, so I went and deleted the thermostats, readded them, all happy again, and then a few days later, they’re back to not working. I could deal with deleting and readding the thermostats, if only it didn’t also delete all of my alerts and routines.

Is there anyplace I can find logs on Smartthings talking to Honeywell? I’ve seen this issue popup in the past, though that was with the old Smartthings app, so the resolutions don’t see to still apply. This is at a second house and I like being able to see different temperature schemes when I’m at the house and when I’m not.

Thanks for any help.

Same issue here. Must be an issue on Honeywell’s side because same thing is going on in Google Home

From time to time, I have go to Settings --> Linked Services and log back into Honeywell Home TCC.

My RTH6580 previously had issues with IFTTT and now with ST. It is probably worse than I realize, but I don’t exercise automations as much with lockdowns. To be fair, it could be an ST service issue, since the same thing has happened to my Bond remotes also.

Hey … the tip you gave above about going into Settings --> Linked Services worked for me. I did that and now everything is back to life for at least a couple of days.

Thanks for the tip!

1 Like

Honeywell’s servers are trash…even worse than Smartthings…

1 Like

I also have two TCC RTH6580WF and I noticed the other day that I could no longer change the set points. I went in the WebUI and changed the Device Type from Honeywell TCC 6000 Thermostat to Honeywell TCC Thermostat and after a few minutes was able to change those set points again… a few hours later I noticed again that I could no longer change the set points and the Device Type had changed itself to Honeywell TCC 8000/9000 Thermostat. :man_shrugging: What Device Type is working for you?

My device type is “placeholder”. I have this connected via linked service to my Honeywell Home TCC account. I can only advise that this disconnects every month or so. Not sure what happens when you change device type.

Same for me. Mine shows as “placeholder” with the name as “TCC Thermostat”. I added it through the Smartthings App choosing as a brand “Honeywell Home Total Connect Comfort”. I do still lose connectivity or it makes me login again on occasion, which is generally annoying, but usually will reconnect when I ask it too.

Not sure why the idea of “auto-reconnect” hasn’t apparently been on their roadmap…

Thanks, all. These devices were migrated a few months ago, so apparently something didn’t come over as expected. I ended up deleting/re-adding the thermostats through the app and now their Device Type does show as “placeholder” in IDE and everything appears to be working in the app. Of course, when I deleted the devices, I had to re-add them to various scenes (which of course resulted in the dreaded “NETWORK ERROR” issue, requiring me to completed re-create the scenes). :disappointed:

Came to post an issue, and this is literally the first thread on the page!!

The suggestion to go to linked services and re-connect was super helpful. Fixed the issue for me. My issue comes back every 1-2 days, so hopefully this gets fixed.

Hmm, I don’t normally use my ST app to control my RTH6580WF. Even after reconnecting the service and having it show as connected, it still fails. I just tried to bump the temperature up a notch and it returns:
“A network or server error occurred. Try again later.”

I just wish they would bring back the resume program command.

I have this exact same problem. My suspicion is something’s wrong in the device-handler behind the scenes that interfaces with Honeywell’s system.
No idea how to pursue this - fortunately I don’t really need the Smart-Things integration and can directly connect Alexa to Honeywell’s TCC system.

Can someone explain how to log out and back in to TCC in the linked services section of the app? The only thing I see there when I select TCC is a list of my thermostats and a “delete device” option. I am getting the same “a network or server error occurred…” message. I used to know how to do this in the old app. I used to be able to do a lot of things in the old app that no longer seem to work. Some upgrade…

Youre doing it correctly. Has to be a problem on Smartthings side. Contact one of the helpful Smartthings reps on the forum for help

How exactly does one do that - contact a SmartThings rep?

I have another thread here where I can see errors in the logs through some of the V3 apps. Would like to know how to pursue them too with someone from SmartThings as these too were things that previously worked with the old version.

Thanks and please have a Happy New Year