Help with Z-Wave Door Lock Status!


(Nguyen Ha) #1

I have a SmartThings Hub with a Kwikset Z-Wave Lock. Yesterday, I noticed something weird that has been going on for the past couple days.

If I unlock and lock the door from my phone app, it works fine and the status is correctly displayed (unlocked or locked).

If I go in the house unlock the door using the keypad and lock the door manually when I am inside, it works fine and the status is correctly displayed.

However, the only scenario where I leave my house and click the “lock” button on the physical door lock, the status still shows “unlocked”. But if I click "lock’ on my app, the motor doesn’t move and the status simply changes (good thing it doesn’t do the opposite). Any reason what might cause this and how to fix it? I have tried replacing batteries and putting a repeater to no avail…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

What do you see in Live Logging https://account.SmartThings.com


(Nguyen Ha) #3

If I’m looking at it right, it just says the events of lock and unlock and the time stamps. The latest event is it being locked from my application (even though the door was already locked physically and showing as unlocked before hand…)


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

You can also get additional information (including Events) for the specific device (your Lock) under the My Devices tab of the IDE.

If those are all showing “correct” information, then it seems likely the problem is in communication with the Lock (i.e., Z-Wave issues: Run a Z-Wave network mesh repair?), or a failure of some sort of the Lock itself.


Regardless: The diagnostics from the IDE should be helpful when you communicate with SmartThings Support.


(Nguyen Ha) #5

Thanks. This is what I had mentioned above, those events are from under the “My Devices” tab. It is showing the correct information in all instances except when I lock it manually (perhaps you are understanding the scenario wrong?) I’ve already ran a z-wave network repair and it still doesn’t work. The problem is that when the lock is manually locked from the outside, the status does NOT change in SmartThings.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

And you get no message in the Event Log and Live Logging with the manu lock, right?

If that’s the case, either the Lock isn’t sending the Event, or the Event is being lost.

I suggest unpairing (removing) and re-adding the Lock to SmartThings … sometimes that will force the DTH to be updated with the most correct code and state.

Other than that, you are either in the realm of mysterious Z-Wave issues, or a problem for which SmartThings Support is needed. Sorry.


(Nguyen Ha) #7

That’s my plan when I get home, excluding it then adding it back…hopefully that will get things right. Thanks!


(www.rboyapps.com - Make your home your butler!) #8

Try this, click on lock on your phone app (it’ll show locked), now kill your ST mobile app and restart it or come out the page and re open it and check the state again. If it’s showing unlocked, then the state never actually changed, it was just a display update and not a state update. What they means is that your lock isn’t getting the lock command.

Things to try:

  1. Reboot your hub and do a z-wave repair (given that you say there’s a repeater close by)
  2. Exclude, reset and re pair your lock (reboot hub for safety as well)

#9

Do you know if the mesh network pucks (ac1300) have beaming capabilities? I’m having issues with a lock but light switches next to door work fine.

Thanks


(www.rboyapps.com - Make your home your butler!) #10

Could be positioning. Signal can reflect off walls corners and objects and do very funky things.

Try to add a repeater at different location or move the switch/lock if possible. If there are big objects nearby check those. Also rebooting the hub and doing a repair can help sometimes.


#11

Do you know if the mesh network pucks supports beaming? I’ve also read “repair” quite a bit but it seems to relate to classic st and I have the new app (iOS)


(www.rboyapps.com - Make your home your butler!) #12

What do you mean by “pucks”? Most locks support beaming.

Repair can be done via the ST Classic app and
Also the IDE under hub Utilities. This should be the first line of defence whenever facing a network issue.


(Benji) #13

Those are WiFi and have nothing to do with Z-Wave, so no.


#14

Dang, I was hoping since the main hub is also a smart things hub that the pucks were repeaters. Guess I’ll need to add a repeater or two to my network.

Thanks


(Nguyen Ha) #15

I’ve rebooted the hub, reset and repaired the lock, and still the same issue where if I physically lock the lock with the button on the outside, my application will not update.


(www.rboyapps.com - Make your home your butler!) #16

Did you kill the app and restart it after tapping lock on the app and check if it still showed locked or unlocked ?


(Nguyen Ha) #17

Yes I did this. After tapping lock on the app, killing and opening it, it shows locked.


(www.rboyapps.com - Make your home your butler!) #18

In that case I would suspect it’s a lock issue. Had it shown unlocked I would have had a different diagnosis.

Try to reset the lock.

Let’s thing to try:
When it’s unlocked open the IDE Live Logging.
Click on lock in the app
Wait upto 10 seconds. Capture all the logs from the ide Live Logging lock device and copy paste it back here and I could take a look at and confirm what’s going on.


(Shawn J) #19

So my understanding is, initially the Samsung Connect Home secondary pucks were not z-wave and zigbee repeaters. However they had a firmware update that allows them to be now. Samsung Connect 3pk - zigbee/z-wave repeater or not?