HELP! Smartthings app keeps redirecting me to browser


(shash) #1

So recently purchased the ST hub and was very excited to set it up. Unfortunately when i try to login to the ST app on my android, it wont let me go past the screen where i enter the email id. It keeps redirecting me to the samsung browser page which for some reason comes up as unoptimized for viewing on my phone (although my default is a chrome browser and this page is optimized for that). Anyways as a result im just stuck and cant setup the app on my phone.

I was able to pair and setup the hub just fine using my wifes S7 but i have no control over the hub on my phone as i am unable to install the app. I have an Honor8 so not sure if there is any particular setting that needs to be modified on my phone to allow successful app installation.

Any advice or troubleshooting reg this would be much appreciated!!


#2

Are you Enrolling or Login In? Make certain what you click.


(shash) #3

doesnt matter which one i click - the same thing happens. now that my wifes account is linked to the hub i have been trying to just login as an existing user on my phone but no luck.


#4

Is your Android 5.0 or higher?


(shash) #5

yep Android 7 Nougat


#6

Needless to say the SD will ask you this. Did you re-install the app on your Android phone and and when you install the app again, you may be prompted to grant permission to things on your phone. Also, please open a support ticket.


(shash) #7

yeah did that like 3 times now - checked permissions each time and granted full access to the app. Will open a support ticket.


(Dave Gutheinz) #8

I have seen this before (from another user). Your default browser is not compatible with the Samsung site.

For us older users (pre-Samsung Connect), it is not an issue; however, new users are directed to the samsung site for login and setup. The Samsung site does not recognize all browsers.

Another possibility (from the Samsung FAQ’s

If you can’t sign in, please check your devices or Samsung account version. Sometimes, it might be a temporary system error.

  1. If you see an error message such as ‘An error occurred during an SSL connection’ or ‘Sign in failed due to difference between current time and device’, then please check ‘Settings - Date and Time’ on your device. For security, Samsung accounts require the settings for date and time to be the same as the actual date and time.
  2. If you still have problems signing in, please contact Customer Support (https://account.samsung.com > Contact us).

(shash) #9

thanks i contacted support yesterday and they acknowledged that this is a known issue but is happening only on Huawei phones. He supposedly put me on a list of other individuals with similar issue who will be notified when there is a fix. This sucks big time.


(Joshua Lyon (SharpTools.io Dashboard)) #10

In the mean-time, can you control your devices with SharpTools? You won’t have access to create new devices or routines, but if you need the ability to control things, it might at least ease some of the pain.


(shash) #11

thanks a lot…yes thats very helpful. i can always add/modify devices when im at home on my tablet but not able to remotely access them was my biggest gripe.


#12

@shash123 just fixed this on my Huawei Mate 9!!! In Apps, go to the SmartThings app > Open By Default > Open Supported Links in this App > Change to ‘Always Allow’

This worked for me! After I did that I reopened the app and was directed to the create account screen. After I selected Create Account I was redirected to the app to configure SmartThings. I hope this works for you too because I’m over the moon right now haha. Luck!!!


(shash) #13

unfortunately that doesnt seem to work on the honor. Its infact one of the first things i tried doing and still no go. Basically gave up and contacted ST CSR and they said they are aware of this issue and are working on a fix. Apparently this is localized to Huawei phones, so not really keeping my hopes up. sigh.


#14

I had this exact same problem with an old LG G2 with a custom ROM. I tried everything but to no avail.

Then I went back and got an older apk from apkmirror - SmartThings Mobile 2.2.7 and uninstalled the newer app and installed the older version and that worked fine. I then updated the app to the latest version and that also wokred.


#15

Mate 9 user here with the same problem. Was very excited to try this, but unfortunately, no go :frowning:.


(Roy Carlson) #16

This worked for me (Nexus6p here - another Huawei phone).

I’d prefer to update the app, but I’m cautious at this point and will stay on 2.2.7

Was there a reason you picked 2.2.7?


#17

2.2.7? Where are you getting that version from? Is this a version from the future?


#18

LOL it is an old version that worked when the previous current version did not. All the old versions of the apk can be found on apkmirror and similar sites that keep a log of old apks.

I updated on my phone and it still worked as I was already logged in and did not have to go throught the login stage again.
I have tried it a few times now so no biggie if you have to go back to 2.27 and start again.

Bummer, you could try an earlier version and see what happens. For me that was the latest version I could use before I got the dreaded browser problem. I sat there and slowly went backwards with apks till I found one that worked - 2.27 was the first one that did not take me to that browser problem page with the login. Another thing you could try which also worked for me using 2.27 old version was I invited anther user to my smartthings account and when opening the app on my phone I made a new account with that invite email and that worked too.

BTW the very latest update works for me as I logged out and back in and it did not refer me to reinstall the web browser like the previous version of the app did so maybe they have fixed the problem with V2.10.0


(Rob Evans) #19

I have the same issue on Xiaomi MI8, i used the smartthings classic which is still on playstore and that works fine…Rob