FIX! If you are having issues with the Huawei Honor Phones signing into the Smartthings app


(Rod Stevens) #1

So yesterday I got a new Honor 7x phone and needed to use the Smartthings App on this phone. With the release of the Honor phone in the USA recently, I am sure people will have this similar issue. I experienced and have read issues where the Smartthings app does not want to work with the Huawei/Honor phones. What my issue was that once I pressed the “Sign In or Login” button, it would open a browser and say some gibberish:

This is what it would say:
image

I spoke to a Smartthings rep via chat and he helped me figure out this issue. The below may or may not help you, but it worked for me. If it doesn’t work, I would contact a smartthings rep via the chat and they can walk you thru your issue.

Here are the steps I did:

You may or may not have to do step 2, but I already did step 2 because I was reading online somewhere about uninstalling the current version smartthings app and installing an earlier version 2.2.7 and then logging in using your “smartthings login”. Then you can update the app from there. BUT if you have a samsung login, then you would have to do a little extra.

Step 1: If you have a firefox browser, uninstall it. Install Chrome browser if you dont have that (Should be installed by default)

Step 2: uninstall smartthings app and install earlier version 2.2.7 found here:

https://www.apkmirror.com/apk/smartthings/smartthings-smartthings/smartthings-smartthings-2-2-7-release/smartthings-mobile-2-2-7-android-apk-download/download/

You will need to download the above on your phone and then locate the file, typically found in the downloads folder.

Step 3: Once installed, login using your smartthings login. Then update the app to the current version. Then login again. IF you have a samsung login associated with your hub already, then click on the “New User” button. If it recognizes your samsung login, then you should be auto-logged in, but if you get that browser open issue again, then you will need to do step 4.

Step 4: If the browser tries to prompt you to open a browser, select CHROME and ALWAYS. Now go back a page because it will show you that dumb error again. So go back and then click “New User” again, and it should take you to the Samsung Login browser. That’s pretty much it.

Hope this helps and I typed these instructions pretty fast because I am at work. So please excuse any grammar errors and/or sloppy instructions.

Thanks!


Help, smart app doesn't work with HUAWEI cellphone
(Richard Gledhill) #2

Hi,
Many thanks for this - I have exactly the same problem on my Huawei P20 Lite. It’s ridiculous that in this day and age an App can force you to use a browser and then even when you do use a common browser, it still fails!!
Installing the old version allows it to work fine, but then Google Play promptly updates it and we’re back at square 1 with it sending me to the login screen
Eventually I tried closing all running applications, which seemed to include both the old and new versions of the SmartThings App as well as browsers, then ran the updated App with Chrome set as my browser and I could log in.
Now when I run it, none of my devices appear. It turns out there are TWO apps called SmartThings; the newer one recognises my login but doesn’t have any of my devices. The older one appears to work fine.
Seriously Samsung, get your act together!!
Richard


#3

It’s frustrating everyone! :scream: See the FAQ (this is a clickable link)


(Richard Gledhill) #4

Ah, interesting, so they taking many months to migrate users over… I’ll uninstall the new one then, and carry on with Classic.
Thanks, that’s very helpful!
Richard


(Leo) #5

I experienced the same issue and got it fixed today. Note, I had no issues with my Samsung tablet, but my two Huawei Honor 8 phones stopped working after converting to the new Samsung account. The problem seems to be definitely related to the Huawei devices.

I called Samsung support and tried a few things without luck, but the following seems to have solve the problem.
On my Huawei Honor 8 phone:
1 - Go to Settings > Apps > Chrome > Click Force Stop > Click Disable ( you can enable it later)
2 - Go to Settings > Apps > Smartthings > Click Storage > Click Clear Cache
3 - Go to back to Settings > Apps > Smartthings > Click Force Stop > Click Disable
4 - Install Firefox Browser.
5 - Cross fingers and Launch the Smarththings Classic App. At this point, I was able to login without problems.
6 - Go to Play Store > search Chrome > Click Enable ( to re-enable Chrome Browser)

PS I also unistalled my LastPass App which comes with a browser, but I am not sure this was related to the fix.

Good luck.