SmartThings Community

Help, smart app doesn't work with HUAWEI cellphone


#1

smart app doesn’t work with my phone (HUAWEI MATE 9 PRO), I opened a ticket(404092) three months ago, and samsung did’t give me any solutions. They just tell me their engineers are working on the app. Anybody has a way to fix? Thank you


(Bob) #2

In what way doesn’t it work.
I have a Nova 2 plus and it works.


#3

thx bob, when i open app, and click ‘new to samrtthings’, it automatically open the browser, and page is failed to display. I tried all the browser( chrome, samsung internet, default), I have attached a screen shot.


(Bob) #4

OK. So it’s not the app, it’s the link it takes you to.
Where is the “New To SmartThings” option that you are talking about.


#5

when you launch smartthings app, you have two options, “new to smarthings” or " I’m a smartthings user". both of this two commends take me to the screen shot that I just posted. I talked to samsung tech today, they told me that more and more users have this kind of problem, they are trying to solve it, but it takes time.


(Bob) #6

Ah OK, with you.
I didn’t realise you was at that early stage.
I only got my Huawei 2 months ago and have not had any issues.
So it’s probably not a phone issue, more of a link issue.


#7

i guess it’s a phone issue , tried 1 mate 9 and 2 mate 9 pro, none of them is working, and reinstalled st app and browser app couple times, clear catches and memories , reboot phone. …, no luck.


(Jimmy) #8

what version of andrioid is on the phone? The same ting happens with Amazon Fire tablets, but thats because Fire OS is based off Android 5.0, which the Samsung authentication website doesn’t like.


#9

ANDROID 7.0, I had this phone for less than a year.


(IG) #10

Im with Mate 9 too, no problems. Did you try to install SAMSUNG CONNECT?


#11

yes I installed samsung connect, if I click log in , it shows the same screen as I posted.


(Derek Murphy) #12

I have a Mate 9 Pro and it works fine. Although I had another phone with Smartthings working on it before this one. Do you have the Chinese version or the international?


#13

I have chinese version, I think this is the problem, just don’t know how to fix it.


(Jake Chen) #14

I also cannot get smart things on my Huawei Mate 9. I know the companies are competitors. But this is not so nice because I’m a customer who’d like to use whichever device is best based on my own judgement. Anyone got a workaround solution here?


(Roy Carlson) #15

same thing here. Nexus6p phone. Filed a ticket, tried everything I could think of and am unable to connect.


(Roy Carlson) #16

I was able to work around this by reverting to version 2.2.7 of the smartthings app (apkmirror).
Although I already have a samsung account, this version of the app didn’t recognize that account so I registered a new “smartthings” account in the app.

Now, my question is now that I’ve gotten past the registration phase, can I upgrade to the latest version - was the issue only with first account setup and login, or will the original problem persist?


#17

I filled a ticket three months ago, no update. I don’t know why it takes so long for samsung engineers to solve this issue.


Creating a ST account not Samsung
#18

I am going to try the 2.2.7 version and if it works, I will update it and let’s what will happen


#19

I tired 2.2.7 version, didn’t work, I was not able to log in. I enter my user name and password couple times,and keeping showing message that says either my user name or password is wrong. I am 100% sure everything I entered is correct, and click forget password option and I did’t receive any email to reset my password. I guess this version is no longer supported.


#20

I was not able initially to login in the latest 2.11 version with my huawei honor 9 - got the same incompatibility message. But I might have found a workaround : I’ve manually enabled access to my location for the app (via settings - permissions). After that I was able to sign in. I was playing with others permissions as well, but I think location was the key. I don’t know why the app cannot request that permission on install.