HELP! Smartthings app keeps redirecting me to browser

Iam having the same issue with an amazon fire 10.1 tablet, if anyone can help would be a blessing ,
Using new smartthings hub not old one , so i cant try to log into the classic one bexouse the new hub doesnt have a code , so iam stuck trying to ise the new app

I had same issue on Mate 20 Pro - basically there wasn’t a ‘default’ browser installed, I had chrome, chrome beta and FUll browser, after I deleted Beta and Fully all worked fine

On the amazon fire tablet 10 inch 7th gen that iam using i added a default web browser , fire fox but silk browser still keeps taking over and sending me to that page , i can open up the classic app its asking for an activation code and the new hub doesnt come with one :sob:

I resolved the same problem on my Honor 7x. I uninstalled “duckduckgo” browser and left Chrome as the only default browser option. Bingo. I was able to login.

Anyone know if these steps will work for Fire tablets?

Same problem for me on a brand new ASUS Google Chromebook.

same problem suddenly on my xiamomi mi note 10
after removal of (default) mi browser could log in again


I had same problem, I worked on it long times. My default browser is Mi Browser which is based Samsung Browser. I found this solution:
(I delete all cookies and data via Android OS)
1-) Press the Mi Browser app
2-) Choose App Info
3-) Delete Defaults
4-) Delete Updates
Then I opened SmartThings app, followed steps, It worked.