Having Issues with Sylvania Gardenspot Control

I recently purchased 2 Sylvania Gardenspot starter kits for my front yard and connected both to smartthings successfully. One of my Gardenspots work perfectly fine when controlling from the Smartthings app (color, dimming, on/off, etc). The other one is not responding to any of those commands. If I turn the light On or Off, it will eventually do it but Smartthings always says the light is On even though it’s off. I also have it setup to a Smart Lighting automation where the lights turn on and off at sunset and set a color and level. The 2nd one that I’m having issues with will turn on and off based on sunset but will not set the level or color. So it appears that some type of communication between the device is occuring even though Smartthings is acting strange.

When I log into IDE, I see that my 2nd device that is giving me problems is showing as OFFLINE while the perfectly functioning one is showing as ONLINE. Both have the same device handler. Any ideas? I’m kind of stumped since the automations are partially working on the 2nd device even though it’s showing as OFFLINE.

Thanks in advance.

I ran into similar problems until I upgraded the firmware. As far as I know, you’ll need to use a Sylvania gateway to do that currently. The cheapest way is to purchase a smart bulb with gateway.
Under $9 at Amazon.com.
https://smile.amazon.com/SYLVANIA-General-Lighting-71932-Sylvania/dp/B073M6274B/ref=pd_bxgy_60_2/136-3957350-5606608?_encoding=UTF8&pd_rd_i=B073M6274B&pd_rd_r=1d11ea62-fa73-4859-9272-da27a2c2b52e&pd_rd_w=EPfqx&pd_rd_wg=bo4kg&pf_rd_p=09627863-9889-4290-b90a-5e9f86682449&pf_rd_r=9WRBKFK635W18TVY3AX1&psc=1&refRID=9WRBKFK635W18TVY3AX1

Both devices are showing the same firmware version:

  • Current Version: 0x00102201

  • Target Version: 0x00102201

  • Current Version: 0x00102201

  • Target Version: 0x00102201

Smartthings won’t show the updated firmware, you need the Sylvania hub. If you’re close to the Phoenix area, you’re welcome to bring them over.

Ha…thanks for the offer but i’m a couple thousand miles away from you.

So the version that shows for the firmware on Smartthings IDE is not the actual firmware version that’s on the lights?

Smartthings is showing the correct firmware, but it doesn’t have the newer (target) firmware available for the devices.

For examole, mine are 0x01020492. However, I’ve not checked for newer firmware in a while as it requires removing from Smartthings and adding to the osram hub. But, it is still newer firmware than what you have.

You’ll need to update the firmware to 0x01020492 to make them more reliable.

Are you sure smartthings does not push the latest firmware?

Mine are listed as 0x01020492

I think smartthings does push the latest.

Smartthings never got updated firmware for mine. That’s why I bought the osram gateway. Maybe yours are newer on the shelf and had the new firmware?

For $9 it might be worth it to check.

The screenshot at the top of this thread makes no sense unless there are different models floating around?

I am pretty sure that I did get an update through smartthings.

But for $9, update them and let us know the latest firmware version numbers.

Maybe there are newer firmware versions available?

Is the screenshot at the top of the thread an older firmware? A newer firmware? A firmware for a newer or different model of garden spots?

How many different models of garden spots are there? More than 1?

Let us know

I’ve gone ahead and ordered the Lightify Gateway and it will be here Friday. I will test it out at then. It’s just a pain to have to unpair, reset, pair, and then do the same thing again to get it back to Smartthings. Also, I’ve included my device screenshots for reference:

Hey, what is your screenshot from?

These seem to be different products, see the descriptions.

Are you sure you have osram garden spots?

They are the same thing. I believe at some point Sylvania/Osram split off and created the Ledvance name for their Smart+ lights. They are the same exact things with a different name.

Is this what you have?

https://www.ledvance.com/consumer/products/smart-home/smart-home-products-with-zigbee-technology/smart-home-luminaires/outdoor-luminaires/smart-gardenpole-multicolour/index.jsp

That is different.

Well regardless Smartthings thinks it is different and it thinks your devices are at the correct firmware.

Are these the lights?

They look similar. But the firmware thing is confusing.

The latest firmware for the garden spots that I have came out in 2016.

If you have brand new product why would it have old old firmware?

I wonder whether it is similar but a new model with different firmware?

This is from the amazon page, different model number and it shows a need for custom code to make it work with smartthings

Yes, the 2nd link is the one I have. They are identical to the old Gardenspots. Even though it says device handler required, that is not the case as when you go to their support forum it states to just change the device type to Zigbee RGB Bulb if you have problems with it not detecting the proper type of device.

The only actual difference between the lights I have and the old Gardenspots is the reset procedure. For the Gardenspots I believe it’s plug and unplug 5 times in a row where as for the ones I have, it’s plug and unplug 5 times in row but you have to wait 5 seconds in between actions. Other than that and the actual name on the device, they are the same thing.

I’m just going to do as originally suggested and try to update the firmware with the Lightify Gateway as planned.

So I got the Lightify Gateway today and connected one of the lights to it and the firmware on those is still showing as 00102201 which is the same as what SmartThings was showing. I went into System Settings > Updates to see if it would reach out for an update but no luck. Maybe these are already on the current firmware or is there a way to force the update through the Lightify app?

Sorry you did not get newer firmware :(, but this matched what I guessed, these are different models with different firmwares.

You are already on the latest firmware for this model.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.