Harmony Connect App Crashing

Well I am out of the house…tying to control remote. Created a simulated presence sensor in IDE, but does not seem to be working as of yet. Lets see if I can mess with the modes/presence sensors to gain back control…

@slagle

It appears that in the firmware update the harmony connect app was changed to one that crashes if you try to use the new trigger control features. But the old “Logitech Harmony triggers” smartapp was added back to the marketplace. (Previously replaced by “Harmony Control” (not Connect)).

But I didn’t see anything in the release notes about harmony changes.

And I don’t know if Both V1 and v2 customers got the same changes.

Can you find out whatever the current recommended procedure is for adding trigger control for harmony since this firmware update? And could we get it added to the release notes if there’s something significant (like don’t touch this field or you’ll crash)? And if it’s now different for those with v one and v2?

Thanks!

It’s news to me if harmony got changed… I’ll have to ask around. :frowning:

I have the harmony triggers smartapp found under SmartApps ->More in the marketplace. I am not seeing a crash when adding it. Are you having a crash using it or installing it? FYI mine says last updated May 17, 2015.

V[quote=“jodyalbritton, post:244, topic:29290, full:true”]

I have the harmony triggers smartapp found under SmartApps ->More in the marketplace. I am not seeing a crash when adding it. Are you having a crash using it or installing it? FYI mine says last updated May 17, 2015.
[/quote]

The crash isn’t in the triggers app. The crash is in the new triggers field in the revised “Logitech connect” app.

Here’s the timeline:

  1. there was a Harmony Connect smartapp in Labs

  2. a Logitech Harmony Triggers smartapp was put into Beta

  3. with the release of mobile app 2.0, Logitech Harmony Triggers came out of
    Beta and was available to everyone in the US

Four) at sometime in October, some customers, but not all, had the harmony triggers app replaced with a new smartapp called “harmony control”. (Not harmony connect) They did about the same thing, but it’s not clear if it was just a rename.

Five) harmony options were removed from UK accounts

Six) in one of the last two firmware updates, the harmony connect app was changed so that it combined Harmony Connect and Harmony Control into one smartapp. So when you went to connect a new hub, you were also shown a list of activities and were supposed to be able to set up the triggers for them. The problem is that this will crash if you touch the trigger fields.

  1. sometime shortly afterwards, perhaps in the most recent firmware update, “Logitech Harmony triggers” returned to the marketplace, presumably as a workaround for the crash in six above.

Now some people at least can add the hub with harmony connect and stop there. Then they can go into the marketplace and get the triggers app and set up the triggers. But the connect app still crashes if you do try to select the activities there.

1 Like

Moved this here. That firmware topic is getting a little off topic lol.

I have confirmed the issue.

@juano2310

3 Likes

Thanks @slagle for the heads up! Is this US, UK or both?

I’m in the US, so US for sure. I don’t know about the UK.

@JDRoberts, Thanks! Try now :smile: and please let me know. Hope you like the new virtual activity. You can still use triggers like before too.

1 Like

Yes, it worked. No crash. :sunglasses: (Although I didn’t completely uninstall the Harmony first, so I don’t know if it works from a clean install. And I haven’t tested actually using it yet. But at least I got farther.)

So this now replaces “Harmony Connect” with “Harmony Control”?

No, it was more like an update. I didn’t change anything unless you had the old deprecated one.

@juano2310 … Go cook your turkey! Happy Thanksgiving…nice addition to the app, works well now…Thank you.

1 Like

@juano2310 You Rock! The Virtual Switches for Activities is AWESOME, and so much easier than having to program my own! I’ll call it a Thanksgiving gift from SmartThings for me going out and buying another 2 multi-sensors today.

I’ll report back Success/Failure on everyday use over the next few days.

Thanks again.

1 Like

@rob_gore glad you like it! Please keep me posted! Happy thanksgiving!

1 Like

@juano2310 No luck using the Virtual Activity Switches.

I have to Logitech Hubs in the house. And have activites separated by Hub.

I’ve tried on both and here’s what I get out of the trace:

trace java.net.SocketTimeoutException: Read timed out

Always a timeout.

Any thoughts?

I still have the credential issue

Should I just uninstall and try again?

@McLovin Yea, I’d remove and re-add the App.

@juano2310 I was able to fix the activity timeout, by removing the virtual device, and then re-adding it again through the Logitech (Connect) application. Very Weird still, but its working now!

2 Likes

Just a random one to throw in… Does this process work for people in the UK?

I’m really struggling to get my Harmony Hub working with ST?

Hi @deano12! Yes, it should be working in the UK too. Please remove the smartapp a try again. Let me know how it goes.

I’ve got the smartapp installed, however - How do I now go about integrating Smartthings to Harmony?

EDIT: Never mind! :smile:

2 Likes