Harmony Hub UK Integration

Interesting. I know have this working but my process was as follows:

  1. Tried to connect Harmony to UK location and just completely failed
  2. Created US based location through graph.api.smartthings.com
  3. Connected Harmony to this. It couldn’t find any devices but did connect and authorise
  4. Copied the code from catalog, enabled OAuth and tried to install. It failed with the error above
  5. Amended the location in the smartapp code from graph.api.smartthings.com to graph-eu01-euwest1.api.smartthings.com
  6. Tried to connect again and it worked.

Not sure what’s going on but at least I can control and monitor activity status from ST now even if it takes a while to update the status.
Looking forward to harmony fixing their side and the integration being a bit more seamless

Had no trouble install Logitech harmony hub follow the instructions above. So thanks for those. Have to say it works really well. Love being able to have the TV swtich on when the “Im back” routine fires.

Strange development in the last few days. Control of Harmony still works fine but previously I was able to rely on Smartthings refreshing the status every so often. This meant I could trigger lights to dim when I switched my projector on by watching the status of the projector activities.
Over the last few days, Smartthings seems to have stopped refreshing the status?
It works correctly when I press refresh on any of the harmony switches.
Anyone else having this problem or help me with a fix?
Is there a way to force a refresh of a switch at a defined interval?

Hi Tom, I experienced this over the Christmas period.Firstly I went into the logitech smart zpp on my phone, unticked my hub and saved the change. then went back in and re ticked my hub in the “Select Harmony Hubs” section and clicked done. Then I re authorised Smartthings access to my hub from within the Harmony app clicked done and it seemed to cure my problems Hope this helps.

I see Harmony have now fixed the issue.
However I am unable to install Harmony Via Market place and the Template does not work on IDE any ideas please


"Re: Integration with SmartThings in the UK
‎01-08-2016 05:18 AM

Dear Harmony Users,

Thank you for your patience! We’re glad to inform you that we’ve fixed this issue. I’d request you to try add SmartThings again to your account and see if that works as expected!
Best Regards,

If a reply resolves your issue, you can help other users also by clicking “Accept as Solution” and “Give Kudos”.

Few important links: Join Harmony Beta Community! ¦ Device Compatibility ¦ Contacting Customer Support

All opinions written here are my own and do not necessarily reflect the views and opinions of my employer."

1 Like

The Harmony fix seems to work in both directions which is good news.

I got the harmony connect all to work. You may want to check whether you have to add a harmony hub device type vias the IDE.

But oauth for harmony in the UK is definitely working.

Can’t find “Harmony” in my app (marketplace). Can you give me some advice where i find the harmony hub in the app? Or should I use a custom device type (which)?


Have a look at Dinos item which is #15 in this thread.

the ide can be found here
https://graph-eu01-euwest1.api.smartthings.com/ assuming your in the UK

Under device types its the Logitech Harmony Hub C2C you need to find add and publish

Under Smart apps its the Logitech Harmony (connect) you need to find. add and publish

Hope that helps

Need some help with this…

What i did was >

1 - Harmony App , add ST every thing was ok, no errors (using UK country)

2 - Using the site ( graph-eu01-euwest1.api.smartthings ) , i have add the template to my SmartApps, and put the OAuth to true.

3 - Using the app ST , Marktplace > Smartapps > My Apps > Logitech Harmony (Connect) , try to enter Harmony Credentials >
{ “error” : True, “type”:AccessDenied", " message" :" This request is not authorized by the specified access token"}

Is there any idea why i’m getting that error?

Update > I have create a USA location, and everything works. I can see my activities, the only down side is that i don’t have any sensors, that i can add to that location.

@TomM and @deano12 is still working for you?

Thank you.

Still no update for this?

You should not need to take step 2. Might be n idea to start again… It should work in the documented way on the Harmony site now

The documented way on the Harmony site (at least the one i have found), its all correct, but the problem is that when you add the ST in the Harmony app, you are redirect to the “graph.api.smartthings.com” and not to the " graph-eu01-euwest1.api.smartthings ".

I have already try to change the country (to uk) on the Harmony app, but it stays the same.

There is a current UK issue reported on the ST status page. I don’t know if it’s related though as it doesn’t provide enough detail re. the affected apps.

Investigating - We have identified an issue authenticating some new devices and integrations that use OAuth. We are currently investigating the cause of the issue and will continue to provide updates accordingly. *
*Jan 25, 16:00 EST

The above ‘issue’ for UK users is now showing as resolved on the status page so if you still have problems unfortunately it looks like it’s something else…

I’m going to try, again…

But Logitech Harmony (Connect) is still missing from the UK.

Yes, you’re right it’s still not there officially - the UK is tediously slow at adding these things , but there were no changes I had to make to the US published versions. I just tried it start to finish and it has worked OK for me…

I added SmartThings to the Harmony iOS app first - selected my ST hub location and then enabled the devices I wanted. That worked OK (although it’s easy to overlook the spinner select for location at the bottom of the screen).

I then added the Logitech Harmony (Connect) SmartApp in the ST IDE ‘My SmartApps’ - enabled oAuth in the ‘App Settings’ and then ‘Publish’ (For me) … and then I did the same for the Logitech Harmony Hub C2C device in the Device Handlers and ‘Publish’ (For me). I did not have to edit either code in any way (for example to change the EU server address).

Then using the ST app via ‘My Apps’ in ‘SmartApps’ I entered my Harmony account details - it authorised (a bit slowly) and then found my hub and my activities (again a bit slowly) which I could then add to ST. My hub then appears as a device using my new device handler in the ST IDE and I have control from ST.

So control in both directions…


I do worry about this maintenance/approval for the devices and apps that appear in the listings on UK hubs. The US ST staff often seem surprised that we can’t see some things that they have available in the US. I’m not convinced it’s well maintained and synched. I’m concerned that lots of things available to US users are just missing over here … for example are there really only two ‘SmartThings Recommends’ apps - SmartLights and Notify Me When ?

Thank you @xAPPO for the info, when i get home will try to do all that.

One thing, when you "I added SmartThings to the Harmony iOS app first ", it did send you to the US site and not the UK, right?

Is it the ST integration within Harmony that isn’t working or the reverse ?

Yes - If I remember correctly it did but it did still authorise OK. But I think it did for you based on comment (1) in your earlier post #29 ? I think that aspect is a red herring. You selected a location OK did you and got the ensuing list of devices back from ST to select from ?

Also later in that post I see you’ve added the SmartApp with oAuth but no mention of adding the accompanying device handler - although you seem to have half succeeded even then which seems contradictory.

Let me know how you get on.



What was missing, “device handler”, didn’t change the urls, just make the steps you say, and no errors.

Do you know how long takes the sincronize, the names of activities in Harmony to be show in ST ? (if change the names or add new activities)

Really Thank YOU!!!

Maybe with some luck (there is a topic talking about that), about the " oAuth " in the Uk server will show more stuff.

My next step is going to be Fibaro FGRGBWM-441 RGBW.

I have this working but since the last update of the hub I get a lot of entries in the live logging continuously
Support said to see if anyone else was reporting this, and also suggested removing Harmony and re-adding, however, its take a long time to get this working I don’t want to stop it now.

Anyone getting these?

843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug Adding subscription

843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug Adding callbackUrl:
843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug addSubscription, params: [appId:843c08c5-4a8b-4508-8c00-346010b5b0bd, param1:subscriptions, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi], request: [attributeName:switch, callbackUrl:, deviceId:cd2fa39b-0051-430e-8825-76682f109e88]