Harmony Hub instability in firmware 4.10.30

remotes
harmony

(Tim) #1

Folks,

I know this is not the Harmony Remote forum, but many of us have integrated ST and Harmony. I’m reaching out with advice that many (on the Harmony Forums) are experiencing home automation control issues on the new Harmony 4.10.30 firmware. Home automation controls (Hue lights, Lutron Shades, SmartThings switches, etc.) have also become very unreliable sometimes they work, sometimes they are delayed by several minutes, sometimes they don’t work at all. I should have followed the mantra, “If it isn’t broken, don’t fix it” But alas, I clicked the dang update button and am now paying the price.

If you haven’t applied the update, you might want to hold off for now and do your research before proceeding. I can find no apparent downgrade option and am working with Harmony support to try to resolve. Unfortunately, step one in their support agent talking script is reset everything and rebuild from scratch. :confused: According to others in the Harmony forum, this has not yielded any results other than wasted time.

If you have applied the update and found a workaround to the issues or haven’t noticed the problems, please do share.


Harmony Hub & ST Dimmer
Harmony hub controlling a fibaro 2 dimmer not turning lights on
Harmony/SmartThings integration - Signing into Logitech through ST does nothing
(Ben W) #2

Thanks for the heads up.


(Dan P Parker) #3

I was just about to upgrade my hub, so I appreciate the warning.


(Michael Hess) #4

Likewise, thank you!


(Chris) #5

I have two lights that turn on with my Harmony activities. One of them stopped powering on, I guess this must be why. I just put them in a group and am now turning the group on with Harmony, seems to be working.


#6

Came looking for this! Too bad I am already on the new version and have lost control of turning on my dimmers, but turning them off works fine!

@destructure00 Will try the group work around and see if that fares any better, thanks


(Chris) #7

The one of mine that quit working was a dimmer too, while the other one that still works is a switch. I used the Trend Setter smartapp to group them both and Harmony sees them as a switch rather than a dimmer, so it seems to work fine so far.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #8

Did you guys try to re authorize smartthings from harmony?


(Chris) #9

Yes. It didn’t help, the switch would still work but the dimmer wouldn’t.


#10

I have updated both of my harmony touch remotes with home hubs to the latest firmware and I have none of these issues, seems to be YMMV here.


#11

Doing a group for just the dimmer didn’t work, guess the trick as @destructure00 pointed out is to combine a dimmer with a switch so the dimmer will work as a switch.

Based on live logging, the commands for ON. Set Level are being passed to ST…But probably not in the right format?


(Marc) #12

I can also confirm the issue is with dimmers, not switches. Tagging @Tyler, @slagle, @thegilbertchan and @jody.albritton, so they are aware of the issue and can hopefully work with Logitech to fix. I am also going to open support cases with both companies


#13

I have the same issue with dimmers. (Fibaro dimmer 2)


#14

Another question for those who have a harmony remote integrated with smartthings. Are you able to sort the lights on the remote itself? I can sort them in the harmony app, but not on the remote.


(Tim) #15

For those interested, the following thread may be useful:

http://forums.logitech.com/t5/Harmony-Hub-Based-Remotes/Harmony-Smart-Control-hub-dropping-out/td-p/1524590/highlight/false

To summarize: One person suggested manually connecting the hub the desktop application and performing a factory reset and downgrade. Apparently losing the ability to sync changes to the remote going forward until the firmware update is again re-applied. I haven’t tried this yet. As Harmony Support Team have now acknowledged the issue, I’m hopeful they will correct and that I won’t need to go that direction.

I cannot yet be certain, but this may also provide a temporary fix to the dimmer (and other device) control issues that many have experienced since the update.

Tim


(Ron) #16

I have my hub on version 4.9.40 and I am having the same issue. So I don’t think the firmware upgrade is the cause.


(Marc) #17

It’s possible this was a problem before hand. I personally never had issues with Dimmers and my hubs until 4.10.30 was released.


(EinarS) #18

Same here, tried different Device Handlers also. Dimers Fibaro 2 is only working for a “switch off” command.


(Automation ) #19

Reading both here and logitech’s forum, someone suggested that updated app is also the problem. I see you do have the prior firmware but looks like you have the latest logitech app.


(Ron) #20

How does the app come onto play ? The ST hub talks to the Harmony Hub, I am pretty sure the app isn’t involved.

It’s all speculation until the ST engineers tell us what is going on.