Official "Logitech Harmony Triggers" failing?

I have been using the official “Logitech Harmony triggers” smart app for a couple of months now. It’s been working fine. This morning, none of my triggers work. If I check the log, it shows the command being sent to harmony, but it’s not being processed and the Harmony hub doesn’t flash the way it usually does.

The same activities work fine From the Harmony button remote or from the IFT TT Do button so it looks like a SmartThings problem.

I put in a support ticket, but is anybody else seeing this?

I just tried initiating an activity using my echo and it worked ok. Also tried pushing the tile from the smartthing app. Last i turned on and off a GE switch from the harmony control

Glad it’s working for someone! Still failing for me. :scream:

Working for me to jd, mostly thanks to your help in figuring it out!

So weird. Worked fine last night, failed this morning. I know, I know, reboot everything, try again. :scream:

Have to wait for my techie aide.

I use it through IFTTT and it works.

Yeah, mine is working through IFTTT, but not the local connection. Same activity.


OK I figured out what happened.

Someone in support (I have about eight open tickets I’m not sure who) pushed some stuff to me.

Among those was a new official smartapp, “harmony control.” Not “harmony connect.”

It looks like this is intended to replace the old smart app “Logitech Harmony trigger”

That smartapp attached itself to my existing triggers. That’s fine. It seems to work OK. It might even just be a re-name of the old app although the screens look a little different.

But here’s the thing, apparently that process signed me out of my harmony Account for the purposes of ST integration, but without any notification that that had happened. So everything was working right, echo was processing the voice request, SmartThings was flipping the virtual switch, SmartThings was sending the activity request to harmony, but because the harmony account was not signed on, the harmony hub never received the activity request. So that’s why nothing was working.

Once I opened the new Control smartapp, found the credentials page, signed in there, and saved it, everything started working again.

So I went four days without voice control of the entertainment center because something changed in my SmartThings account without my being notified of it. That’s not a complaint, it’s just an explanation of what happened and why. And why it might happen to somebody else but not everybody else.

So if anyone else has their Harmony integration suddenly fail, poke around and see if you have a “harmony control” Smart app installed, and if so, check the credentials page to make sure that you are signed in to your harmony account there.

Tim, would be a good idea to make sure support knows that people may have to re-sign in on that specific credentials page. I don’t think everyone’s going to find it on their own.

Also, the official knowledgebase still refers to the “Logitech Harmony trigger” smart app so I really don’t know what’s going on

1 Like

You’re on the super special list, I don’t have that app in the store, only harmony trigger…


Yeah, I have a notification problem with smart home monitor that they haven’t been able to fix for over a month, so support did do some things in my account this week including installing at least one smartapp trying to find a workaround for the notification. So maybe I got some firmware push that accidentally included this control app with it.

You deserve a dedicated support line to make your system run like clockwork for everything you do to help people with their Smartthings problems!

Actually I just bumped into it. If you go under things tab, drill into entertainment category until you get to Harmony hub and then look at popular apps, the new app is there…but I don’t think it’s any different other than a name change.

1 Like

I could be wrong, but I don’t remember having to do a Harmony sign in on the previous version of the triggers app. Just the connect app. But this one definitely has the credentials page and you definitely have to be signed in there.

Yeah, you’re right the names match, the functionality is different. The one I mentioned is identical with the old trigger one (just stepped through it)