Gledopto mini controller gl-mc-001 pairing probs

Hi wise friends.

I have the gledopto mini controller gl-mc-001 attached to a light strip.

I successfully added it to my smartthings hub a few years ago.

However, I recently tried to delete it and readd it.

But now it won’t add. When I turn power on and off 4 times it appears to reset or something like that- flashing purple a few times, then cool white, then warm white. But it doesnt go green and doesn’t show in smartthings when I’m in add device mode. It never adds.

Please help. How can I get it to add to smartthings ?

Were you using a custom DTH (device handler) for it, or a stock SmartThings handler?

If it was custom, then it’s likely not adding because ST has moved away from Groovy based handlers to Edge drivers and there’s no Edge driver available, or the “fingerprint” of that controller isn’t found in an Edge driver provided by SmartThings.

@Mariano_Colmenarejo may have an Edge driver that will work for you though:

Thanks so much for replying.

To be honest i cant remember what device handler i was using, i suspect it appeared as a thing and then i maybe had to select zigbee zll handler in the ide.

The issue now is that i am not even able to get smartthings to find/add it in any form, which i presume needs to happen in order first regsrdless of the device type i end up using ?

Hi @Milomolly ,

You won’t be able to add it until you get an Edge driver for it installed on your hub. If you click on that link I provided above, it will take you to the first post of that long discussion. At the bottom of that first post is the link to @Mariano_Colmenarejo’s channel. Once you enroll you’ll be able to see the available drivers. I suggest installing “Zigbee Light Multifunction Mc” and “Zigbee Thing Mc”. His channel can also be found here:

Once you install those, try adding your device. If the fingerprint is in his driver, you’ll see it show up properly. If not, it will join with the Zigbee Thing driver and show you a bunch of detail he’ll need to add the fingerprint of your controller to his driver.

@Mariano_Colmenarejo , did I miss anything important?


Hi John, thanks, will look into this.

As i didnt have any issue previosuly getting it added to smartthings at least as a thing. Why would i need a driver now just to get it to show up when i sesrch on smartthings ‘add device’ ?

Because you were using a DTH, and now you need an Edge driver. ST has started the migration away from Groovy for DTH’s and SmartApps, which is why you longer can add, see, or delete them in the IDE.

If you removed a device that was using a DTH that had not yet migrated to Edge, and tried to add it back, you’ll now be required to have an Edge driver for it, especially if the DTH you were using didn’t have fingerprints for the device properly set up. In the IDE you could force a device to use any DTH, but you can’t really do that anymore on the updated platform.

This is a very long discussion about the end of Groovy, but it has useful dates, links to other related posts, and should answer many questions about the migration. If you’ve not been up to speed on this platform change, I recommend that you take a look: