Gentle Wake up Smart App

SO ive been struggling with this smart app for a while but today i released why it hasn’t been working. Dtheespite the time to start being set to 06.15 the actual time it starts is 07.15 (as seen in the logs and physically watching it) so its entirely due to daylight savings adjustments. It kind of fits in as its been a few weeks since the clocks went back!
Anyone else seen this??

I started using this SmartApp at first but probably the week before the clocks changed I switched over to using the built in alarm in Philips Hue, because the first step is lower and doesn’t wake me in one sudden jolt like the ST app did…

I can tell you the alarm in Hue works perfectly across the clock changes…


I’ve tried uninstalling /installing this app several times and it never runs for me. I opened a ticket with Support. It did work perfectly before the day light saving…so seems like there is some correlation there.

I set the time to start to 5.15 am in the app and at 6.15 the wake up routine worked correctly. In the event list in the IDE it shows the correct time for the events

I have been using this app (with a Hue bulb) for about 5 months now. Before that I was using a GE link bulb for about 5 months. So far I have not had any major issues with it not working. I have had to change the time by 1 min and reset but that was part of a different problem (bigger issue). Have not had a DST/PST problem…

Set this app up for the first time yesterday in the UK using an Osram Lightify RGVW bulb and @Sticks18’s excellent device type for it.

It did exactly what several people have reported. No activity at 7:15 when it was set to fire, so woke #1 son up the hard way at 7:30.

Wife texts me at 8:50 to say ‘did you know #1 son’s light is on’… Logs reveal it all fired perfectly but exactly an hour late. (2015-11-30 8:15:23.036 AM GMT (2015-11-30T08:15:23.036Z))

The hub was installed before UK DST ended (date created: 2015-10-25 12:57 PM UTC), but the app was only installed yesterday - I suspect this might be part of the issue?

Ohoh and ahah :smiley:
If I go into the specific page for the alarm on the IDE, it lists:

startTime time 8:15 AM BST

This is technically correct, since BST = GMT+1, but:

  • Why is it storing the time as BST, when nowhere else I can find on my system or phone thinks its BST?

  • Why is it then ignoring the timezone?

    Handler Next Run Time Prev Run Time Status Schedule
    scheduledStart 2015-12-01 8:15:23 AM GMT WAITING Daily
    How did that happen, I wonder? @steve_vlaminck?

Was this silently fixed since yesterday morning?

If so, I have a very grumpy and bleary eyed teenager who’d like a word…

1 Like

Don’t think so. Mine didn’t run this morning nor did my good morning phrase :frowning:

OK. That’s strange. I deleted and re-added it yesterday, and the startTime property changed to GMT.

hmm i will delete and re add mine too and see what happens tomorrow. Will do both smart app and phrase

Great news! Its broken again! I have to edit it every night now and change it by one min to get it to trigger now. Timed routines are also broken. Emailed support but haven’t had a ticket response yet.

Good. Not just me then.

Support emailed me back. Its a trending issue and they have a known issue with timed events. They will update me when they have a fix :smile:

I’ve had to uninstall this SmartApp.

I’ve got mine to come on at 7.30 during the week only. It worked Monday and Tuesday last week, and then never worked again. Until Sunday morning where we work both rudely awoken, despite not having set the app to work on Sunday

Yeah - I had the same problem with timed routines. You can check the ‘next run’ time in the IDE …it gets a) confused with GMT/BST so you have to set it an hour early and b) never fires after one or two successful runs - this because the ‘next run’ is never updated and is stuck in the past, the fix is to delete the time of day and then re-add it …all monumentally tedious.

We can put men on the moon (decades ago!) but seemingly still cock-up time zones…however a work around/fix that is stable/reliable is to run your schedules via IFTTT - I have a couple of lights come on/off using this for a few weeks now and been very consistent. Use virtual/simulated switches to control multiple devices from IFTTT. I believe another way around the flakey scheduling is to use the ‘Rules Engine’ app but not tried this yet.

Anyway hope this helps,

And today we’re back to starting an hour late after I reedited and saved the Smart App config.

Ho hum.

Reading through the code, I don’t see anything that would cause Gentle Wake Up to run any differently than other SmartApps. Can you install another SmartApp that runs at a specific time and see if that’s off by an hour as well?

Actually, today it didn’t start at all *wry grin*

I’ll run a test when I’m back home and can observe the result.

So - re-sved the config on Gentle Wake up and it worked PERFECTLY today.

And next run time is correctly scheduled for 2015-12-31 7:00:29 AM GMT.

Will see what happens tomorrow.