Daylight Savings Issue?


(Automate This) #1

I wrote a simple app that just uses schedule to turn some lights off and on at a particular time. Everything seemed to be working fine but the schedule/hub doesn’t seem to have taken Daylight Savings into consideration.

Gentle Wake Up seems to use schedule in a similar way to my app (for the initial event anyway).

Is there something my app is supposed to do to adjust to Daylight Savings?


(Andrew Urman) #2

@mysticeti

We updated everything server side for daylights saving so you shouldn’t bee seeing any issues. For safe measure have you tried uninstalling and reinstalling it?

Maybe something got cached


(Automate This) #3

I tried updating the settings (which does an unschedule before rescheduling the events) but I’ve not done an uninstall.

When you say “everything was updated” would that include even non-published apps?

Thanks.


(Andrew Urman) #4

The update should have worked. You bring up an interesting point of non-published apps though. You should publish it again and see if it fixes the issue.

It doesn’t seem to be effecting the platform globally


(Automate This) #5

Oddly enough it’s working now. I’m not sure if it was my updating the settings (again) or what. I guess we’ll see come Spring time.

Thanks.


(Smuts) #6

Sunset just ran an hour early.


(Bob) #7

If you go into your IDE, what does the sunrise/sunset times say.
Is this correct?


(Smuts) #8

It says 6:48 in the IDE. That’s correct. I’m not sure if it was set correctly 30 minutes ago when sunset ran.


(Bob) #9

Perhaps wait till tomorrow then and see what happens.
EDIT: It might be worth raising a ticket to support to make sure that the server/shard is running the correct time for your location. (If that’s possible).


(Smuts) #10

Will do, though I don’t have much of a choice.


(Chris) #11

What’s the point of a smart home if it can’t even get basic DST right. My apps have been running off all day today. Smartthings please fix this issue. Seems to always happen twice a year!


(Smuts) #12

I’m happy to report that it ran again at 6:58, 10 minutes after sunset as programmed.