GE Z-Wave Dimmer - Smart Lighting not setting level

I just installed a new GE Z-Wave Dimmer with an Aux switch. I can control it as expected (on/off/dim) from both switches and manually via the app.

I added a new lighting automation via Smart Lighting to turn the light on at 20% when motion is detected, but it always just turns the light on the the previous dim level.

Has anyone seen this? Any ideas? I’ve got other switches where this same config works without a problem.

1 Like

Yes, I am having the same problem. This affects GE dimmers and my GE link bulb.

I reported it to smart things and have an open case.

You said set level works with some hardware. Which ones?

Open a support ticket and let them know which ones work and which ones don’t. We might have to do some testing on our end but that information will help us narrow it down.

Done and done. Karl’s on it!

1 Like

How do I request an enhancement?

The idea came out of living with this bug.

So the set level option should be split to 2 options

  1. same as now, turn on and set level to…

  2. NEW option, turn on and LEAVE level as last set in light.

I have some lights to turn on with motion, sometimes it is good to be able to set the level by hand at switch manually by anyone who passes through hallway so next time when someone passes through hallway, smartthings can trigger lights turn on with motion but level is what was previously set.

This is the current behavior due to the current bug, set level is leaving last preset

More info on bug, affects GE and linear dimmers; seems to be the set level command AND when the motion is set to just turn on.

Hi, I have a similar problem as well. I have two different brands of Z-Wave dimmers (GE and Evolve) and when I create a Smart Lighting rule to turn on some lights based on motion and set the dimmer to 20% it always turns on at full brightness.

Interestingly when I create a routine to turn the same lights on with a 20% dim level that always seems to work. So it seems like somehow the dimmer setting works in a routine but not via Smart Lighting app.

Guess I should open a support ticket as well.

They just pushed a new “Smart Lighting” Close App and reopen…You will notice the Icon changed…they must be fixing things as they go.

Yeah, I noticed the icon change just recently but I’m still experiencing the same issue. Actually I just tested this with another app called “Bright When Dark and/or Bright After Sunset” and it works exactly as I expect it to which means it has nothing to do with the actual Z-Wave switches. It’s evident now that there is a bug in the ST Smart Lighting app.

It was a shot, but at least they are fixing issues by pushing updates. Did you put in a ticket with support, I am sure that is where these pushed updates are coming from…FYI, there were issues on other threads and a couple I had, that were fixed in this push update, so they are making progress…

I just sent them an email. I’ll post back here when I get an update from them. Cheers.

So I heard back from ST support. They are aware of this issue with Smart Lights not turning on lights at the specified dim % when run locally. It should be fixed with the next firmware release. I emailed them back to find out when the next firmware is scheduled to be released. Will post back when I hear back from them.

It seems that this issue has now expanded to dimmers that previously worked just fine. My Leviton dimmer that had been setting the level properly is now always turning on to the previous dim level.


My ticket for this got closed without comment earlier today. Is this supposed to be fixed? Someone else just created a new thread about it.

Don’t be worried mine got closed weeks ago, hope that makes you feel better (that you are not alone)

I’m having the same issue… i’m curious if it’s been resolve… i will test tonight when i get home.

Just noticed this bug today as I was configuring my new GE link bulbs. Just had the new firmware pushed to my hub yesterday. I am guessing that that did not fix this bug. Any one else see this fixed after the firmware update?

Hmmmm this works for my GE-Link bulbs, that would be new if it didn’t work.

Same here…20 char worth of data points…


I just setup a new GE dimmer tonight, and tested Smart Lighting rule:

When motion detected, turn on and set level… well the light turns on, but Level is not set.

Anyone have any update on if this is still being worked on… forget about the GE-Link bulbs… I’m wanting this to work for my Dimmer Switches.