GE Dimmers & Hub 2.0 not dimming

Is anyone else having issues dimming GE Z-Wave Smart Dimmers with ST hub 2.0?

Mine all worked perfectly with hub 1.0, but no longer dim with hub 2.0 apps. Looking at the device history there appears to be no setLevel command sent to the dimmer when I have the SmartLights app setup to Turn On & Set Level. ST turns the dimmers on and off okay, but will not set the level.

I noticed that all my Hue and Lightify lights do set the correct dim level and there is a setLevel command. So I added one of the Lightify lights to the same routine as a GE dimmer and use the Turn On and Set Color command (which also allows you to set the level), and it does send the setLevel command and the GE dimmer does get set to the correct level.

I lost all my legacy apps when I upgraded as I ended up creating a new account due to not been able to remove all my devices. So I am using Smart Lights for all my lights.

I did contact support about a week ago, but understandably they are really busy right now. So wondering if this issue is unique to me or if others are having the same problem? Thanks.

Yes, this is a known issue.

Okay, thanks. I did a search but couldn’t find anything about it. Thank you.

I am having the same issue, BUT this gave me an idea for a feature request to add to smart lightning.
Current settings in smart lighting

  • Turn on Full
  • Turn on set level to preset

New Enhancement

  • Turn on and do NOT set level level is set to previous set point set at the switch (Current behavior due to bug)


Sometimes it might be useful to have some automatic action, lets say motion to turn on lights, and the lights go to the level that they were last set at the switch.

So a den, the lights are activated on motion, but if people are watching a movie at night, lower the light level real low so when motion detected lights are low.

Other times if need light very bright, set level to full.

Hey guys,

We located the issue for this yesterday and have started on a fix.

Not sure when it will be ready but we know where the issue is now :smile:


Great news! This has been driving me a little crazy too. Looking forward to the fix.

Any progress on this? Thanks.

Any progress on this?

Any idea when this will be resolved?

1 Like

Next firmware update has half the fix. We found an issue specific to GE Zwave dimmers that will be in the following firmware release but zigbee dimmers will work just fine in this upcoming release. I will try and get a date for this release. I don’t know when it will be out yet.


Very odd that I don’t seen to be affected by this. I installed a ge z-wave dimmer in my bathroom about 3 weeks ago. I have it set to turn on with motion and set level from 5PM to 7AM. During this time I have 3 smart light installs to set at 3 different level depending on time. This has been working fine. I know this doesn’t help, just puzzled that it works for me. Hope u guys get this resolved for others soon.

Thanks for the update. What about Linear Dimmers? Would they have the same behavior as GE Dimmers? Or would they be fixed with the zigbee fix?

Is there any update on ETA here? I’m freshly migrating from a rival platform, but this is kind of a basic showstopper for me. I can’t program my dimmers! :smile: I have Leviton in-wall dimmers that exhibit the exact same issue.

FYI - @mobious posted a workaround in another thread that makes this work correctly. Here are the steps:

  1. Create a virtual switch if you don’t already have one you can play with
  2. Create or edit a SmartLighting rule
  3. Set the light to come on at a desired dim % when the virtual switch is turned on
  4. Test that this actually works correctly and that it sets the light to the correct level. You may need to hit the virtual switch more than once before the light comes on.
  5. Edit (not delete/recreate) the SmartLighting rule to come on via motion instead of the virtual switch. It should still work after this AND set the light to the correct %. Yay!

Thanks @brbeaird - that seems to work!

The app does not appear to run locally with the work around. Anyone else having this issue?

How can you tell? Mine seems to still be running local as far as I know.

Use this link:

Huh. Yeah, looks like the ones I’ve used this workaround on are also not on the local list. I actually wondered if this was the case because I felt those were still running slightly slower than my local ones, but I figured I was just seeing things. Guess my gut feeling was right. SmartThings is so weird sometimes.