GE Plug-in Outdoor Smart Switch - Won't pair through app

Question - Have you ever had a device that you had to manually add to your network because it would not properly pair through the app?

Observation: I could not get the device below to show up in the Smartthings app without adding it manually (see workaround below). I tried multiple combinations of device reset, exclusion, button presses, etc… No luck. While the device was never discovered by the Smartthings hub (classic, v1), the device was showing up in the activity feed after I tried to discover it. It appears that the device was discovered and partially paired. No device appeared in the device list, but I could see its events.

Device: GE Plug-in Outdoor Smart Switch (ZW4201)
Issue: Device won’t pair through Smartthings App
Workaround: After noticing that notifications for the device were appearing in the app, I logged into the graph and looked at events associated with the device location. From there, I was able to determine the device ID on the network and then I manually added a device (Z-Wave Switch Generic) using the correct device ID. This allowed the switch to appear in the app and is working properly.

What did I try prior to discovering the workaround? Normal inclusion failed (set app in inclusion mode, then press button on plug). I excluded the device (this worked immediately on button press), then set the app back in inclusion mode and pressed the button, no devices were discovered. I tried pressing every ten seconds, no change. I reset the device (plugged it in while holding the button for 3 seconds). I moved the device to 2 feet from the hub and repeated all steps, no luck.