Firmware update 45.11 made my Juno Connect lights stop working

Anyone found a solution to make the Juno Connect lights start working again with the SmartThings hub v3? Ever since the 45.11 firmware update the lights fail to connect, and even when I do get them to connect they then forget the connection and show off line. I keep hearing from technical support that “known problem and working on it” but seems like no one is really working on it. Since Oct 25th!! Note to company….those of us that use this stuff with lights use it daily. Not being able to switch a light on for three weeks is kind of a big deal!


I’m sure that’s very frustrating. :disappointed_relieved:

You might also post in the official announcement thread for that update:

Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Hotfix Notes - 0.45.11

I’m in the EXACT situation. Haven’t found a solution yet.

If you’re interested I’ve got a bunch of comments in this thread near the 100ish comment mark

1 Like

Same boat.
Just finished building a house with 70+ wafers. Can’t connect the hub to any of them.
Any chance changing the zigbeee channel in dev options will help?

They had me change channel when first trouble shooting and it made no difference. I got a text update recently saying they are applying a fix now, but have yet to verify it worked 11/25/2022. In the absence of a fix, un-find the lights and connect them by Bluetooth to be able to use them. When it finds them, there is a link that says connect with my phone that will by-pass the firmware part. You still see them in the SmartThings app but just can’t write automations for them.

1 Like

The problem is that the I have 70 lights spread across the house so I would have to be in the vicinity to control them. If I want perimeter lights on then it’s simply not possible due to the distance.
Light groups also get weird when using Bluetooth with 5 or more lights.

Thinking about just changing platforms to another zigbee enabled hub

As a temporary solution, do you have an Echo device with zigbee built in? You could at least get them running, even if not optimal (and i doubt it supports zigbee group messenging).

I started with a google hub but that was only Bluetooth and good for a handful of devices. Then I grabbed the 4th gen echo but it didn’t work right, can’t remember if it was the interface or what, but something wasn’t right. Now on the aoetec hub and stuck with the current issue

1 Like

I’ve been using Juno Connect lights for a few months with zigbee2mqtt. Was hard to get working, then worked well for a while, and now a few lights are unresponsive and I can’t seem to make them work. Since smartthings is the only actually “supported” hub to use with the Juno Connects I figured I’d give them a shot. Just got a hub, trying to connect them, and not succeeding, found this thread.

Any updates on this?

What I’m seeing might be different, or maybe it’s related. I have nine lights on the same circuit. The smartthings app sees all the lights. When I click add it says “Let’s get started” and goes through a few steps. I tell smartthings to connect via my Hub. It asks for a QR code that I don’t have (I guess it’s on the box that is in the ceiling) so I skip that step. And then it gets stuck on a page that says “Install the light and turn it off, then on again.” I don’t know how to get past that step. Hmm…

No updates that I am aware of.
I can tell you that scanning the QR code on the wafer does nothing. I pulled one of mine down and when i scanned it, it gave an error. not recognized or something like that.

You are stuck in the same boat as the rest of us it seems.

Aoetec support was the most helpful but in the end, they said there was nothing else for us to try and we would basically just need to hope that Samsung provides another update

Thanks. Does anyone have evidence that these Juno connect lights can work with the 45.11 firmware? I’m wondering if it’s completely broken or just somewhat.

Juno Smart is not connecting to the hub since the update in v3 hubs.

The Bluetooth connection to the SmartThings app works (no hub used) and there is a software update for the lights there. It won’t help with the hub issue but it makes the D2D (device to device) work as intended.
D2D won’t help with schedules and automations but you can control the devices.

Google works ok but that is limited to five devices per speaker since Google does not use Bluetooth mesh. Great alternative if you have a few lights.

Amazon Alexa home hubs work fine (4th gen. echo, echo plus, echo show, echo show 10). All functions work as intended including grouping, schedules etc. I would recommend making sure you have the latest firmware in the lights by connecting to D2D SmartThings first, then factory reset the unit (five on\off’s), then connecting to Amazon.

1 Like

I just spoke to someone in Juno tech support. Very helpful call. He confirmed that they are aware of the issue and it has been escalated to the highest levels at Samsung. Of course who knows what will happen, but at least that confirms it.

He also told me that the Alexa smart home hub will work for up to 20 devices and is a supported means of controlling the lights.

I asked if there were any firmware updates for the lights and he said no. Interesting that the D2D smartthings connection does offer an update? Good to know.

I’m tempted to try this Alexa hub but I’d also like to be able to connect a remote to the light via Zigbee bindings, and I also like to control things with Homekit. Maybe I’m asking for too much, lol.

I am functioning at 75% as things got “slightly” better. I am told by Samsung has more fixes still in the works. Generally I can open the app and control the devices but the only thing that is consistent is that one or two lights will show offline. I have automations to turn all lights on and off programmed and ones to turn all lights to 50%. Interestingly the automation command works about 99.5% of the time. So with that “group” icon I can always turn all lights off even when some show off line. Other tricks to get offline lights to come on line is is turn the lights switch at the front of the run on and off once or twice. Other times I open the light icon where you can dim and set temperature and turn it off and on from inside that setting area. I will enjoy it when we can talk about this smart technology like we do some others and say remember when back in the day we had too……move the rabbit ears on our tv a hundred different directions to get a static’ee picture.

1 Like

I just wanted to add to this that I am also having this issue. I have over 30 lights I can’t control. It really sucks.

My Juno Connect lights are working again. See this thread for details.

1 Like

Problems back!!! Juno wafer lights will not reconnect to app. It sees the lights but it feezes at “preparing” …“processing”. I have reset the hub, the lights, dont know where else to reset to get the app to find the lights that I have now reset. Is Samsung having server problems?