Fibaro zwave join problems - hub zwave radio problems

So, I’ve been having trouble trying to re-pair/include a handful of fibaro eye ball motion sensors.

I went into the IDE and re-published the handful of device handlers that i have in there.

This still didn’t resolve the problem.

So, is there a way to temp turn on/off each/all device handlers?

What about // commenting // out the whole code of each device handler, one at a time and trying to re-pair/include one of the fibaro eye ball motions.

how are you trying to pair… by add device > scan nearby or add device > by brand > fibaro?

I’ve tried both generic z-wave and fibaro > motion, but not scan nearby.

and you excluded the device before pairing?

yes, but i did notice something interesting in the ide hub event list, when i exclude with the minimote, the ide hub event list is showing that it is excluding a device network ID. so, it appears that it is pairing, but not reflecting that it is which is leading me to believe that i have a rogue device handler.

do you still have other fibaro motion sensors currently paired to your hub?i saw you had another thread on same subject. if you still have some paired… are they using that custom device handler?

yes, a couple of weeks back I was able to re-pair/include 3 and those are still connected, but i have a mix of z and z+ that just wont pair. this leads me to believe that something fairly recently is causing this.

anything else z or z+ that I add pairs

only two thoughts, since i am stuck, is run z-wave repair and reboot your hub. see if there any errors when running repair and that there are no ghost devices.

im going to do that right after i go through the dh and comment them out one by one and try to pair.

something just isnt right and shouldnt a device pair as a ‘thing’ if there isnt a dh (internal or added).

Yes it should, BUT weve also seen the old ‘stale’ dth issue prevent pairing.

Watch the hub event log while you’re attempting to pair the device - what do you see?

The ‘stale’ dth is why i went and republished att for me.

itll show zwave ready, then hubinfo, and then zw radio on. that is all i see until i exclude when it should a network id being removed.

im running a zwave repair right now - it just only showed that it finished without any errors.

Do it while you have the Join active - you should see the hub go ZWJoin ready / searching and also the ZWJoin end… if you don’t see the device try to join between those it’s not communicating properly.

this is what it showes from the exclude thru include timing out on the app.

2021-04-23 12:23:31.000 PM CDT
moments ago
HUB zwStatus ready Z-Wave is ready
2021-04-23 12:23:23.000 PM CDT
moments ago
HUB hubInfo hardwareID:000D, version:17, … hardwareID:000D, version:17, mac:D2:52:A8:17:10:7D, localip:, localSrvPortTCP:39500, localSrvPortUDP:0, zigbeeFWM…
2021-04-23 12:23:21.000 PM CDT
moments ago
HUB hubStatus zw_radio_off Home Hub
2021-04-23 12:23:21.000 PM CDT
moments ago
HUB hubInfo hardwareID:000D, version:17, … hardwareID:000D, version:17, mac:D2:52:A8:17:10:7D, localip:, localSrvPortTCP:39500, localSrvPortUDP:0, zigbeeFWM…
2021-04-23 12:23:19.000 PM CDT
moments ago
HUB zwStatus inactive Z-Wave inactive
2021-04-23 12:21:28.000 PM CDT
moments ago
HUB zwStatus include search Z-Wave include search started
2021-04-23 12:19:21.000 PM CDT
moments ago
HUB zw removed device: CA zw removed device: CA zw removed device: CA

I just IDE rebooted the hub and it came right back online.

they all joined almost immediately to another hub. this tells me that something might be wrong with the zwave radio on the current hub.

Have you tried a power off reboot of the hub?

I had a similar issue a few weeks back after a hub code update and an IDE reboot didn’t help.

I havent tried that yes as I have around 300 devices connected and dont want to lose anything just yet.

so, to soft reset I can just disconnect the power and plug it back in or do i need to briefly press the recessed button with a paperclip and then plug back in?

No, just remove the power for 10 seconds so all the lights go off. This should be just enough to allow the hardware to reset without your devices panicking they cannot see the hub.

so, i did this a couple of times, but it didnt fix the problem. though it did cause about 20 zwave devices to go offline, but they came back online after a little while.

it appears that its time to change/divide devices across multiple hubs. this is a v2 hub 200 from around '15 and the second time its done this type of zwave behavior. same as last time around 300 devices during firmware updates.

so, i have access to various v2 200/250 v3/aeotec hubs. i was thinking about spreading out the 300 devices across multiple hubs. say put the water leak sensors and smoke alarm detectors on one hub. motion detectors on another hub. contacts on a different hub. outside mailbox, yard motion sensors, gate contacts on their own hub. this way it would balance out the load and then something goes rogue hopefully it would be less to reset at a time.

something else to keep in mind is where samsung is going with smartthings and their own sensors vs. other brand sensors. might need to put all the smartthings sensors on their own hub eventually.

Sorry it didn’t fix it. I did not pick up that your network was quite that scale. Various sources state that a Z-Wave network can consist of up to 232 devices. So if 232 is the max then likely the practical limit could be considerably lower depending on the mix of devices you have and how chatty they are. It could also be that some of the Z-wave devices on the network are less able to handle the scale than others. Maybe breaking it up would help.

Guys if you are interested: