Fibaro smoke sensor not reporting temp

hubv2

#1

I´ve got 3 Fibaro smoke sensors. I´ve set temperature reporting interval to 5 minutes and every 0.1 degrees on all of the smoke sensors for testing.

One of the sensors is never reporting temp, even if I move it outside where there is a 20 deg C difference from inside, its not reporting the change.


Fibaro Smoke Sensor FGSD-002 EU - Not reporting temperature
#2

Hi, did you manage to get the issue fix, I faced similar issue as well


#3

Yes, the config within the app is not working. I had to go into the IDE and create a new device type to be able to use the simulator. There you can press the configuration button to force it to take the configuration. Press the config button and the button on the smokesensor three times right after to wake it up and it should update the config.


#4

Thanks for your reply, may I know which device type you are using?


#5

Just use the standard fibaro smoke sensor (from template)


#6

unfortunately, mine doesn’t work :frowning:


#7

What exactly is not working for you? After creating new device type you must install the simulator to the unit you are trying to configure


#8

In the app, the smoke sensor show the word “CLEAR”, but “–” for both temperature and battery(?), it has been there for a day.

How do you “creating new device type & install the simulator”?


#9

Have you tried tripple clicking the button on the sensor to wake it up?


#10

Yes, I tried that. I also removed it from ST, reset and re-added into ST.

May I know your version of the sensor? I suspect mine was on the latest firmware that need diff handler.


#11

Go to IDE

Click on My Device Handlers

Click Create New Device Handler

Click From Template

Select Fibaro Smoke Sensor and create

From the simulator on RH side, select your location and the device you want to configure

Triple click the button on the smoke sensor and click the configure button on the simulator, if you also have a tab with live logging you will be able to see if the configuration is sendt and received


Fibaro Smoke Sensor FGSD-002 EU - Not reporting temperature
#12

I got this error, pairing problem?

d8c03317-c0ae-4be5-9ee6-5352550f994a 11:56:40 PM: debug Fibaro smoke sensor not sending configure until secure
d8c03317-c0ae-4be5-9ee6-5352550f994a 11:56:40 PM: debug configure() >> isSecured() : false
d8c03317-c0ae-4be5-9ee6-5352550f994a 11:56:08 PM: debug Updated with settings: [smokeSensorSensitivity:High, zwaveNotificationStatus:all notifications, visualIndicatorNotificationStatus:all notifications, soundNotificationStatus:exceeding temperature threshold, temperatureReportInterval:30 minutes, excessTemperatureSignalingInterval:null, lackOfZwaveRangeIndicationInterval:null]


#13

@Tyler need your advice here


#14

Are you getting an error during pairing about Secure Inclusion not completing?


#15

Where can I see the pairing info?

So far I tried to un-pair and re-pair the sensors for 3 times. I do noted when I add the smoke sensor, the add things process alway not showing the sensor found but after I cancel it, I can find the sensor added.

I noted the z-wave finger print is different from the one in the handler, and that result in SmartThings already pair it as"z-wave sensor", and I’ve to manually change the device type in IDE.

Separately, I duplicated the Fibaro smoke sensor handler and updated the finger print, then SmartThings able to use the correct handler during the pairing, but I still can’t see the device info in the app.


#16

This was probably causing the Configuration issue. If the device doesn’t pair correctly we can’t configure it correctly.

If you use the DTH with the updated fingerprint it should pair AND fingerprint correctly.

In the events list for the device or the hub do you see Secure Inclusion failures around the time of the pairing? Either way, it might be helpful to try pairing within 5-10 feet of the hub.


Fibaro Smoke Sensor FGSS-001
#18

I removed and added the smoke sensor again, placing the sensor next to the hub.
From the log, seems like ok but I still see “–” in the app.

I also went into the app config, set the settings, done, and press the B button right after.


#19

Can you click on that “zwjoin” event and share a screenshot of that event detail page?


#20

Thanks for following up. Here you go:


#21

Can you confirm the exact model number?