Fibaro Smoke Sensor FGSD-002 EU - Not reporting temperature


I have two Fibaro smoke sensors (FGSD-002) that have been successfully paired with Smartthings hub. However, the smoke sensors do not report temperature like they should. I have tried to change reporting interval to 5 min and report hysteris to 1 degree, but nothing happens. This thread suggests that I should run a simulator to get the configuration downloaded correctly to the device: Fibaro smoke sensor not reporting temp. Doing that the log seem to show that the configuration has been downloaded to the device correctly, and the temperature is read at the point of configuration, but temperature reporting still does not work as expected.

Have anyone experienced something similar and any ideas on how to fix this?


I’ve just added a 2nd Fibaro smoke sensor (FGSD-002) which prompted me to notice the same issue with temp reporting with with both of them. Can’t find any solution yet.

I notice this every 5 mins in the logs, the interval for temp reporting is set to 5 mins;

 warn General zwaveEvent cmd: Crc16Encap(checksum: 64796, command: 5, commandClass: 49, data: [1, 34, 0, 206])

Many have reported the same issue. It’s likely because of the handler not being able to set the configuration properly. Everyone, please send a ticket to Smartthings support so we can pressure ST to fix this issue

The preferences in Smartthings device list shows that the configuration should be set correctly:

Following info on another thread, I did the settings via the simulator, which appeared to work.

I have tried an experiment. I briefly loaded the Fibaro motion sensor DTH onto this device. During this short test it did report temperature correctly twice. I think it’s how the DTH processes the event from the sensor but I’m limited by my knowledge of the coding involved as only got ST a couple of months ago.

I have emailed support about this issue. Will update on reply.

Just read this post a checked my smoke detector.
No reports in my recently tab so it looks like mine is the same.
Will be interested in what ST has to say.

Reply below from ST support. Somewhat disappointing if I’m honest.

Thanks for getting in touch.

I’m so sorry that you’re having issues with your Fibaro Smoke Sensors.

This is a known issue and our engineers are looking into it. A problem ticket has been raised for the problem.

Unfortunately, at the moment I can’t offer an ETA on when the issue will be resolved.

I offer my apologies for any inconvenience this has caused and I ask for your continued patience with the matter. smiley

If you have any more questions, please do get back in contact.

It is interesting that one of the most popular smoke detectors does not work (temp) with SmartThings even if it is on the supported devices list. I have five of those and is experiencing the same problem. SmartThings firmware is 17.13
Waiting for a solution that is working.

Moving from Domoticz because i wanted something that works out of the box - so far it is not going well.

I agree, they clearly say it works with ST then support tells you it doesn’t after you’ve paid out for them, that’s not on guys. Maybe everyone who is experiencing this issue should raise a support ticket then they might give it more priority to get it fixed.

Yeah same problem here - bought it as i didnt need the carbon monoxide checker which comes with the nest, and this was supported. This should be fixed as its fairly crucial to ensuring the safety of ones family!

Wow, was just about to buy these - I think it best if I put that one on hold.

I can’t understand how they claim they don’t support these anymore:

Well dang it if isn’t working now. I had almost given up. If it stays working I will get some more. They are a nice piece of kit.

I can confirm mine is now reporting temperature sensor - will keep an eye out and post back with testing - Last issue besides the temp reporting was the turning the alert off one you have tested - anyone else have this issue - ill test and report back

Great to see this finally working!
Thanks for posting it in this thread and reminding me to check the reporting interval, had set it to 5 mins when testing this bug and dont want the battery to go dead in a few days :slight_smile:

Hi, this is really not working yet. I tried everything and none of my six Fibaro Smoke alarms are not reporting anything automatically to hub.
First of all it is recognized as Flood sensor at the beginning. Then I change device from IDE to Fibaro Smoke Alarm. When trying to adjust settings it seems like everything goes like planned but instead it’s not working at all. Information of temperature and battery is only updated to hub when pressing button one time in smoke alarm.

Log says:
[2018-08-27 5:42:08.626 ip. EEST
*hetki sitten-> means just a moment ago.

Notice that name in log file is “flood sensor” like ST hub thinks it is. I didn’t change the name but device that I use “Fibaro smoke alarm”.
Any ideas. I’m getting mad…

I have 2 of these working as expected. When I originally installed them I had to add a DTH. A month of so after, the ST team updated the embedded driver so I deleted mine and switches to that. I have been using it for over a year now with no issues. It’s the “Fibaro Smoke Sensor”.

Did the smoke detector include in secure mode? You should see something like “zw:Ss type:0701 mfr:010F prod:0C02 model:1002 ver:3.03 zwv:4.05 lib:03 cc:5E,86,72,59,73,80,22,31,56,98,7A sec:20,5A,85,84,71,70,8E,9C role:06 ff:8C01 ui:8C01” as the raw description on the device page of the IDE.