RESOLVED: Unable to add fibaro smoke detectors to Smartthings V3 (EU)

Hi, I purchased 2 x V3 hubs and a lot of sensors.
Then I tried to pair fibaro smoke sensor (fgsd-002, v3.3).

Smartthings just keeps on scanning. I tried repair z-wave network, I tried exclusion (hub says it excludes), I tried disable and enable radio, I tried rebooting, I tried resetting smoke sensors.

I also tried classic app.

Note: in logs I see a zwave join event, but then nothing more. If I login via webpage and try Add new device button, I get an 500 internal server error.

Hi, same here. I just noticed that same internal server error 500 -thing in my IDE. Can’t basically do nothing at the moment.

One of my Fibaro Smoke Detectors lost connection with the hub after a complete battery drain. I have been trying for 2 months to get it connected again. (Ver 2 Hub; both old and new Smartthings apps).
I have about 10 of these detectors and in general, my experience have not been good with these devices. (I have tried numerous DTHs.)

Tutorial for fixing:

  1. Enter Smartthings API page for your Region (EU, US, etc)
  2. Copy code from “FibarGroup : Fibaro Smoke Sensor ZW5” ( https://raw.githubusercontent.com/richb1/FIBARO-Official-SmartThings-Device-Handlers/master/FIBARO-%20Smoke%20Sensor ), also found under https://github.com/richb1/FIBARO-Official-SmartThings-Device-Handlers.
  3. Paste the code into a new device handler on the API pages (device handler>create new device handler), click save and publish (to my self).
  4. Now add your smoke detector, if you are having issues with this step, please check at the end.
  5. When it’s added it will say 0% battery etc. So you have to find your device in the api pages under devices, now click edit in the lower bottom left corner.
  6. In the dropdown list “Device type”, scroll all the way to the bottom and you should see your device handler.
  7. Choose the correct device handler found in step 6, click update.
  8. confirm you now see temperature etc. in your device.

Troubleshooting:

  1. Try to add the first smoke detector near the hub.
  2. Try to go into your hub via your app and choose tools>z-wave. There you can both repair z-wave network and forget device.
  • Forgetting the device will mean you have to quickly triple click the button on the smoke detector while the hub is in this mode.
  1. You can also try to reset the smoke sensor, hold the middle button to you see a led. When this turns yellow/orange, just do a short click.
  • after this it should make a sound and blink a red led. You can do one short click while orange and one right after to make sure youre not clicking too late. One too many is ok.
  1. You can try a reboot of the hub
  2. If all above fails, in the api pages try to go to My devices>+ new device. If this fails with a code 500, it most likely means the issue is not in your building but in the cloud.

There will be a status page update about this shortly, but this issue joining devices and manually creating devices in the EU should now be fixed.

1 Like

Thank you @Olavxxx. I’ve tried all your suggestions many times over, without any luck.

I haven’t tried in the last 2 weeks. Will try again in view of @tpmanley’s remarks and report back.

Two hours later: :hot_face:
I’ ve tried every possible process to include the sensor. (Sensor within 5 cm from the ST hub: Resetting the device; doing excludes in the old and new Smartthings apps; resetting the sensor again once inclusion mode has started; removed battery of the device etc. etc.)
After about 45 minutes, I managed to include it with the new ST App. The sensor was listed as a “Z-wave device”. Changed the DTH but could not get the sensor to configure. Eventually noticed that the sensor did not include in secure mode:


I excluded the sensor again and reset it as well to make sure. Started the process again and only after another half-hour, managed to get it to include again (using the net ST App)
Unfortunately, it once again failed to include in secure mode.
I tried to configure it using various device handlers, but it fails to report the temperature.
I left it for an hour and so far, no new reports from the sensor in the IDE log.
I had since noticed that one of the other Fibaro Smoke sensors had also stopped reporting data (the last report was with the battery at 100% - can’t see when the hub received the last report.) I tried to wake it up by pressing the button, but that did not help. Also tried pressing the button for 3sec. Nothing. (I suspect it last reported soon after I had replaced the battery about three weeks ago)
I have 4 of these sensors at my holiday home as well, so I checked if they are still reporting. Two of them show “Offline”, and a third last checked in 12 hours ago. (I replaced the batteries of all four the last time I was at the house two months ago.)
Think my time with these sensors has, for now, come to an end.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.