Fibaro smoke cannot connect to Smartthings


I have bought some Fibaro smoke sensors ( FGSD-002) in the past. I had no issues connecting them until know. I pressed the B button three times (also tried 2x3 presses).
But the classic or new Smartthings app cannot find them. They are very close to the hub. Also reset them several times, but no luck. Nothing to see on the EDI smarthings.

Any ideas?


If you are using a custom device handler…

Login to IDE, open the device handler(s) and save/publish them again. Then try adding the device(s).

Tried, but without luck.
I had also set the other smoke detectors to use the standard Fiabro handler and then add them, but no improvement.
If I check the connection (with purple light) it turns green. So shoulb be in connection with hub.

I forgot to add, you may need to perform a z-wave exclusion on the device

Which app are you using? Classic or STSC?

Found it, restarted hub by removing the power, repaired z wave network. Seems that did the trick. Can connect them now. Thanks for the help jpk