Fibaro Smoke Sensor FGSD-002 EU - Not reporting temperature

Now I removed all six sensors. Took one and tried to pair it. This time hub found Z wave door/Window sensor… (?) I checked secure mode thing you asked and yep there’s long pattern of stuff. Didn’t past it all cause don’t know if it’s something that shouldn’t be shared public, but beginning is like this:

zw:Ss type:0701 mfr:010F prod:0C02 model:1003 ver:3.03 zwv:4.24 lib:03

EDIT:

I tried to change correct device handler: Fibaro Smoke Sensor
Result of it is:

Aaarghtt… …"#¤%&¤"/("#(**¤%)(%()#)=… u know…

Tried again and behaviour was “normal”.

If looking events it show very good when it’s flood sensor…

There has to be something wrong between device handler and these sensors. Are my sensors somehow newer version or something and that could be the reason for not showing as smoke sensor.

The zw:Ss is secure mode, so that’s OK. You do need to use the smoke sensor DTH. Just make sure you don’t have any custom DTH for the smoke detect in your IDE. Then go into the device on your phone and set all the settings. I have mine as Medium, disabled, disabled, disabled, 15 minutes, 10, 55, 5 minutes, 30 minutes. Save these and you should see two lines appear in the log. You then need to get the config updated on the device. To do this just hit the button on the front once. You should then see a bunch of stuff appear in the log, including several lines that have “Sending secured command” in them. After this it should update OK. As you see above, I have my temp report every 15 mins as this has an impact on battery life. You may want to reduce this initially .

At night sensor was able To do 2 successful reports with ST. At 3am and 4.17am…nothing To do with 5min reports settings I configured.
I tried now your settings and event log says again Entity_update DeviceUpdated -> false.
In IDE it shows that there id right settings but for some reason configuration is not correctly done.
So devices seems To send information To hub but not how settings are supposed To be. I do not undestand what is the temperature report interval if traffic was 23pm then 3am and then 4.17am. Time is now 7.15am and nothing has been automatically send From sensor To hub.

Can you post a section of the live log for when you save the settings the app and then press the button on the smoke sensor?

I got them working.
Default Smartthings Fibaro Smoke Sensor device handler in IDE is not correct and should not be used with FGSD-002 EU sensors.

Found this link:
https://manuals.fibaro.com/knowledge-base-browse/st-handlers/

There was link to official Github:

Which includes “Fibaro Smoke Sensor” (updated 6months ago)
Went and checked device handlers code and it was quite easy to notice that it’s different than the default “Fibaro Smoke Sensor” in IDE.

Copied new code and created new device handler. Then one more time full reset all sensors by pressing sensors middle button 3 seconds, when yellow light -> pushed shortly again. Red flash and sensor is reset.
Then normal way added new device from mobile phone and pressed sensors middle button three times to achieve pairing mode.
Shortly sensor was found and it was recognized as “Fibaro Smoke Sensor ZW5”. Now this is different information than earlier when sensor was just found to be as "Fibaro Flood Sensor(?).

Gave device a suitable name and then saved it. Went to device information from mobile app and pressed sensors middle button one time. Sync started and soon temperature and battery level was shown.
It’s important to do that button press before changing settings. I you do not press button one time before configuring settings sync will never success.

So finally I went and configured sensor settings and pressed save. After that middle button has to be pressed once again so that new configuration is synced to sensor.

Made a ticket to ST and just sent them email if they should update default device handler for Fibaro Smoke Sensor. Thanks Simon for you help too!!

Glad you got it working. This is interesting though as mine are working with the standard DTH. When I originally installed them I was using another DTH and I recall issues getting the temp working.

I recall seeing the standard one had been fixed so I switched to that. Maybe the fact I had installed under another DTH is what allowed the standardise to work. Who knows.

I use this DTH for the sensor and it appears to be working well. It allows some other settings compared to the one you linked below. Have been using it for about 6 months.

Tested that too and didn’t work. There might be some issues between the sensor models. I have 0003 and your DTH is marked for 0002.
I think my handler is missing led settings which can be adjusted in Fibaro Smoke Sensor DH.

Has anyone tried real smoke test with Fibaro?
Selftest says everything is ok. I smoked some candle under the sensor but couldn’t create an alarm. Don’t know if there wasn’t enough smoke cause my alarm level is set to “medium”. Found one smoke test video from youtube and there was lot more smoke but sensor did not alarm at all. Anyone made a successful smoke test yet?

Another thing. Sensor reports if there’s temperature changes in x amount of minutes. What happens if smoke triggers alarm. Should sensor immediately send alarm to smartthings hub or does sensor wait x minutes that temperature polling happens?

You cant smoke test with a candle. You need a proper smoke test pen - you can get them online or in a good DIY shop or plumbers merchant

I couldn’t find Richb’s device handlers topic so I’m asking here.
Is there a way to add new settings to device handler. It would be cool if there would be possibility to broadcast alarms to sensors, and it would be cool to set led settings too.
Red the manual and it says about broadcasting:

“13. Alarm broadcast
A value other than 0 means that alarms are being sent in broadcast mode, i.e. to
all devices within a Fibaro Smoke Sensor’s range.
Available settings: 0 - 3
0 – broadcast inactive
1 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) active;
casing opening notification broadcast (3-rd & 5-th Association Group) inactive
2 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) inactive;
casing opening notification broadcast (3-rd & 5-th Association Group) active
3 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) active;
casing opening notification broadcast (3-rd & 5-th Association Group) active.
Default setting: 0 (broadcast inactive)
Parameter size: 1 [byte]”

Could this be possible to add?

You can use Z-wave tweaker to do this. Change the device handler to Z-wave tweaker. set the option and then change it back to the smoke detecter.

Oh wow! Haven’t heard anything about Z-wave tweaker. I’m going to check this one out ja report if success (or not).

Ok, so my Fibaros might need an fw update before those settings can be found. Does anyone know how to update Fibaro smoke sensors without Fibaro gateway. Is it even possible?

Hi. Something weird happened monday. One of the Fibaro smoke sensors was not reporting “woke up” or temperature readings to ST hub. Made a Fibaro sef test and I got it back reporting data to ST hub. It syncs reports once in hour (or two, it depends)

Today I noticed that all of my Fibaro smoke sensors are not reporting anything to Smartthings hub anymore. There’s no special point of time that they all went off. Logs says one of them dropped at 11pm. Rest of the sensors at some point at night. Also that first one which earlier dropped off dropped off again.

Smartthings doesn’t say that they are “unavailable”. They seem to be in clear state, but my simple device viewer smartapp sent messages that they haven’t reported anything after night.

Is anyone else experiencing issues with Fibaro Smoke sensors. If I remember right these sensors were “works with smartthings” devices. Now I’m trying to find them from the ST list but they are not there anymore. Some of you guys and girls are using original DTH and year ago I had to use Richb1’s device handler because I couldn’t get these work with original hander.

One thing that might or might not be important is that on last sunday I broke my Zipato z-wave siren. Usb plug was broken so device was left on with battery power. Logs says that Zipato was unavailable at 6:03pm (battery run off). First smoke sensor dropped off at 6:30pm on that same day. Could it be that all my smoke sensors are somehow tied to that one z-wave siren (originally ac powered)? This sounds weird but time seems to be near enough to make me wonder. I did also z wave repair and it went through but it gave one error: Zipato “Mesh point couldn’t be …something”. Well device is offline but has it something to do with my smoke sensor problem.

I have two of these and they are working well, reporting temperature, etc. I am using the original DTH, although during the setup I did use a different handler. Something was fixed in the original one and I now use that for both. The only issue I have found is one of my smoke detectors drained its battery quite quickly a few days ago. Looking the history this sensors used up the previous battery faster than the other one, yet the config of both is the same. Maybe its just due to the position in my house.

Thanks for the comment. I’m going to test original DTH when I get home. I update my situation later.

Everything is fu***. Changed to original handler, configuration and secure is true but it won’t woke or read temperature automatically. Only by pressing button it sends something to hub. So we are back in same situation than year ago. Last time I found right device handler (ZW5) from richb1. Now it’s gone and I managed to destroy that device handler from IDE.

I heard that Fibaro chaos is solved. That did not help with smoke sensors. Can someone confirm what settings are you using if you take a look IDE.
Mine is:

Name Type Value
paragraph
paragraph
paragraph
excessTemperatureSignalingInterval enum null
intervalOfTemperatureReports 30
lackOfZwaveRangeIndicationInterval enum null
smokeSensorSensitivity enum Medium
soundNotificationStatus enum all notifications
statusNotification 3
temperatureReportHysteresis number
temperatureReportInterval enum 1 hour
temperatureReportsThreshold 6
temperatureThreshold number 55
visualIndicatorNotificationStatus enum all notifications
zwaveNotificationStatus enum all notifications

Do you guys have same amount of settings to configure. Mine has some empty lines and there seems to be double temperature report lines:

  • temperaturereportinterval
  • intervaloftemperaturereports

Is there something weird in my settings. Im now trying to use original Fibaro DTH. I did some electricity changes in my home and I took hub offline for couple of hours. After I got it back up and runnning log shows that all my smoke sensors are now online. Still they do not send temperature reports in 30min or in 1h settings. One of the sensors has reported temperature yesterday at 2pm. One of them at morning. Is this how it is supposed to work, so it’s not doing it’s normal “device woke up” once per two hours and reporting temperature.