Fibaro Single Switch 2 no longer responds to status (January 2020)

please fix this for fibaro single switch 2. There are so many of us waiting!

Hi guys so this a video of what is happening to my smartthings setup with my fibaro single switch 2 devices

1 Like

I have the same problems with FGS-213 v.3.2.
Does not work with any available DH.
Have you found a solution?

@Mati_Ruutel, This is what you are looking for then,

Unfortunately, I still don’t work.

Can you post what you are seeing in the IDE’s Live Logging when you toogle the switch from the app and/or physically?

Thanks! The switch works.

1 Like

Both of my single switch 2 have the same problem. Has it been fixed now?

Ironically, Amazon Alexa app works fine for this device, I can toggle on and off and see status correctly

Same here (except the part about Alexa control working) - my Fibaro Single Switch 2 dropped offline on 2nd July and hasn’t worked since :frowning:

Hi ST Community,
may I ask for newbie help? I unpacked the smarthings box tonight and successfully connected the fibaro single switch 2. yey! I had switch on the light, used the app to switch it off, worked fine and could never turn it back on (status remained on, app said ‘a network or server isse occured. Please try later’). A quick googling brought me to this page, but being brand new to this field I’m not able to use the great advice shared here. Would someone mind pointing me to the right direction to solve the issue?
Thanks!

I had the same problem. The DH in item 109 above by GSzabados fixes the problem with mine. See [FAQ: An Overview of Using Custom Code in SmartThings (SmartThings Classic)] for how to do it…

2 Likes

Thanks - that’ll help me get started :slight_smile:

I’ve been experiencing some weirdness with my Single and Double Switches in the new app.
All the devices use the old DHT’s from the classic app and I’ve done nothing to migrate them over to the default DHT’s provided by Samsung in the new app.
Has anyone changed or excluded/included the devices to the new handlers? Is it worth it?
I ask as they are behind the wall and will take a few hours to get them out and reintegrated.

thanks again for pointing me in the right direction. I was able to install GSzabados DH, and make it work. But to switch it on I have to press twice in the app. And the Fibaro Button I want to use with it can only switch it off - not on.
Again, does anyone has an idea on how to fix this ? I don’t mind pressing twice to switch it on of course, but was hoping to use the button for it.
Thanks

As I said before current solution for SingleSwitch is:

  • go to groovy environment
  • find your single switch
  • change DTH to standard samsung provided DoubleSwitch
  • in the phone app delete DoubleSwitch USB device
  • use as ususal
1 Like

I bought my Fibaro Single Switch 2 a couple of months back and I also bought some 2 years ago (which are on different firmware). Recently the new one has stopped working as I think something has changed in ST. I remember initially when pairing it (as its a different firmware) I had some issue and now no matter what I do, it will not work. The other older ones work fine, just sometimes they show a delayed response.

After spending 3 hours yesterday standing in the kitchen trying to get this to work, I have got to the point that I don’t want to waste more of my life to trying to fix something that ST has broken, and I can’t even report it to support as when I email them to raise a ticket, I don’t get any response. So I think I will swap this Fibaro with a Zigbee Switch Module\controller as I need it for my underfloor heating and the replacement needs to take a high amp load, and winter is coming ! :slight_smile:

1 Like

Hey,

I have 3 Fibaro Single Switch 2 ZW5 that worked very well with Classic app but stopped working after migrations. It usually reports status (On/Off), often switches the light Off but never On. The light works well with momentary physical switch. No wiring has been changed - just migrated to new app.

  • networkSecurityLevel: ZWAVE_S0_LEGACY
    zw:Ls type:1001 mfr:010F prod:0403 model:1000 ver:3.03 zwv:4.24 lib:03 cc:5E,86,72,59,73,22,56,32,71,98,7A sec:25,5A,85,70,8E,60,75,5B secOut:26 epc:2

Logs show: Received a multichannel event from an unsupported channel

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:59 PM: warn Received a multichannel event from an unsupported channel

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:59 PM: debug Bedroom Light - Bedroom Light - Parsed MultiChannelCmdEncap MeterReport(scale2: false, scale: 2, rateType: 1, precision: 1, meterValue: [1, 199], deltaTime: 0, meterType: 1, size: 2, scaledPreviousMeterValue: 0.0, scaledMeterValue: 45.5, previousMeterValue: [0, 0])

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:59 PM: debug Bedroom Light - Parsed: MultiChannelCmdEncap(destinationEndPoint: 0, parameter: [33, 50, 1, 199, 0, 0], sourceEndPoint: 1, command: 2, commandClass: 50, bitAddress: false)

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:59 PM: debug Bedroom Light - Parsing: zw device: 2E, command: 600D, payload: 01 00 32 02 21 32 01 C7 00 00

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:56 PM: warn Received a multichannel event from an unsupported channel

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:56 PM: debug Bedroom Light - Bedroom Light - Parsed MultiChannelCmdEncap SwitchBinaryReport(value: 255)

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:56 PM: debug Bedroom Light - Parsed: MultiChannelCmdEncap(destinationEndPoint: 0, parameter: [255], sourceEndPoint: 1, command: 3, commandClass: 37, bitAddress: false)

[17a9f977-f326-4139-96ad-91cc950610e4](https://graph-eu01-euwest1.api.smartthings.com/ide/logs#17a9f977-f326-4139-96ad-91cc950610e4) 7:17:56 PM: debug Bedroom Light - Parsing: zw device: 2E, command: 600D, payload: 01 00 25 03 FF

This has worked perfectly for me

Huge thanks @SYL

I have been using your fixed DTH since you released it. I installed another Fibaro Single Switch 2 this week, and was really surprised that the problem reported in January is still not fixed. Almost a year, and no action from Samsung - I am so not impressed. It should also be made local!

2 Likes

Hey, all.
Thanks for the tips regarding the issue of Single Switch 2 not responding properly. I have just bought one with a date of 22nd November 2020 on the box and running firmware v3.03, and experiencing the same issue.
I can’t believe this is still a problem!!
I’ve switched to the Double Switch 2 and deleted the additional channel, and it’s now working as expected.
This should be fixed, and should be made local as well! In my opinion, Samsung should remove their ‘Works with SmartThings’ badge until this is done!

I’ve got to be honest, I’m pretty much done with Fibaro and will be looking at alternative providers for the future. I bought this single switch with the intention of using S2 for a 3 way switch set up (like you can do with the Dimmer 2), only to discover that S2 is just for sending scenes (which incidentally, has its own set of flaws). Their kit is way too expensive to have problems lasting as long as this.

Any suggestions for something similar (Dimmers and Switches) that work well with SmartThings?
Thanks