Edge Drivers Z-Wave+ for Homeseer WD/WS100+?

I’ve got a significant investment in my house, consisting mostly of HS-WD100+, HS-WS100+, and HS-WA100+ switches (40+). I’ve been combing the forums for some time, and seem to be SOL when it comes to finding anything that would give me hope an actual Homeseer driver appearing in the new App. So has anyone found a generic Z-Wave Edge driver that they’ve gotten to work? I had previously run with Darwin’s DTH groovy code with the pleasure of the Multi-Tap functions for single, double, triple tap and hold. However, at this point I’d be happy with the dimmer and on/off functionality.

I still hold hope that ST will release a generic Z-Wave/Z-Wave+ Switch/Dimmer driver, but in the meantime I thought I’d ask if anyone has found a solution for the Homeseer 100 family of switches. I’m sorry if there’s been a post about this, but my Neanderthal search attempts have come up empty.

For the record I have tried to add the Generic Z-Wave device. Interestingly, it says it added it, but when I look to see the room I added it to, no device is found. To add insult to injury, Alexa notification appears and I can control the dimmer for my Alexa app, but not ST app, as it is not found. I also tried the GE Z-Wave, with similar results.

Lastly, not really germain to these switches, but more to the frustration of the new app, I have tried to add out of the box devices like my Ecobee 4 w/Alexa and my Ring Door Bells and Cameras. I experience the same shenanigans with the device saying it was successfully found and added (connect to the ecobee and Ring accounts) to the appropriate room. However the devices never get listed any where, but Alexa now says it discovered a new device and I can control them from Alexa App and using my voice commands.

Don’t know what to think, but it is a wild ride for sure. If you’re curious I’m using a US-V2 Hub and Android App (latest release on the Play Store) on a Samsung S21 FE mobile phone.

1 Like

I haven’t seen any drivers for Homeseer switches. ST does have a generic zwave-switch driver in their beta channel though, which I expect will give you on/off/dim, but no configuration or multi-tap. Your switches should match that driver using one of the generic fingerprints. I’m not sure how easy/possible it is to get a device to pick up an edge driver using a generic fingerprint right now.

There are certainly paths to getting full functionality for these, ranging from begging Homeseer to write a driver to writing it yourself.

1 Like

Over at the Homeseer forums an admin stated that the devs are working on a driver for the WD/WS200 series. I requested an edge driver for both the WD/WS100 switches as well as the FLS100+ Motion Sensor in their respective forums. I haven’t had any response yet.


I looked at the DTH for the WD/WS100 and didn’t see anything tough about it. Ideally someone that has the devices would tackle the driver, but if someone who has one is willing to get CLI logging running then I can look into it in a week or two.


@jacobth4th The SmartThings Z-Wave Switch driver worked for my HomeSeer switches - I’ve got the WD100, WA100, WD200, WS200, and FC200s. But I also enjoyed the Multi-Tap functions, so I’ve started writing a driver for the HomeSeer switches. It currently supports the basic switch functions and Multi-Tap.
This is my first attempt at a driver, but it’s working well for my switches.
Code and channel invite link here:

@jshessen took over this driver and developed it much more thoroughly.
Code and channel invite link here:


Wow thank you …
Just install on my 2 switch wd100.
So far what I did with your driver is assign toggle up 2 times to control a light .
It is working but you can’t trigger that command 2 time in a row without having to toggle up or down one time .

So after trying the toggle up 2 time, first attemp work , second attemp won’t work till I press the up or down one time .
In the app it always show that I have trigger 2 time but nothing appens.

Here the log when I press the upper switch 2 time and when nothing’s happens.

2023-01-04T01:32:36.766948553+00:00 DEBUG HomeSeer Z-Wave Switch Lumière Salon device thread event handled
2023-01-04T01:32:59.979056880+00:00 TRACE HomeSeer Z-Wave Switch Received event with handler unnamed
2023-01-04T01:32:59.985126130+00:00 INFO HomeSeer Z-Wave Switch <ZwaveDevice: 17a26399-fdbf-42fd-9bb5-7430831c4456 [DE] (Lumière Salon)> received Z-Wave command: {args={key_attributes=“KEY_PRESSED_2_TIMES”, scene_number=1, sequence_number=181, slow_refresh=false}, cmd_class=“CENTRAL_SCENE”, cmd_id=“NOTIFICATION”, dst_channels={}, encap=“NONE”, payload=“\xB5\x03\x01”, src_channel=0, version=3}
2023-01-04T01:32:59.990564464+00:00 TRACE HomeSeer Z-Wave Switch Found ZwaveDispatcher handler in homeseer-zwave-switch
2023-01-04T01:32:59.994011005+00:00 INFO HomeSeer Z-Wave Switch <ZwaveDevice: 17a26399-fdbf-42fd-9bb5-7430831c4456 [DE] (Lumière Salon)> emitting event: {“attribute_id”:“button”,“capability_id”:“button”,“component_id”:“main”,“state”:{“value”:“up_2x”}}
2023-01-04T01:33:00.003884672+00:00 DEBUG HomeSeer Z-Wave Switch Lumière Salon device thread event handled

@Sylvain I’ve also experienced this, and I don’t know why it’s happening.

It looks like there’s only one ‘KEY_PRESSED_2_TIMES’ in the log, are you sure that’s the whole log?

I have only include when I press 2 times and it’s not working in the logs

I found another problem:

Hold_up or Hold_down is not working too!

I have an automation to dim the lights when I hold up the paddle. At smartthings app does not trigger this event when I hold the paddle!

@ryanjmulder , maybe @philh30 can help you with that problem

@ryanjmulder You’ll need to set state_change = true for all of your button events. You should just be able to add event.state_change = true right before the emit_event on line 57 of init.lua.



Thanks @philh30 ! If you have any other suggestions, I’d welcome them.

@Sylvain I made the change that philh30 suggested and packaged the updated driver

@anghinoni I also attempted to add hold events

Let me know if it works for you!


wow that was fast , now it is working Thank you

Thanks a lot @ryanjmulder it is working now!


I have been waiting to try your integration when I return from my work assignment. I can see from the follow-ups that things look very promising. Thanks for the work and for sharing your efforts. I will try your drivers as soon as I am back.

Works great! Thank you :pray:

Hi. Can someone point me in the right direction to install this Edge driver?

Thank you!

  1. Click the link above to go to the GitHub page for the driver.
  2. Scroll down a little and click the invite link found there
  3. Log in to ST, authorize for your hub
  4. Click “Available Drivers” and then install the Edge driver

FWIW, your switches will not pick up this driver until ST moves your switches to Edge.

You can check if ST has already switched you over by clicking one of your HS switches, then click the three dots top-right, and see if “Driver” is in the menu between “Edit” and “Information.”

If not, your options - once the driver is installed - are to wait, or to remove each switch individually, then re-add as “Generic Z-Wave Device” and the new Edge driver should get assigned automatically based on fingerprint (if not, go back to the three-dot menu, select “Driver”, and choose the driver).

1 Like

Hi @ryanjmulder , any chance of adding the fingerprint for the FS100+ Water & Light Sensor?