Edge drivers, ongoing issues

I have 3 ongoing issues ever since the end of Groovy. I am at a loss and cannot find a way to get things to work properly. Everything worked perfectly prior to any edge drivers being installed on my hubs.

The first issue and the most minor one of the 3 was that i found my Weiser or KwickSet 914 door lock will not install an edge driver of any kind. I have removed and added many times. Factory reset the device and I have even removed all the old device handlers a while back as well.
This is the model i have and looking at the fingerprints.yml the manufacture code etc is not in the yml file at all despite it being almost the same as the other KwikSet 914 locks.

The second issue i have is with my Fortrezz MimoLite that i used for a garage door opener. It opens the door and reports the staus correctly but for some reason the button in the SmartThings app does not close the garage door it changes the status of the door to closed and once that is done i have to hit the button a second time to send the “open” signal (since it is a momentary switch action) and then the door will close and report the proper state of the door at that time. If i refresh the status when the door shows closed when i hit the button only once and the door is actually open, it correctly changes the status back to open and i will have to hit the button twice to actually close the door. When i try to create routines to control the garage door from another device, i can only get the control actions Open and Closed (not Close). To get it to close properly i choose the “open” action in order to close the door. So this work around works great using other devices but i cannot change the way the button works in the app. As well there are times i can be out in the garage with the garage door open and after a significant amount of time it randomly decides to turn the status to closed. I have not figured out any pattern to this as of now.

My third issue and the one device i use a ton of routines, or at least used to was for was my Zooz Zen16 for sprinklers. When operating any of the 3 relays in the app i hit the button it will activate the valve and show a status of ‘on’ but within 2 seconds it changes the status back to off. Refreshing will not update it at all. When i hit the button the second time it changes the status to on and stays on. The same issue will happen when turning it off. The first time i hit the button it turns the valve off and reports the status as off and within 2 seconds it changes the status of the relay to on again. I will have to hit it a second time to change the status to off. The main or parent status button operates as it should turning on and off when it is supposed to.

So basically with the MimoLite for my garage and the Zen16 for my sprinklers i cannot use the status indicators in SmartThings to reliably tell me the correct status or even interact with the devices correctly and has become useless because of this. All of this is on a V3 hub and as weird as the Zen16 issue is, i have a second SmartThings hub attached to my account at a different location (the wifi hub) and it does the same thing. I also have a Zen17 on this second hub and the relays work just fine without any issues. In the case of all three issues i have reset, removed, changed drivers even to random other drivers and back and nothing seems to solve or repair the issues. Everything worked perfect prior under the groovy system and the issues only showed up once the move to edge drivers occured. I am at a loss, can anyone point me where to look for any of the 3 issues.

Contact the owners of drivers you are using and report the problem.

@cooldog1 you’re not alone with your ZEN16 relay issue. I also have similar problems, but it is not quite as bad now that I’m on hub firmware 48.2.

What firmware is your Zen16 on?

One unit I have was constantly going offline, has not gone offline since 48.2, but I still have the issue with the 3 relays not activating, but the main does.

I also had a Aeotec plug that was going offline, the one thing they all had in common they were all onboarded under the prior hub firmware. It is also stable now.

I’m in contact with @TheSmartestHouse support, I suggest you do the same if you purchased it from them, as it maybe a device firmware issue.

1 Like

Your Kwikset is supported by the [ST EDGE] Z-Wave Lock PH - Devices & Integrations / Community Created Device Types - SmartThings Community from @philh30. Subscribe to his channel and install his driver. Then exclude and re-add your lock.

It appears i forgot to include the link to the Kwikset lock i have in my original post. According to the thread it is the same as the stock Zwave lock fingerprints with a few added features for some Schlage locks. In my case the stock driver doesnt include my Kwikset 914 but it includes other 914’s


My lock will require
manufacturerId: 0x0090
productType: 0x0006
productId: 0x0440

The only 914 locks are the following and it doesn’t match the fingerprints of any other lock in the stock driver either

  • id: “KwikSet/914/1”
    deviceLabel: KwikSet Door Lock
    manufacturerId: 0x0090
    productType: 0x0003
    productId: 0x4006
    deviceProfileName: base-lock
  • id: “KwikSet/914/2”
    deviceLabel: KwikSet Door Lock
    manufacturerId: 0x0090
    productType: 0x0003
    productId: 0x0440

I was looking for others that may have had the same issue as me and any fixes they may have tried. I cant be the only one that is using a MimoLite for a garage door and using the stock “Z-Wave Garage Door Opener” driver.

I suppose a trouble ticket to Samsung over these three issues is the next step. I will likely put one in with Zooz as well but it is strange that it worked flawlessly prior but now it doesn’t.

1 Like

Then I would post in @philh30’s driver topic and ask him to add the fingerprints for your lock(s).

I will likely be putting in a trouble ticket with Zooz soon, I was hoping it was something other than firmware as it worked flawlessly when i had the groovy device handlers.

both Zen16’s are on firmware 1.03

I would have to buy a zwave dongle of some sort to get a firmware update so i was hoping to find any other potential fixes before going down this road.

The smartest house is telling me that it is probably not firmware as it’s not an issue on other platforms and I think that is probably correct as I am on a different firmware to you 1.2

I had the mimolite issue as well. I found this page while researching the issue. I ended up fixing it by changing SmartThingsEdgeDrivers/init.lua at main · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub line 82 to set the value to 0xFF.

Basically, the driver is turning off the momentary switch when you press the button and the door is closed, which does nothing. You want the momentary switch to turn on both when opening or closing.

1 Like