[ST EDGE] Zooz Edge Driver Channel

I just ordered mine, this is the last piece of the house that isnt “smart” yet. Excited to give it a try!

1 Like

Same here, it got delivered today so looking forward to getting it set up tonight. I was wondering whether a driver was required - question answered before I could ask it!

The link implied the driver isn’t there yet. Is it? $24 is much cheaper than $50* n alarms, and an future update required…

It’s included in the Switch driver.

1 Like

Just installed. Very simple, with the driver already installed it immediately showed up as a smoke detector and triggered a notification when I tested the system. Further options available by setting up smoke detector in STHM. Nice work @thesmartesthouse and @krlaframboise !


@krlaframboise @TheSmartestHouse I’m having an issue with a Zen16, firmware 1.2, Hub firmware 47.11

I have reed switches connected to Input/Switch 1 and 2, they are closed when off. (2)
I have a snap switch connected to Input/Switch 3, it is N.O, closed when on. (0)

0 – normally open (relay reports off when it’s open / input is off and on when it’s closed / input is on);
1 – normally closed (relay reports off when it’s open / input is on and on when it’s closed / input is off);
2 – normally closed (relay reports off when it’s closed / input is off and on when it’s open / input is on). Default: 0.

When any Input/Switch is toggled the relays do not change state in the app, they remain off, but physically the relays change state (checked with meter, and can hear them cycle) and routines fail to run. The main switch/relay activates correctly, just not the child switches.

The behaviour is the same whether using the iOS or Android app.

Is anyone else experiencing similar issues, do my settings appear to be correct?

I also have a second ZEN16 on firmware 1.2 that is set with all 3 relays normally open and it appears to be functioning correctly.
The release notes for 1.2 state: Firmware: 1.20

  • Addressed issues with reporting when relays are triggered via Sw inputs when Multirelay is added with S2U security on select platforms.

From API Browser:

Key Value
Name zooz-zen16-multirelay
Mfg Name SmartThingsCommunity
Mfg Code 027A-A000-A00A
Model A000-A00A
ocf Type oic.d.switch
Category Switch
Room Kitchen
Presentation ID 231be2de-23bf-3633-a732-f0de9dddae8d
Parent ID 9fc68a4a-cad0-4ae4-acff-c3a606c37bd8
Parent Name Home Hub
Driver ID 7333473f-722c-465d-9e5d-f3a6ca760489
Driver Name Zooz Multichannel Switch
Network ID 3F
Provisioning State PROVISIONED
Local Execution yes

Are there any parameter changes that have occurred as the notes on ZOOZ’s site are only listed for firmware 1.04?
I noticed that the firmware file extension is the same for habitat and others, so this morning I will reflash the firmware to ensure I did in fact download the correct one, any other suggestions would be appreciated.

@krlaframboise , @TheSmartestHouse I have two Zen32’s on 10.3 firmware they both work as expected except when pressing the large button 3 times then they appear to go into inclusion mode (blinking blue led), but even if you scan for new devices the are not found, as they are already included.

Tried factory reset, exclude, include with no change in the behaviour so I believe it is a firmware issue?

Is your problem that you’re not able to include the devices or they include well but you want to use the triple-tap to trigger scenes and instead the switch enters inclusion mode for you? If it’s the latter, then you need to disable programming from the button in the advanced settings to disable that inclusion mode on 3-tap (see parameter 22 in the advanced settings here).

It is the latter. @krlaframboise is this something that should be available in the settings?

Enable / disable programming on the relay button

Parameter 22: Enable or disable programming functionality on the relay button. If this setting is disabled, then inclusion, exclusion, manual LED indicator change mode no longer work when the relay button is activated (factory reset and scene control will still work) - that means you can now use triple-tap triggers on the relay button for scenes and remote control of other devices.

Values: 0 – programming enabled (default). 1 – programming disabled.

Size: 1 byte dec

This setting was added more recently so it may require an update to the driver. It should be added in the next few weeks.

Thanks, I will hold off doing it with a “z-wave config” driver as I don’t really want to redo 60 routines.

Having same issue with ZEN switch. Worked great until I updated to EDGE Drivers. Every few days it becomes disabled and have to oull the air gap button to restore.

My two Zen20 power strips automatically migrated in the last day or two. They came on board with the stock ZWave switch driver rather than the already installed Zooz Multichannel driver. Channels 2-5 slow up as “edge child” devices in the API browser.

They’re in the kids’ bedrooms and I noticed the change after they were asleep, so I haven’t tried messing with the drivers yet, but all the routines ran correctly at bedtime so I think the stock driver is at least handling basic functionality well. Power meter also seems to show correctly. Will try to find a minute to switch over and experiment more tomorrow.


Hi. Pretty new ST user here and 1st post. :wave:

Just want to add that I am seeing the same issue as RedTx w/ the ZEN32. Any updates? Any information that it would be helpful to have from another user seeing the same behavior?

iOS app v
Hub v3 w/ firmware 000.047.00011
ZEN32 firmware 10.3

@nayelyz is there an update on the iOS multi-component “THEN” issue, it has been broken over 3 months.

Hi, @NickA
The team mentioned this should be solved in the next version of the iOS app, it should come soon, I don’t know the exact date.


Thanks for the update and I look forward to it


Thank you @NickA and @nayelyz!


Confirmed fixed in the iOS version just released.


Curious little issue with a Zen52 recently. I’m not sure where the fault lies, but I figured I’d pop it in here so there was a record.

I have the multirelay set up to control the lights in my garage and outside in the driveway. They’ve been working fine for at least 8 months. The other day I was leaving the house and I noticed the outside lights were on, in the day. I popped into the app and turned them off. When I came home they were on again. I turned them off and checked in the history and saw the two relays have been turning on and off every couple of hours for the past day. Since I had no automations or rules that would turn these on without some kind of interaction I was kind of stumped. I rebooted the hub. They stopped turning on and off on their own, so I thought everything was good.

A day later I was in the API Browser+ and I noticed the two relays were gone. I looked in the app and they were still there and they still worked (I could turn them on and off from the app.) So, no worries, right? Well, the next morning I wake up and, being curious, I check to see if they’re back in the API Browser. Nope, now they gone out of the app too.