Gocontrol Garage Door Help Needed

My Zwave Linear (Go Control) garage door opener recently stopped working. It was able to communicate the open/close status from the tilt switch, but I timed out with a network error every time I tried to open or close the garage. I bought a new Go Control opener and it looks identical to the old one. The only difference is that it is Zwave plus and has a QR code on the back. I tried installing and when it was time to scan the QR code I received an invalid bar code error. I skipped the extra security and continued. Unfortunately, it is in an even worse state than my old opener. I get a β€œdevice hasn’t provided an update” error. So nothing works.

Any thoughts and ideas are welcomed.

The Go Control garage door openers, all models, have always been very finicky when adding them to ST. You have to first pair them right next to the hub by either taking them down and pairing right next to the hub or moving the hub to the opener. Look in the advanced web page and see if it paired correctly as shown below.

1 Like

I just tried repairing with the opener and hub side by side and the symptoms are identically the same. When I open the opener in my mobile app I see a message the bottom that reads β€œThis device hasn’t updated all of its status information yet. Check again later.” Could this be related to the groovy to edge migration? Do I need a different driver?

I get this same error with my thermostat but that appears to be working fine.

BTW. I am on the v2 hub. I wonder if this one has outlived its useful life.

What does the summary page show for the device in the My.smartthings.com/advanced . Have you tried removing the device and then rebooting your hub and then adding it again? Do you have other Z-Wave devices that are working correctly?

Plenty of people still using the V2 so I dont think this is your issue.

I have 58 Z-wave devices and 5 Zigbee working fine. Well sort of, my Thermostat works but does gives me a failed to update error when I open it in ST. I’ve rebooted, z-wave repaired, connected and reconnected. Nothing works. I am completely baffled. See screen shot for Garage Door setup. Right now from the ST app it shows as offline.

I’m curious if I am having a wide area network issue. What is your latency when you ping your hub from the advanced portal. My latency is crazy high. See second screenshot.

This is normal, mine is even higher.

Your screenshot shows the issue


The model number is all Zeros which means the device did not pair correctly. You have to remove it again and keep trying to repair the device to the hub until the model number populates correctly.

See the link below by JD


thanks. I will keep trying.

What’s the exact model number of the door opener?

1 Like

You may also want to try and install Marianos driver and see if that works. You will need to remove the device and then add the device again after you install the driver from his channel.


I had tried Marianos too with no luck. However, I got it working tonight. Last night I excluded it, reset the opener to factory defaults, rebooted the hub, ran a Z-wave repair, and went to bed. I wanted to get a clean start today.

Here are the lessons learned.
The instructions say to put your controller in discovery mode then press sync button. I did this more time than I can count and it did not work. It looked like it worked but it was clearly not connected properly as you noted last night with the 0000-0000 model#. Yesterday, when I started doing this next to the hub I observed that occasionally a menu would pop up that asked if it was a garage door, lock, or switch. In reality this popped up too late. So tonight I decided that I am not going to hit the sync button until the menu popped up and I selected garage door. So I picked garage door and ST prompted me to β€œhit the sync button.” I did. Then it prompted me for the security code on the back of the controller. This was a first. (recall the QR code was invalid on all prior attempts, so a manual entry made sense).

Bottom line. The instructions that came with the controller are wrong!

Thanks for sticking with my on this Michael. BTW, it is the Go Control GD00Z-8-GC.



Great, I’m glad you got this sorted out!