[Edge drivers] Duplicated device instances (DTH and Edge)

Hi and happy new year

i try to pair a Xiaomi contract sensor device but the smartthings find 1 of many FGR-222 (fibaro roller shutter 2) that is already pair with old device handler now have it on app both with edge an device handler

i do not have delete the device handler and the device in the app is still 2
i have this problem with edge driver the icon is not show closed window when is full closed and also does not show the energy etc
i do not know if not working well cause of exis device handler conflict or something

Hi @b16b I hoppe you a very happy new year too

This pairing without uninstalling the device is very strange, I had not seen it before.
Has it been paired with the Z-Wave Window Treatment Mc?

The fact that the status of the blind is not displayed correctly may be because you need to perform a calibration from preferences.

The energy information is sent depending on the report settings in preferences, you could try changing them to other values

I’ve experienced a similar (?) Issue.

When adding a Zigbee switch it fails, but a 2nd (app-) device is created for an existing Z-Wave switch. So, now I have 2 (app-) devices for the same physical Z-Wave switch:

The original one using a stock Z-Wave DTH and a new one using your Z-Wave Switch and Child Mc Edge driver.

The Z-Wave DTH-based app controls works flawlessly, as earlier. (On/off, dimmer level, power, energy)

The Edge based one controls has an on/off button only. On iOS your Edge driver is identified, but on Android I sometimes (!) cannot see it/confirm it. In the IDE it shows that the Edge driver is in use.

Driver version 2023-01-03T18:18…

Hi @nayelyz

Have you heard or been reported something similar to this reported by @S.F.B and @b16b ?

When adding devices by searching nearby, some Zwave devices paired with a DTH are paired to a driver edge and remain paired to the DTH.
They are duplicated.

1 Like

I had that happen with a Jasco Z-Wave switch. Someone turned on the switch while the the hub was in pairing mode, and the switch paired with an Edge driver.

You just need to find an edge driver that supports power monitoring and change the driver.

Hi, @S.F.B, @b16b

When you tried to pair the device, did you delete it first from the app or just rebooted the physical device?

I ask because Z-Wave devices need to be excluded from the Hub to delete them completely before joining them again.

The Zigbee device I attempted to add was brand new and never used by anyone before. The add-attempt led (as said above) to an additional Z-Wave Edge driver for an existing, DTH based Z-Wave device.

Hub 2015 version. Latest available fw.

1 Like

This has been happening with legacy z-wave devices for over a year. Many legacy devices broadcast a NIF very readily - just toggling one of the old Jasco switches sends one even if it’s already in a zwave network. If the ST hub is in inclusion mode when it receives the NIF for a DTH device, it creates a duplicate Edge device assigned to the same zwave node. Both the DTH and Edge device are able to send zwave commands to the physical device, but the hub only routes inbound zwave commands to the DTH device. Deleting either the DTH or Edge device without performing a zwave exclusion leaves the other device functioning properly.

This is 100% repeatable. I exploited this bug to easily migrate all of my legacy zwave to Edge. I’m not sure if it’s still possible though - I haven’t kept up with the changes to the Groovy IDE to know if it still lets you delete a device.

1 Like

Nifty bug, indeed!

But, still, it does not explain why the Zigbee device refused to be added, which it should, considering I’ve a number of these devices added and working at another location/hub.

@nayelyz, I am having a similar problem with zigbee. I have several of the same device and all but 1 converted over to Edge with no problem. One flashes indicating it is ready for inclusion but the hub never finds it. I have tried resetting the device several times but the hub just won’t see it. This is happening for one sengled bulb and for one ledvance smart+ led strip. All the rest seem to work fine.

Hi, @guxdude

I don’t think it’s the same issue, here there’s no issue to install the device but it gets duplicated, one instance using a DTH and the other using a DTH.

About your devices, have you checked if their fingerprints are included in the official ST driver? Can you share them here?

It is the same issue @S.F.B reported relative to a zigbee device not connecting. Different from the z-wave duplication issue. I have 7 of the identical bulbs all purchased at the same time and 6 connect. This one was connected but I had a hub issue and now it won’t connect to the new hub. for the LED strips, I have 3. Two connect and one doesn’t. So, yes, I have a valid Edge driver that works for these devices. Not sure what the problem is. I will try to look up the fingerprints later for you. Still recovering from my hub issue. :frowning_face:

I’ve got a number of devices that transitioned over last night and now have duplicates with a 1 appended to the name. The extra one seems redundant, so I removed it and it appears to come back. Is this intentional?

Can you share the Brand and model of those devices, please? Which driver are they using?

I think these are all Ge/Jasco. I don’t recall which model #. The driver for the “new” one is the ST Z wave switch. I tired thsi again, just now and I was now able to delete the older devices with the ! annotation and they newer ones appear to work.