Edge driver for Monoprice Smart Plug and Repeater (27481)?

Is anyone aware of an Edge driver for the Monoprice Smart Plug and Repeater (27481)? I used to run RBoy’s device handler for this, but have since removed it and am using whatever SmartThings includes by default. I have a number of other Z-Wave switch drivers installed, including Phil’s drivers and a Zooz driver that somebody else said worked, but I don’t have the option to change the driver in the app. On the API+ site, trying to change a driver just throws an ‘Ineligible device’ error, which I assume means I have nothing compatible installed on the hub.

It’s still using a DTH. at this point in the transition, you can’t change between drivers until the device has been added to the network with a driver (any driver).

And it can’t be added with an edge driver until you have deleted any custom DTHs that it matches. But be aware that once you do that you can’t get them back anymore. Since you’ve already downloaded edge drivers that might work with it, see post 3 in the community edge driver FAQ for the process of getting the device assigned to those.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

If the DTH it’s matched with is not a custom DTH, then the issue is that your device’s exact fingerprint is not in the edge driver that you want to use. You will have to ask the edge driver author to add it.

(Note that it is entirely possible for two devices with the same model number to have different fingerprints, as some device manufacturers do update the fingerprint if they change the firmware.)

You should also check to make sure that the edge drivers that you want to use were in fact downloaded to your hub. This process is explained in the same FAQ, but in post one.

I am using the Zooz driver for the Zen15 with my Monoprice Plug with the same fingerprints

1 Like

I removed and unpaired the two devices that used the RBoy DH, deleted the DH, then added the devices back. I’ll give the Zen15 driver a shot. I did confirm that the downloaded drivers were installed on the hub, so that part is good.

1 Like

So yeah, that’s the same Zooz driver I tried before. Still no success. The only DH’s currently installed (Nuheat t-stat, ecobee) don’t apply to any of these devices.

That may have changed on May 24th, or should be soon, Automatic Device Pairing with LUA Drivers. Just depends on how they define: (after May 24th).

1 Like

Hi @NTPanaccio

Can share this information with us to investigate the problem?

  • Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  • the fingerprint
  • the name of the device
  • please try to add your device again, save the date/time and share it with us
1 Like

This is almost comical. I enabled Account Data Access, deleted and unpaired the devices again, then readded them - and now they pull in with the Zooz driver by default, and allow me to switch the driver. I did this the other day and did not experience this behavior. I’ll still provide the fingerprint, etc. if you want, but it sounds like my issue is resolved.


Okay it’s good that the problem is resolved, in that case, I can’t investigate was happened but if you experience another problem let me know :slight_smile: you can disable the account access.