Door Lock (manual lock/unlock) not triggering events (April 2019)

I have 2 kwikset smart locks going on 3+ years and have had them trigger events on lock. It seems these stopped after the recent upgrade (or just a coincidence).

I’ve tested both locks to see it’s not the lock. If I use my smart phone to lock/unlock it does seem to actually trigger events. However, If I try to lock the door manually (for example at night before bed) it used to trigger events to turn of lights, dim lights. I Do see the kwikset red light (once you take cover off) light up as if it is sending messages to hub for both manual and via smart phone.

However, now, no matter what I do, I don’t see any events listed for manually locking/unlocking and because of that assume that’s why it is no longer triggering events.

Has anyone else seen this behavior?

I do use RobB smart lock apps (have for just as long) - don’t believe it’s anything with the application or with the lock.

1 Like

You are not alone. This is caused by changes in the latest hub firmware. To rectify changes to the DTH are required (which hopefully the developer will handle in due course).

I just installed a Kwikset 99140-103 Convert Z-Wave Plus Lock yesterday and I am seeing the same thing. There is nothing in Live Logging in the IDE when I manually lock or unlock the deadbolt. Eventually (at the end of the check interval) the lock status does update. Control via the mobile app on the other hand is very fast and works as expected.

I am using the default SmartThings DTH, Z-wave Lock Without Codes, which seems to have been updated to address the above referenced issue with this commit.

@Kianoosh_Karami can you comment on this? Could this be a bug in the DTH? If so, I would be glad to assist with troubleshooting.

  • Jon

Hey Jon,

I PM’ed you so we can troubleshoot this problem.


1 Like

I don’t mean to hijack this thread but here’s an update on my situation: it turned out to be a hardware problem with the lock itself, not a SmartThings or Z-wave issue. I found that if I uninstalled the lock from the door and manually rotated the shaft all the way in one direction or the other, it would trigger the locked/unlocked status in SmartThings. It did not matter if the lock was right next to the hub or near its normal location on the door (about 15 feet away from the hub). I tried this with and without the cover on the lock and there was no difference. With the lock reinstalled on the door, rotating the knob in either direction once again failed to trigger the status change. For the record, my deadbolt is properly installed, has very smooth action and no restriction in rotation.

I assume the problematic component in the Kwikset lock is some sort of potentiometer, set to trigger at the locked and unlocked positions, and that mine was out of spec. Although my lock was brand new, I wonder if this could be a failure mode for older locks as well. Anyhow, I returned the lock to the retailer today and will not repurchase as I am concerned about long term reliability.

I would like to thank @Baohua.Sun and @Kianoosh_Karami for looking into this on the SmartThings side. I would also like to point out that in multiple threads, a member of this community has harped on the need for Z-wave repeaters - seemingly regardless of the situation - to people troubleshooting similar issues. Not all lock problems can be solved with Z-wave repeaters :hammer:

1 Like

Just for reference, if you are using the custom DTH then update the custom DTH to the latest version:

And also the LUM app:

We had issued a patch some time ago to incorporate the changes in hub firmware related to the new z-wave framework as pointed out above.

There are key tell tale signs of the root cause of the issue, for example:

  1. If you are seeing an lock/unlock event show up in the lock history/recently events but not the user name, then updating the code to the latest version should fix it that
  2. If you’re seeing manual locking/unlocking events and not user specific events it could be either updating the apps or it could be the mesh is losing the event (user locking/unlocking events often are sent via 2 separate events where as manual events are sent via a single event and mesh issue sometimes drops the second event)
  3. If aren’t seeing any messages at all in the event history then it could be a defective lock/module, a lost connection with the hub, internet issues, mesh issues, a bad battery etc

This is just the most common issues. Feel free to PM to deep dive.