Devices keep showing as "Unavailable" but still working- Device Health

I keep seeing Zwave switches and outlets and Smartthings buttons showing as “unavailable” even though they are working. I remove the batteries from the hub and disconnect the power, wait a minute and reapply power. Everything is normal for a short while and then devices start showing as unavailable again. Getting to be a pain the butt!

Sometimes they come and go without any intervention. Nothing in the environment has changed.

1 Like

Next time check the IDE and see what their status is.

It’s not just you. I have been having all sorts of problems with unvalable and offline devices over the last week. There have been issues with “status” of devices based on the emails I have been getting from SmartThings. It’s been so bad this week I had to disable all my offline device monitors in WebCore due to the number of SMS messages I have been receiving.

https://status.smartthings.com/incidents/pd7x35b8p5hb

1 Like

The Groovy IDE status matches the apps (both the new and classic).

Glad I’m not the only one - I hope they get it resolved soon. I haven’t seen any emails from the service status notifications about this issue…

1 Like

I have been seeing this as well. Multiple types of devices showing unavailable but still working and then several hours later, after taking no action, the show back up as available.

1 Like

I’m having the same issue. It only appears to be a problem with devices that I’ve changed the name of after adding it to WebCoRE or the SmartThings app. Just a correlation I’ve noticed, but may not be the actual cause of the problem.

Removing and adding back the item may help.

I created a support request - got this reply

“This email is to notify you that we have created a support ticket for your request. Kindly note that our reply may be delayed due to a sudden volume increase. We will follow up with you as soon as we can. We deeply appreciate your patience.”

Happening to me all day today. Devices coming and going as to showing as unavailable, but yes they work as per normal.
Rebooted a few times and did a few repairs to no avail.
Support did return my email, their only advice was to reboot. Told them it didn’t work got no further replies.

2 Likes

Same here. 2 locations and I have multiple units coming and going. Outside of deleting and adding back I have been able to go into the IDE and pretend to change and update a device to get it back on line. Doesn’t always work though.

I received an email regarding the support ticket I opened

"We regret the inconvenience caused with the device health status. It was an issue for sometime and has been fixed recently.

Currently, I can see Cree Bulb, Z-Wave Dimmer Switch and Z-Wave Relay are showing offline. I would request you to reboot the hub again, wait for 3-5 minutes and supply the power. If the devices still showing offline, kindly take the screenshots of the same and write back to us."

My reply was:
"I did as you suggested and now diffrerent/other devices show as unavailable. It is different ones at different times.
I don’t think the issue is resolved. Attached screen shot
Thanks"

>>> We should continue to contact them so they know the extent of the problem
and include a link to this post.<<<

1 Like

https://status.smartthings.com/incidents/pd7x35b8p5hb

1 Like

I’ve had the same problem but now even my hub reports offline as well… And still working… :smiley:

I got another reply from Smartthings support after sending them a screenshot from the app and providing details…

I’m sorry for the difficulties you are experiencing with the SmartThings network. We are going through the deep investigation on this issue and we will write back to you with the possible fix quickly

I don’t have any z-wave devices but am having this same problem with multiple (and different types of zigbee devices. I have 3 zigbee door sensors that have always done this (show offline or constantly bounce anyway) even though they have always worked. This weekend my SmartThings branded vibration sensor and one of my Kwikset door locks started doing this. The door lock reports unknown on the front page of the app yet I can still control it via that page (as well as the Things page). The vibration shows offline in IDE but shows correct state in IDE as well as on Things page.

1 Like

Overnight I had more that 30 offline events, randomly between door locks, Zigbee plugs, Zigbee Lights, Water sensors, and door sensors. I am still logging them just no longer alerting them.

I’ve been having the same issues with ‘things’ showing unavailable. Some reset themselves. Others I have to delete the ‘thing’ and re install it. When I re install the problem goes away. I’ve been following this process for almost half my sensors over the past month.

You can email or call Samsung about this issue - scroll down to the bottom of this page:
Smartthings Support

Another email from Smartthings Support

Please try the below steps for the device to show online.

  1. Sign-out of the app and login back and check if it is online, If no luck then
  2. Delete and re-add only the specific device that is showing offline, still not online
  3. Delete the app and restart the phone once and check if the devices are showing online.

If not online after following the steps please let us know and we will work towards fixing it.

Also, please let us know if the issue is with any specific device or all the devices are showing offline.

I followed those instructions
1. Signing out and back in did not work

2. I deleted and re-added devices

. First Alert One Smoke & CO alarm

.BTN3 and BTN4 - Smartthings buttons

.Computer Room - Smartthings Outlet

.Living Room - Levition wall Dimmer

    1. I deleted both the Smartthings App and Classic App, rebooted my phone and reinstalled the apps*

I had to fix a bunch of routines and SmartApp automations, rediscover Alexa devices and IFTTT settings. A royal pain in the butt.

The good news is, so far all my devices are showing online as normal.

I will wait a while before responding to support.

Well - eight hours later and no devices have shown up as unavailable.
I emailed the support person but asked the incident not be closed for a day in case the problem recurs.
Keeping my fingers crossed :crossed_fingers:

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.