Device “unavailable” but still works

Everyday, there are different devices popping up as “unavailable” in which I have to not just scroll through my device list in the classic app to turn on/off or see status, but I have to tap and go into the device to turn on/off and see status.

They still respond but when using Alexa to turn on/off, Alexa says the device is not available and to check internet connect but STILL turns them on or off.

I contacted SmartThings support and they keep telling me to delete the device having this issue and re-adding. This is ridiculous because the devices will show unavailable one day and the next day other devices will show unavailable.

This is a huge waste of time and not a solution which I have told them but they keep responding like robots with the same answer.

I’ve tried turning device health off, but Alexa still says the device is not available (but still carries out command).

I’ve also tried unplugging the hub for over 1/2 an hour.

Both zigbee and zwave devices are randomly affected by this and read “unavailable”.

Anyone know of a solution?


It’s nice that the current SmartThings status reflects this, however this has been going on for a week for me and back and forth with customer service telling me to delete and re-add all the devices showing as unavailable.

the only thing I would do at this point is reboot the Hub from the IDE. Don’t worry about it until the status page is updated.


I’ve never rebooted from the IDE. How do you do that?

I usually just unplug the power and batteries.

it is under hub utilities on the hub page.

I turned off device health and haven’t had these problems.

That’s not an option in the new app.

I’m seeing the same issue. Rebooting from IDE seems to help but I think it’s a known problem with the servers or the device health function. Will wait it out and hope Smartthings will fix itself.

I have been testing various devices motion, multi-purpose and leak sensor. I have had very few issues but I did run into this one recently with my SmartThings Water Leak Sensor M/N: IM6001-WLP01

The device shows unavailable but still works -

I have been jumping to change batteries or reboot the device and it typically reconnects. I am just wondering since the device works maybe I should just chill and let Samsung get to this bug?

Yes. Maximum, reboot the hub.

If you look at the device’s “Status” under My Devices after signing in at Does it show Offline or Hub_Disconnected?

If it shows Hub_Disconnected, you are likely being impacted what is reported on the status page and that will hopefully clear up in the next few days.

Typically rebooting the hub will correct this but when system is seriously bogged down like it is now, the correct “ONLINE” message that is usually triggered by the reboot can take more than a few hours to make its way through.


My device says unavailable - the hub is online as all my other devices show as available and they all respond appropriately even the one that says unavailable - I woke up this morning and all devices say available - I work in the software industry and I know that unless Samsung can reproduce this it wont be fixed anytime soon. I suspect is maybe some lag with the device health could even be my network.

Jinxed me again. had approximately 20 devices in HUB_DISCONNECTED state this morning.

Are there benefits to rebooting from the IDE versus just unplugging the hub (v3) and plugging it back in?

There are technical differences of course but for this issue there shouldn’t be a benefit one way or the other.

Thanks. I’ll add to this thread that I had some devices show up as unavailable a few days ago but they still worked fine. I unplugged my v3 hub and plugged it back in, haven’t had the issue since. As for what started the problem, I have no idea. The problem seemed to show up right after my Schlage lock had ‘Unknown state’ following an auto-lock attempt on a door which was only partially shut (and thus the deadbolt couldn’t fully extend), but that may be just a coincidence.

Not sure if anyone else is still having this issue, but I continue to experience it and have for some time.

Strangely, if I edit the network ID of the old device (to some random string), SmartThings will re-add the device to the network at the exact same network ID number, and it seems to work normally. Of course, that’s a hassle since all the SmartApps I have are connected to the old device profile, but if one doesn’t have a lot of SmartApps, that seems to be useful short-term solution.