Devices have stopped responding - how to wake them up?


(Tina Caron) #1

Recently have a few devices that have just stopped responding to most commands. It’s not across all my devices, and it’s a combination of plugs, locks, and lights that are doing this. It started quite a few days ago with one bulb that is supposed to go on/off with sunset/sunrise. It’s one of two on the same routine, and one works, the other doesn’t. They are both Hue Lux bulbs, but interestingly the misbehaving one is not connected via Hue, only through ST. I tried repeatedly flipping the switch to no avail, got annoyed, and shut the wall switch off for a couple days. Turned it back on, and things went back to normal for a few days. Now I notice it’s on, and won’t turn off via the app. When I watch the log lots of blather populates, but the light never responds.

Then more irritating I started having two Aeotec switches fail to respond to any commands from ST. I can turn them off and on from the buttons on the bottom, but they won’t respond to routines, rules, or direct commands. Nothing shows in the logs at all when I try to command these two devices. I have tried repairing the mesh network, as well as removing and re-adding both devices. Painful because they were in a lot of routines, plus Alexa and Harmony activities. They show up in the app as configured devices, and the “replace” option seems to act like they are ready to replace, but then what to do is not obvious.

When I was trying to repair the mesh network they both reported that they could not be updated. Even more troubling though is that my two Kwikset locks that have worked just fine have also partially started failing, and were reporting that they could not update the route. I was just able to command one lock to unlock, and it’s been mostly rearming itself at the 15 minute point, but not always. It is also supposed to unlock upon my arrival, and that has stopped working in the last 2-4 days. The other lock is exterior facing, so it only unlocks by command. That is totally unresponsive with nothing showing in the logs when I try to interact with it. ST does log the deadbolt status, and once in a while I think it is telling it to unlock. This typically happens when it’s closed, and I just locked the deadbolt. Perhaps a weird interaction with another smart app, that part. But it’s troubling.

I have a lot of devices in my network, and it feels like little by little my SmartThings is losing it’s mind. I do not really want to decompose all this, remove all devices and start over, but I’m at my wits end to getting these things back up and running. Any suggestions on what I should try? Tried rebooting the hub via the graph.api site as well as by unplugging.

I see that there was a sunrise/sunset and time driven event problem over the last week, but this doesn’t seem to be my case. I have sunset/sunrise and time triggered events that are doing just fine. I’m reluctant to waste my time messing with exclude include device process, since it seems like my non-responsive garage door lock just started to work. Anyone with thoughts?


(Jason Hearne) #2

A lot to read here, but you’ll get the drift after a few comments. ST is going through some “issues” right now. They are upgrading a few things (Database and Scheduler). ST is aware of the issues and they seem to be trying to fix everything. Database has been upgraded, yet the scheduler has not. It’s assumed they are using an old school scheduler and once a command doesn’t fire, it falls off the list (mind you, this is conjecture). Here’s the link:


(Tina Caron) #3

I did read a lot of that stuff, and perhaps is related. I see things like this after removing and adding the Aeon Switches though, and repairing my z-wave network, which seems to be not related to scheduling:

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎34‎:‎37‎ ‎PM: trace NON-HUE EVENT Network repair for Garage Interior Lock [10]: Failed to update route

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎34‎:‎37‎ ‎PM: trace Location: Network repair for Garage Interior Lock [10]: Failed to update route

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎58‎ ‎PM: trace NON-HUE EVENT Network repair for Foyer Table [1D]: Failed to update mesh info

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎58‎ ‎PM: trace Location: Network repair for Foyer Table [1D]: Failed to update mesh info

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎47‎ ‎PM: trace NON-HUE EVENT desc: 0 0 0x1001 0 0 0 c 0x25 0x32 0x27 0x2C 0x2B 0x70 0x85 0x56 0x72 0x86 0xEF 0x82

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎47‎ ‎PM: trace Location: desc: 0 0 0x1001 0 0 0 c 0x25 0x32 0x27 0x2C 0x2B 0x70 0x85 0x56 0x72 0x86 0xEF 0x82

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎47‎ ‎PM: trace NON-HUE EVENT Foyer Table [1D]: Not responding

da24a420-7d6b-4c75-a512-2651cdcdb745 ‎6‎:‎33‎:‎47‎ ‎PM: trace Location: Foyer Table [1D]: Not responding


(Jason Hearne) #4

Look at your “installed SmartApps” in the IDE (MyLocations -> List Smartapps).

For you switches: look at each automation and see if you see any of them stuck at a scheduled “next run time”. If any of them show a date that is from yesterday or earlier you may need to update the App. With your phone just open the smart app, click through until done. this will update the smartapp and it will come back on line.

This helped my switches get back to normality - at least for the next couple days.

You might also try this with everything before removing/re-adding completely.


(Tina Caron) #5

Oh thanks for this, I will check that out.

Additional interesting find…these four devices are all in the front corner of my house more or less. The Garage lock is closest of the 5 to my hub, and it’s responding OK now. The others are all in the same general front area, and reasonably far from the hub without a repeating Z-Wave device nearby.

I took a Leviton switch that I stopped using just a couple days ago (temporary, but it frees up a device) and tried it in place of the finicky switch. No dice. So then I took that Leviton switch and put it in the hallway near to the garage lock. The Leviton switch goes back to responding just fine, but didn’t assist in the signals to my other devices.

So then I tried the Leviton back in the Aeon switch’s place, again no go. But I moved the Aeon switch to the outlet where the Leviton was happy near the garage and BAM, it works fine. This has never been an issue in my house before, save for when I initially tried to pair the locks. I did have to get a really long network cable to bring the hub close to each lock, but never again since.

And one more weirdness…now the Leviton DOES work. Front door deadbolt still non-responsive. I’ll check your suggestion. Oy this is driving me crazy.


(Jason Hearne) #6

I was told that the Smartthings Plug switch is a repeater. (I believe Wifi and Zigbee). As for Z wave related things, maybe this will help guide you in getting you closer to your solution:


(Tina Caron) #7

Thanks. I did find some scheduled events in the past in waiting state, but the only thing that seemed to take care of that was removing the time trigger totally. So those are all cleared. The Aeon Switch will work if I move it to other locations in the house, it just fails to respond when I put it where I really want it to be. Which is about 15 feet from the location that was broken but now works.

The part that is really the head scratcher is why all of a sudden these devices started to fall apart? Especially when it somehow seems to be a distance thing all of a sudden. My hub hasn’t changed locations, and it’s about 5 ft off the ground in the center of my house. Always worked OK before the last few days. It seems like it would have to be correlated to the issues on the platform in general, but why is the puzzling thing.


(Tina Caron) #8

Maybe I’ll have to go with a repeater, although I am not sure that will work. There seems to be a pretty clear line up one side of my house, across which these ZWave switches aren’t working suddenly.

The light bulb that’s misbehaving is a zigbee GE Link bulb too…been so long that I forgot I’d tried those. I may just replace that with a Hue that seems more reliable, albeit pricey. Or at least something that SmartThings supports natively.

Now what to do about that front door lock…


(Eric) #9

as you change and add device locations, you have to do a repair to tell the devices to look for new routes. Not positive but I think MULTIPLE sequential repairs are advised to catch sleepy (battery) devices when they wake up briefly.

It’s not clear to me that you are doing that repeatedly in your investigations - I saw one mention of repair.

Good luck.


(Tina Caron) #10

It has been repaired more times than I can count. Several iterations of remove then multiple repair. Or add then multiple repair. At what point does “repeatedly” become “stop trying because something else is wrong”? That’s the frustrating part of this.

I didn’t move any devices around physically until after many attempts to simply delete and re-add the devices in their current locations, followed by repairs as mentioned before. Once I started doing that, I was able to get one of the non-responsive switches to work, and the garage lock suddenly started behaving. The switch that started responding also seems to work only intermittently via smartthings control. Didn’t work yesterday, but is working today.

The thing I want to make sure is also clear is that nothing had been added or removed at the point that devices stopped responding. Other than the two locks, the devices not responding are all plugged in (or lightbulb, which is zigbee anyway).


(Andy) #11

In my case I find sometimes I just need to hard reset the hub and then everything starts working again. If I go to web console and under “My Hubs” and select “List Events” it is showing active pings. if I go in to the mobile app it is showing “Hub is Online”. If I trigger a door sensor or motion sensor the mobile app updates. The problem is if I try and manually turn on/off anything from the mobile app it ignores me. Reboot of the hub usually helps … at least for me it helps mostly.