Devices added in April 2021 show online in IDE, offline in automations and app (both physical and virtual devices)

Many different people in both the US and UK reporting that many different kinds of devices, both physical and virtual, are showing as online in the groovy platform, including the IDE, but off-line in the app. This is happening to devices that were added recently, regardless of the type of device and regardless of whether it previously worked. So far it has been reported for some Z wave devices, some zigbee devices, and several different types of virtual devices.

No idea what the problem is, and no workarounds have been reported yet, but it’s definitely real. :disappointed_relieved:

Here’s one thread with particularly good screenshots. Note that the devices affected include one mains powered and one battery powered Z wave device, both using a stock DTH.

If this is a physical device using a standard DTH, please report it to support. The more people who report it, the sooner they will start paying attention to it.

If you are using a custom DTH, it’s probably not worth bothering reporting.

So far there are at least seven different threads discussing this, although not everyone realizes what the common issue is. (Recently added device showing as off-line in the new platform, but online in the IDE.) @nathancu did much of the initial research, and deserves a lot of credit for identifying the common cause.


@Automated_House reports this has now been added to the official status page, so thanks also to all those who reported it to support.


@nathancu @jkp @Automated_House @Brad_ST @tpmanley @RBoy @625alex @joshua_lyon @TheSmartestHouse @Eric_Inovelli


I´d been trying to make it work since yesterday and nothing. In the IDE it shows “ONLINE” but not in the ST app.


+1, just was about adding a motion sensor today, and ran headlong into this. Was trying out a Nedis zigbee sensor but couldn’t get it to work: Added to the hub, but app shows offline while IDE shows online. Had a Sonoff motion sensor available as well and tried that but with the same result, and at that point it seemed something was off as I have the same Sonoff sensor at another location working just fine…

1 Like

I’m sure it’s frustrating enough for anyone who just bought a new device, but I have to admit my biggest sympathies are for those who intended to use this weekend to migrate from one of the discontinued hubs to a new one. :disappointed_relieved:

The status page was just updated


One of my child devices suddenly started to work. But not the parent device. The other devices are not working at all…

But now it is gone again.


Issues with offline devices

New incident: Investigating

Beginning yesterday, April 2nd, at around 3pm UTC, some users may have begun experiencing issues with hubs and devices appearing as offline in the app. We are currently investigating and will provide updates as available.

Time posted

Apr 3, 18:02 UTC

1 Like

Oh hum, seems like my devices are now online in the app as they should be, so hopefully this issue will soon be resolved for all.

1 Like

Yes, I just got a response that it is resolved. It took 43 minutes after they identified the issue.


I’m guess that is what solved my problem. I had also seen to power cycle the SmartThings Hub and to turn off affected lights for 20+ minutes. About the time the situation was resolved in the web, we plugged the hub back in and turned the affected lights back on and everything was online. Thankful that everything is going smoothly now! Thanks to all for the help.

1 Like