All Devices Offline, But Still Function When Tapping (Hub is Online)

JUST getting started with Smartthings, although I’ve spent plenty of time in the past creating pretty complex Stringify flows, etc. I have also already installed WebCoRE and run my first test piston successfully.

For some reason though, all my devices are now offline, except for my hub and 1 light. When I click an offline switch though, it still works. In my googling I went into the classic app to turn off Device Health, but that hasn’t changed anything.

Any ideas?

Sometimes rebooting the hub from the IDE will fix this.

Alright, I rebooted from IDE and returned to the app after a while. Still everything is offline, but when I click on a LIFX light for example, it allows me to power on/off successfully even while displaying the message “check that it’s online and connected to network”

EDIT: everything appears to display properly in the classic app

I think turning off Device Health in the Classic app only affects whether the information is used in that app. It doesn’t change things for the ‘new’ app.

I have been seeing weird stuff for the last few days. It is hard to pin down but my latest thinking is that the ‘new’ app simply can’t get the connection status of devices and this manifests itself as dashboard tiles that are ‘offline’, ‘Getting status’ or have a blank status, and it also affects the Automations which also thinks the devices aren’t available. If the tiles are configured with a status based on an attribute like switch or motion they seem to work fine.

Hey there!

Have you already tried sending a forced ping from the server to the devices using the IDE (Integrated Developer Environment) to see if the devices are still communicating or need to be repaired?

Also, have you already tried force rebooting the Hub using the IDE Tool?

I hope this message finds you well!

I have not tried this yet. I’m not sure how to, but I’m also not sure if it’s relevant for the reasons below.

I can still manually control all the devices from the app despite them being “offline”, and my webcore pistons communicate with the offline devices just fine.

Also, lately when I open the app all my virtual switches just say “checking status” forever and never change. They are virtual, so how can there even be “communication” issues? They still also work however when manually clicking the switch button.

I have force rebooted from IDE, and this did not seem to affect the issues in any way.

Thank you so much for confirming that information.

I’m sorry to hear the force reboot wasn’t able to resolve the concerns. A Z-Wave exclusion would have been my next suggestion to get the devices to show back online, I’m glad to hear that you are still able to manually control the devices but I definitely wanna get you back to your normal routine!

Here is an article to assist with Z-wave Exclusion:

@MJRoark If the symptoms continue after trying an exclusion, I would recommend reaching out to the support team directly so that we can take a look into resolving your concerns and you can receive remote support.

I hope this message finds you well!

I tried unplugging, waiting 20 minutes, and plugging back in twice, and it did not help. Everything is online in the IDE and old app, but all Zigbee devices and my two Z-wave locks + hub are offline in the new app.

1 Like

I am facing pretty much the same thing.

About a week ago the server I was connecting to for IDE was down and it redirected me to a different server and none of my hardware was showing…it was completely blank. Then about 1-2 days later the original server came back up and when I logged into IDE it was there and showed as working and being online and sensors were recording data.

However when I open the app it says everything is offline… even though clearly it’s not. Tried contacting Samsung support, but nothing yet which is frustrating !

So what’s the solution? I added a new hub in a new location using the new app (since the classic app doesn’t work anymore). The hub shows up in the app as connected for a very short time before then showing offline. After about five minutes of being powered on, I also get a push notification that my hub is connected. In the IDE, it’s still showing up as active, even after changing to offline in the app. I added a couple of motion sensors during the short amount of time the hub showed up as connected in the app. When the hub changes to offline in the app, the sensors also go offline in the app. The sensors are also still connected in the IDE. If I tap one of the tiles for a sensor, it’ll show no motion, or if create some motion in front of the sensors, they’ll show motion. The sensors are fully functional, but the app shows them as offline, along with the hub.

I tried the suggestions I’ve read: reboot the hub from the IDE, log out and back in again in the app, unplug the hub for a while before plugging it in again. Still having the same problem where everything goes back to offline in the app, while still actually working. What’s the cause of this and how do we finally fix it? My other two hubs in two other locations are still connected as usual and haven’t shown any behavior like this.

There was a new problem, platform wide, which was introduced yesterday sometime. People began reporting it, there are about a dozen new threads in the forum in the last 12 hours about it. Smartthings engineering began working on it this morning and according to the status page a solution has now been applied.

See the following discussion thread: