CT100 thermostat zwave edge driver problems

Hi. I noticed 2 days ago that my CT100 zwave thermostat got moved to edge driver. It actually connects and can read the temperature but the set temperature always set it to 1.7 C. Anyone encountering the same issue and is it possible to go back to groovy driver?


Looks like other people are experiencing issues with this model too:

Have you reached out to SmartThings support to let them know?

@nayelyz what’s the preferred method of reporting issues with devices that were switched to drivers and started having issues?

Edit: Perhaps related to this as well assuming the CT101 and CT100 are related.

Up exactly seems to be stuck at 1.7 and not taking any update. Reached out to samsung
I got a canned response to remove and reinstall as expected so far

This does not help yet.
I am trying to call them

1 Like

I have escalated the problem to their tier2 teams . Hope they can fix it quickly

1 Like

Multiple people have reported problems with multiple brands of thermostats. There are at least two threads on the CT 100 already.

Thermostat problems (multiple brands) Nov 2022

If they are here in the Community, they should tag us (@nayelyz or @andresg)
Or, they can send an email to build@smartthings.com.
Checking this with customer support is ok as well.
We saw @JDRoberts comment and shared it with the internal team, if the Customer Support team escalated the issue, it will show the impact to the team.

@samertheodossy, it would be nice if you could share the updates you get here. Thanks!


Will do once I get anything
Suspect it will take a couple of days

Hi, everyone.

We are looking into this issue with the Engineering team and they have asked for Hub logs. So, everyone facing this issue, please follow these steps and DM me when you are done:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

And please let us know which Samsung Account you’re using and if you have more than one Hub, the name of the one where the device is paired.


Logs uploaded.
Acct: ne***@***ly.ca
CT-101 Thermostat not working

1 Like

Hello same CT100 issue opened ticket as well I have log file but new to community not sure how to upload log file

If you follow the steps in andresg’s post, it should upload the logs to SmartThings directly.

  1. Open http://ide.smartthings.com

    The link in @andresg’s post used to be correct, but takes you to the SmartThings web app now

  2. Tap the My Hubs tab at the top
  3. Tap the ‘View Utilities’ link at the bottom of the first table

    If you have multiple hubs, you may have to select your hub first

  4. Under the Hub Commands → Send Hub Logs section, tap the Send button

    The button is pretty flat looking, but it’s a button and it should show a green success message at the top of the screen when clicked.


Thanks. I uploaded the hub logs following the instruction.

loaded my logs as well
hope we get a quick resolution on this issue

mine is a CT100 issue

Have we gotten anywhere with figuring out this issue ?

This is very interesting. I have a GoControl GC-TBZ48 Z-Wave thermostat running on the default Edge driver (thermostat-no-humidity, af8f84b1-b445-45e5-9c4a-07294a9682ea). I use Fahrenheit.

When I set the temperature with the Android app, the new value always appears with 0.2 degrees added - so if it’s showing 67.0 and I hit “+”, it jumps to 68.2. Hit plus again and it goes to 69.2. But after sending the command to the thermostat (“+” briefly replaced with circling dots) it drops the displayed temp to 69.0.

Slightly weird… Not a functional problem, just a curiosity that appeared a couple of weeks ago.

I got the same problem (can’t change temperature and network error) with my CT101 thermostat. I changed my Smartthings temperature unit setting from Celsius to Fahrenheit and the temperature control is working again.

To change from C to F, go to https://graph.api.smartthings.com/, select your location, and press the Edit button to see the temperature unit setting.

Hi Team any progress on solving this issue.

I also have this issue. Tried removing device, then remove the driver, and readd the thermostat. Didn’t help.

Tier 2 reached out to me but still no progress on the smartthings side for this problem. THey asked for some screen shots but not sure how that can help as it shows nothing really.

Any one get any other updates ?