CT100 thermostat zwave edge driver problems

I have ct101 and have noticed that my thermostat has no device network id when I look it up in IDE. Possibly the root cause of the apparent communication issues that we seem to be experiencing.

If your device switched to an Edge Driver no network ID will show in the IDE. The IDE doesn’t work with Edge Drivers, and will be phased out in a few weeks.

1 Like

I don’t usually keep my house this cold :-/ but I’m out of town for a while. The “56.2” is transient - after the new value is transmitted, the display switches to “56.0”: Function is just fine, both from the app and from scenes, and the thermostat responds promptly.

I am seeing some progress with the temp.
now it seems to sometime take it.

There is still a lag and i still see comm errors during the changing of the temp
so some hope but it is not consistent

Has there been any changes to the driver now ?

Automation routine now seem to work but it requires doing it 2 times.
So like I said some hope but not fully usable yet

is there more work to make this more reliable ?

The driver seems to got updated to Dec 6 version but my thermostat still have the same issue. I removed and added it again but still the same issue.


It seems to be working much better but not 100% reliable yet.
Not everything from routines makes it correctly to the thermostat

way better than before but still not there yet

I take it back, one of the routines I ran looks like it worked for sometime
atter 20 minutes the target temp changed back to the previous one and restarted again

so not really working yet. We still have issues to deal with
this is bad as now I cannot trust the routines or the output on the screen from the app

Seems that doing this (changing gateway to F) combined with a remove and re-add seems to be working

Having the same problem :confused:

1 Like

Same problem here on the CT100. When going to the device on the app, I also get the error message:

“This device hasn’t updated all of its status information yet. Check again later.”

1 Like

This message has started popping up a lot lately, for several kinds of devices (Z-Wave temp/lux sensors on stock Edge, Zigbee motion sensors, bulbs on stock DTH, Zigbee Switch on bespoke DTH, Z-Wave Thermostats on bespoke DTH, Z-Wave Dimmer/switch on bespoke Edge, all on v2015 hub)

What may be the root cause?

1 Like

Same here, CT101 not working properly using edge driver
Logs uploaded , message sent.


Just to add some info, since it still doesn’t work and there is no updates whatsoever on this issue.

Got another CT101, and to my surprise this one works properly BUT …

Thermostat 1 is using Type placeholder (not working)
Thermostat 2 is using Type CT100 thermostat (working fine)

They are both exactly the same, on same hub as well. What gives?
Tried to remove and add the non working one many times, no change.
It only correctly detect temperature and it’s able to switch modes. Adjusting temperature is ending in network error.
If I change the “placeholder” type to CT100 Thermostat there is no change, only other Driver available in the app is Z-Wave Switch.

ST case 1448192

Logs uploaded, access enabled, info sent to andresg


Unfortunately not working for me

Thank you for the information, @lifeisfun
When you see “placeholder” in the IDE, it means it is not using a DTH, and, changing the device type from there will make the device non-functional because it wasn’t connected using any Groovy features (like DTH). So, please, avoid editing this part in the IDE.
I don’t know why the other device was connected using the DTH, we’ll add this info to the report.

1 Like

I’m going to find a used CT100 or CT101 on eBay to try and figure out why the device is giving you guys so many issues. If anyone has a spare they can loan me instead, let me know.

100% EDGE driver issue, with the old DTH working perfect.

Thank you for reply!
I hope in the process of fixing this my other Thermostat will not be “downgraded” to placeholder as well…
Very cold around here :cold_face:

ST case 1448192

The ct100 is a pretty old device, one that doesn’t look like its made anymore. Not sure how Samsung would even go about testing with it to provide compatibility with Edge.