CT101 Z-Wave Thermostat no longer working for routines (Nov 2022)

hmmm I am using a ST v2 hub and it doesn’t like the device handlers I had been using for several years. It started giving a network error any time I tried to change the temperature.


Are you saying that you installed a custom edge driver for the CT100, or is the CT100 supposed to be supported in an official SmartThings driver?

I installed one of the beta drivers from the following link for the 2gig CT100:

Unfortunately, uninstalling the device and trying to add fails with the driver. I couldn’t find any others for the CT100 or the CT101.

1 Like

I’ve been using a CT-101 for 5 or 6 years now, and twice I’ve had it stop responding to SmartThings, similar to what you’re describing. Both times I followed R-Boy’s quick fix and it solved my issue in no time.

I don’t know if it’s exactly the same issue you’re having, but I hope it helps!


@kajoyce has a 2gig CT101 z-wave thermostat that is not being discovered by the z-wave thermostat edge driver. @kajoyce says it is almost identical to the CT100 thermostat, which is supported by the z-wave thermostat edge driver. What would be needed to add support for the CT101?


Hi, @kajoyce, sorry for the delay.

Do you know the device’s fingerprints of the CT101 model? This is just to check if they are included in the driver.

I also saw your comment here:


I am not sure how to get the fingerprint of the CT101 as you are requesting? I can provide the data and raw description from the API:

Data |
- manufacturer: Radio Thermostat Company of America (RTC)
- networkSecurityLevel: ZWAVE_LEGACY_NON_SECURE
- productId: 12
- productTypeId: 25857

  • | - |
    Raw Description | zw:F type:0806 mfr:0098 prod:6501 model:000C ver:9.00 zwv:3.28 lib:03 cc:20,81,87,72,31,40,42,44,45,43,86,70,80,85,60 epc:2 |

Let me know if you need anything else about the device.


ok, in the stock DTH, this fingerprint was included: SmartThingsPublic/ct100-thermostat.groovy at master · dkirker/SmartThingsPublic · GitHub
And, it is also included in the Edge driver: SmartThingsPublic/ct100-thermostat.groovy at master · dkirker/SmartThingsPublic · GitHub

Have you tried installing the driver “Z-Wave Thermostat” from the SmartThings Beta Channel?

Please, let us know if installing that driver and repairing the device makes it work correctly.

I did try to install using “Z-Wave Thermostat” from the beta channel but it did not find the device.

Could the problem be the defined devices in the SmartThingsEdgeDrivers/fingerprints.yml at main · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub ? I’m not a developer but I did notice Iris Thermostat is defined 2 times:

  • id: “0098/6501/000C”
    deviceLabel: Iris Thermostat
    manufacturerId: 0x0098
    productType: 0x6501
    productId: 0x000C
    deviceProfileName: base-thermostat
  • id: “0098/6501/000B”
    deviceLabel: Iris Thermostat
    manufacturerId: 0x0098
    productType: 0x6501
    productId: 0x000B
    deviceProfileName: base-thermostat

I also looked at the SmartThingsEdgeDrivers/init.lua at main · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub

{ manufacturerId = 0x0098, productType = 0x6401, productId = 0x0107 }, – 2Gig CT100 Programmable Thermostat
{ manufacturerId = 0x0098, productType = 0x6501, productId = 0x000C }, – Iris Thermostat

Should the “,” be after the } before the Iris Thermostat? Looks like someone was planning to add another fingerprint.

It looks like ST moved my thermostats to an edge Driver yesterday, and now I am having some issues.

I have 2 CT101 thermostats and 1 CT 100 thermostat. ST v3 hub

  1. The thermostat works fine, if I manually control it at the physical thermostat itself. For example, if I lower the thermostat setting by 2 degrees at the physical thermostat, this is reflected in the ST app. It works perfectly.
  2. I can also control the thermostat using Amazon Alexa. For example, if I ask Alexa to lower the thermostat by 2 degrees, this is reflected on the physical thermostat and in the ST app. It works perfectly.
  3. I can also use the Alexa app to adjust the thermostat temperature setting.
  4. The problem is controlling the thermostat from the ST iPhone app. In the app, I can monitor the furnace actions. I can also change the mode, from heat to cool to off, etc.

The issue is trying to increase or decrease the thermostat temperature setting. For example, when I try to decrease the thermostat temperature and I press the minus key in the app, it errors out. But, the thermostat actually changes the temperature setting.

Say the heat setting is 70. If I press the minus key, the app after about 30 seconds errors out and tells me there is a network issue and shows the settings still at 70 degrees. But the thermostat will actually now be set at 69 decrees (when I look at the physical thermostat).

Anyone have any thoughts?

1 Like

@plgill99 I use a V2 hub and have similar issues but with the old device Z-Wave thermostat handler. I can’t even get the beta drivers to recognise my CT101 thermostat to try the new driver. I also don’t use Alexa for controlling the thermostat. I only use the actual thermostat and the Smartthings app.

Trying to use the old CT100 device handler fail with the error for changing the temperature but it does NOT change the temperature on the thermostat. While I am using the Z Wave Thermostat handler I can change the temperature but can’t run any routines and if I change the temperature on the thermostat it is never reported to Smartthing in the temperature control section of the app. It does show in the actual room temperature that the temperature is registered.

This all used to work fine under the old CT100 device handler but broke sometime between April and November this year.

1 Like

Hi, guys

We would need you to provide us with Support Access. The way to do that is by following these steps:

  1. Go to the SmartThings Web
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

And we would also need you to send Hub Logs. If you don’t know how to send those logs the procedure is the following:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

And please let us know which Samsung Account you’re using and if you have more than one Hub, the name of the one where the device is paired. This last piece of information can be sent by DM to me directly, so you don’t have to share it publicly.

Also, please confirm the email address associated with your Samsung Account.

You can send this last information on a DM to myself.

Done and sending you DM now.


Logs have been sent. Account Data Access was set before I sent the email requesting assistance from support.


Hi Andres,

I am also facing the same issues. Followed the steps described above - however, I cannot figure out how to send a DM on this board.

It also looks like the routines are not working correctly. For example, I have a routine as follows: at 7am, adjust the heating temperature to 75 degrees. These routines seem to work once (it is random) in a while but mostly they do not work. Is anyone else seeing this?

Just click on the person’s name and click the message button to DM that person.

that’s the thing - I don’t see any message button… sorry :frowning:


Can you take a look at my response from November 29? It doesn’t seem like anyone with coding experience has commented to my question about the Edge driver source files and if they are formatted correctly.