Create A Vacation Routine?

I am very new ti Smartthings & installed 2 Cree connected bulbs & an outlet to control 2 lamps. All working good. Here is what I did when I set them up

  1. Outlet with 2 lamps set to come on at 7Pm & off at 10PM Then on at 6AM & off at 7Am
    2 1 Cree bulb on at 7PM off at 9PM then on at 6AM & off at 7AM
    3 1 cree bulb on at 9PM off at 9:30PM
    These will be used when we are away from home

Now I want to pull all 3 into a new Routine called vacation that way I can just click when we leave & everything should work.
Problem I am seeing is that it is asking me what to do ON Off & what lights. Now when I add the lights I want controlled will they do the times I pre programmed or do I need to edit these?

Step 1: Create the “Vacation!” routine.
Step 2: Setup “Vacation” routine to Arm SHM.
Step 3: Install CoRe Rule engine.
Step 4: Create Positions in CoRe Rule engine to perform each of those steps when your home is in “Vacation” mode.

When you say On/Off and set the time, it will turn on at set time and off at set time.

1 Like

sorry to be so DUMB but with being brand new (less then 3 weeks) I have no idea what you are talking about. Tried to put some of this in search & search will not work. Plain English with step by step PLEASE.

You can also do this with smartLighting found in the marketplace.

Create a new Mode called “Vacation”, which then you can have as a routine.

Create a few rules in SmartLighting for each scenario you want. Think it will be 5 rules. Only have the rules execute when mode is “Vacation”

There is also vacation lighting director, which will randomly turn on/off lights that you have in your routine. Won’t be as scripted as what you want.

OK used Vacation Lighting Director & set times. Now will this auto start when we are away? (Away is the button I checked)
The other problem I have is while I was out today about 25 miles away from home I checked Smartthings. It said I was present in the house when I was not. How can I correct this or do I just need to tap the Arm (Away) button on the Dashboard.
Thanks for all the help it has been a real learning experience.

The key to using SmartThings as a home automation platform, is to understand routines and modes and have them fire automatically. It sounds like you’re well on your way if you’ve already installed Vacation Lighting Director.

So to automate this, you don’t even have to create a new routine or mode. Start by making sure you set up presence and it works. We use our phones are presence, and it typically works great. The next step is to automatically run routines when your presence changes. On your Goodbye! routine, change it to run automatically when, say, everyone leaves. You can then also arm Smart Home Monitor and change mode to Away. So then when you leave, the mode will change to Away and SHM will be armed.

Similarly, change the I’m Back! routine to automatically run when anyone arrives. Set it to change mode to Home and disarm SHM. So when you arrive, the mode will change to Home and SHM will be disarmed.

Now set Vacation Light Director to only run when mode is Away, and voila! you have home automation :slight_smile:. You can use the same concept for any SmartApp or SmartLighting rule.

1 Like

Looked at Android Phones & they say present how can I check to see if they are working?

I was able to setup Goodby & I’m Back so that looks to be done.
Again thanks for the help

Is the app running on the phone and have them access to location services? The app can be running in the background.

Some phones work better than others. I have 2 onePluses and a Nexus 5p. Get good reporting on all of them. You will also need to set up your location adjust your zone.

You can look at the phone’s Notification in ST and see if they have reported away/back.

If you set smartlighting to run when mode is away then it should fire.

1 Like

Notifications have been sent that both phones have arrived home. So looks to me everything is now working. We will see this weekend.
Thanks for all the help

Sorry @siam,

I was running out of the office when I typed up the reply.

Here is a pictorial of Routine and Mode setup for your Vacation.

1 Like

I have not used this app in a while but it worked very well for me a couple of times when I was on vacation.

Thanks for the great pictorial. I have it setup step by step like you showed.
Last question
When we leave all I need to do is tap the routine & it will work until I return home & turn off.
I have realized I need to keep my Mobile Data on ( Something I have not done before) & also keep GPS on.
Thanks Mike

Mobile presence for both IOS and ANDROID requires you to have WIFI/GPRS/Cell Data active. IOS manages it a bit different than ANDROID, but for both, you need to have it active. FYI, in order to change to I’M Back routine, you will need to set it to automatically activate when “Someone arrives”.

I have all ready done the I am Back
Thanks for the help

For some reason, well at least on iPhone, I can’t create “modes”. I had to go here,, to create a new mode, look under locations, and select your hub (mine is called home).

1 Like

ST took that option out of both IOS and Android apps :unamused:

Sorry about that. I didn’t update my original post. ST has recently forced all to use the IDE in order to create Modes.

If you automatically have Good Night executing when things quiet down you will want to set Good Night to not “automatically do this if I am in one of these modes” when in vacation mode. Or Good Night willl execute and take you out of Vacation Mode.
You can check the active mode under “More”, touch the three horizontal bars at the bottom right corner, and the mode is displayed at the top.

Lighting director isn’t firing on and off my set lights, mode is Vacation, yet nothing.

You may want to use the updated version of the vacation smartApp, rather than trying to have a routine do this.