Just getting started on the automation


#1

Apologies in advance here as I’m a newbie. I am trying to use Smart Lights App to enable some vacation events:

  • Turn on lights at sunset.
  • Turn off lights at 1:00AM.

I can’t seem to find where to Activate/deActivate the Vacation routine from ST in the app on my phone. I’ve created and saved it on the phone (its says its saved and running), but where do I find to activate/deactivate? I can’t seem to find the app on the phone.

I’m looking to get something going quick as I leave for a business trip shortly and I’ve just installed my first two switches. Longer term it seems that vacation director has many of the more advanced features for which I’m looking.

Any guidance and/or pointers to documentation/examples appreciated.
thanks.


(sidjohn1) #2

#3

Use smart lighting that’s in the app under smart apps


#4

Hi,

I see that I can use routines or the smart lighting app to accomplish my objective. I’ve chosen to go down the route of the smart lighting app. However, it’s not clear to me with either option (SL app or Routines) how to enable/disable the execution.

I’m thinking that I don’t want vacation rules being executed until I need them and I can’t see where to turn them on/off. Am I forced into doing this through the use of modes? I am missing something here and the documentation is sparse.
Thanks.


(Nick Snyder) #5

@Tango If vacation routines are only to run when your entire household is gone then the best solution is to use modes to activate and deactivate.

Put the house into vacation mode and set those routines/lighting apps to run only in that mode.


#6

When you set the smart lighting triggers there will be an option to only do it in a specific mode. Can create a mode called vacation or just add it to the default away routine


#7

Hi,

I’ll start down the automation path by learning routines/modes. Here are some questions:

  • It’s not clear to me if I can do more than one event in a routine. For example, when looking at Goodbye, the first two choices presented are : Turn on these lights or switches and Turn off these lights or switches. Can I program the Goodbye routine to turn on the lights at sunset and turn them off at 1:00 AM? While I can do the ‘programming’ for that, it’s not clear that it will execute. Part of my doubt has to do with the second point below.

  • All I have programmed in Goodbye is to turn off the lights at 1:00AM. When I press the Goodbye routine icon on the routines page, it immediately turns off the lights. But the instructions I have programmed indicate that the lights are turned off at 1:00AM. So is pressing the away icon equivalent to executing all the events regardless of the time request associated with those events?

  • What is the relationship between “Automatically perform Goodbye at…” and the time associated with the events? What I had programmed was the following in Goodbye:

Turn on lights at sunset - 30 minutes.
Turn off lights at 1:00AM.
Automatically perform Goodbye at 6:25 PM.

When I left the home, the lights were on (I had turned them on physically). At 1:00AM I expected the routine to turn them off and this did not happen.

Thanks.


(Nick Snyder) #8

@Tango Can you take a screen shot of the goodbye routine you have programmed and post it here?

To answer a few of your questions, you can do multiple events in a routine but it runs the entire routine at the time specified. So you would set up one routine to change the state on multiple devices at once and setup a second routine to change the state again. However, if you are just controlling lights, you want to install the SmartLighting app and do your programming from there.

Pressing the routine button activates that routine even if the time inside is set to run at a later time. That programming just tells it to run at a specific time, pressing the button tells it to happen now.

So as far as your programming goes, it looks like you setup the lights to turn on and off via SmartLighting and have Goodbye to trigger at 625pm via the routine. Is this correct? If you turned a physical switch on to turn the lights on, the system doesnt know the lights are on. Its just the nature of ‘smart’ bulbs. They do not send a command to the smartthings to let them know they are now on. So chances are that the system did fire the routine as you requested but it already thought the lights were turned off.

Check the log inside the mobile app to see if the routine ran.


#9

Does that apply to smart switches? I’m slowly wishing I never ordered all those GE bulbs and just got the smart dimmers


(Nick Snyder) #10

It does not apply to smart switches.

I only use bulbs for a light thats plugged into an outlet. If its a ceiling light or wall light I have started switching my system over to smart switches for this reason. Also makes it easy for anyone to come into a room and flip a physical switch and not screw with your system.


#11

I realized I could summarize my question after I wrote the blurb below :slight_smile:
as: Is there a simple way of setting a mode?

I’ve been successful using the SmartLighting app (SL). I have one automation that turns the lights on at sunset -30 minutes and another that turn the lights off at 1:00 AM. So, I’m essentially running my ‘vacation’ mode every night which is ok. While this ‘gets the job done’, I’d still need to examine how to enable/disable these two automations. I have been able to create a new mode ‘vacation’ and I understand that I can use Routines to tell ST to go into Vacation Mode. Once in Vacation Mode the two SL apps should run when I set the trigger to be Vacation mode. My requirements are that I wish to tell (not using presence) ST to go into Vacation mode and, when I return to go out of Vacation mode. However, I don’t the ability in Routines to just set the mode to Vacation. There needs to be a trigger (such as everyday at 8AM), and then it stay on till I go in and code it to not be on (e.g. either delete the Vacation routine or don’t set a time). Is there a simple way of setting a mode?
Thanks.


#12

You can have a routine that does nothing but set the mode, then just tap it manually to run it.


#13

You can go into the ide and create new modes. Not sure if you can in the app or not


#14

You can create new modes in the official mobile app (see the link above). But not, I believe, in a custom smartapp.


#15

Here is how to create a new mode from ST (and it’s how I created the new vacation mode).

Ok…apparently I can’t post a link so, the answer is in the link from JD Roberts who posted an excellent description from the link in his response. Yes, you can create a new mode from the ST app.


#16

Murphy’s Law…so I installed a new switch and, unbeknownst to me, the ST servers were down. So, of course, the switches didn’t work and I assumed it was my installation. It took me an hour to figure out it wasn’t me but the servers were down and my hub was ‘offline’. This was frustrating. My suggestion to ST was that they should opt a new user into their status updates rather than make it an opt-in option. Of course the downside is that they might be informing users who don’t care, that their servers are down, kinda making them look bad.

But when the servers came back up, everything worked and the hardest darn part of the installation was trying to cram 2 cubic feet of wire into a 1 cubic foot circuit box! Then my wife pointed out that the switches all operated slightly differently which was one of the by products of purchasing different switches from different companies.


#17

I am a newby, I have created a vacation mode and have created a vacation routine. I manually turn on the vacation routine- when I will be gone for a few days. My problem is I tested it out - I manually pressed it- it went into vacation all day and night UNTIL my “good morning” routine set to automatically change to home/stay at 6:30 am. How do I create a vacation program that can not be cancelled?? Thanks


(Scott G) #18

If you go into your “Good Morning” routine setup and click on the “Automatically Perform When” section, then at the bottom is a plus sign for Additional Options. Expanding that, you’ll see the option to not run Good Morning in selected modes. Changing that should fix this for you.


#19

PERFECT !!! I never clicked that plus sign! Thank you