New App: Vacation Light Director

Occupancy light simulator will simulate your house being lived in even when you are not.

Pick a set of lights and at a interval you specify the app will turn off all lights and then turn on a random set of lights. Nice things is you can restrict this to mode/time/day of week. It is always triggered by mode change but will not run outside of specific restrictions you set. Nice things is it will not run if someone is home and the mode changes.

Thanks to @dave for testing!!!

https://github.com/tslagle13/SmartThings/blob/master/Director-Series-Apps/Vacation-Lighting-Director/Vacation%20Lighting%20Director.groovy

20 Likes

Tim,
Thanks for making the Occupancy Light Simulator App! It has been working great the last couple of days.

For those setting it up on their ST system, make sure you fill out the “If these people are home do not change light status”. Without this filled out the app will turn your lights out upon mode change, even modes that are not set in the app (like when your home etc).

I will be using this every week!
Thanks again!
Dave

1 Like

That is epic, I’m going to try that out.

1 Like

Tim,
That is really a great idea. I have access to the IDE. How do I go about getting this on my ST? I have added Nest capability on ST from the IDE. I am assuming this is a smart app. Is that correct?

1 Like

Yes, it’s a SmartApp, go to the IDE, My SmartApps, + New SmartApp, From Code, then Paste Tim’s code in from his Github, Create, Save, Publish (for me).
Force close your ST App and when you restart it use the: + sign, MyApps, and select the Occupancy Light Simulator.

1 Like

Hi Tim, trying this app, but when I fill in the specific times on the second page, it crashes often, or when I can complete the times, they don’t display in the app.

STs issue. Doesn’t display on any app including apps produced by STs

Is that a new bug then for ST? So the times will work?

IDK if its new or old, but is a bug. Yes time restrictions work.

Thanks Tim. Looking forward to using it.

FYI - app is sending light commands even with presence home and outside of the time range.

Within the mode you selected is normal. (From the start of that mode to the end of that mode it will send off commands at the selected cycle period).

Just tested. Working fine for me. Did you select both a start and a end time as noted?

I thought if you selected presence, then it wouldn’t activate even during those modes if those folks were home?

same for me as well, it seems to be ignoring presence.

My copy seems to work fine. What is yours doing that you don’t think is correct?
If your lights are not getting turned off at every mode change then this presence setting is working correctly.

It will always run during the mode you select Not matter of presence. it just will not action any light changes depending on presence settings.

1 Like

@tslagle13
Tim do you have any TCP bulbs? I’m sure this is a ST / TCP issue but my TCP bulbs are very hit or miss currently when using the Light Simulator.
Turning the TCP bulbs on manually using the ST App / UI works fine.
Thanks

Update: reducing from 8 bulbs to 4 bulbs that the Light Simulator controls seems to have fixed the problem.

Greetings again!

This is indeed epic! I downloaded, installed, configured, and tested yesterday - works like a charm. True enough, be sure to review and adjust all of the settings thoughtfully (like ensuring it doesn’t activate if people are home, etc.).

My only suggestion at this point would be to add a bit of a random factor to the time duration - for instance I have it set at 45 minutes, and would love if it could use a bit of wiggle room in there (sometimes 43, sometimes 47, etc.) just a bit.

To me this is one of the killer apps in this whole ecosystem, building on the the sensing apps (like changing the state from Away to Home when one of us arrives, which is both foundational and also very cool). Kudos again and thanks so much!

2 Likes

Really glad this helps ya man!

Merry Christmas and God bless!

2 Likes