Couldn't register Hub

I have recently bought a smartthings hub v3 and motion and mutlipurpose sensor. I am trying to register the hub using the smartthings app.

The app could see the hub and i went through the registration process and registered the hub successfully the first time.

However, for some troubleshooting, i deleted the hub from my account and tried to register it again. It goes through the process and then during the registration it gives me an error message “Couldn’t register Hub”. I have tried the process many times from the same account, different accounts and different mobile devices and it gives the same error message.

Can anyone help and give me a clue what the problem might be.

Thanks in advance

1 Like

Thank you jkp, I have followed the steps and it is now registered. I am now trying to add a motion sensor to the hub.

I have followed the steps and I should be able to add the sensor manually by selecting the category for the motion sensors.

Unfortunately in the app I can find only 1 category listed which is the “Home Appliances” and under this category, there is only smart home adapter or TV.

Where can i find the categories for motion sensors and other sensor types.

Install the SmartThings Classic app now that you have the hub added. Login as new user using your Samsung account and try to add your sensor.

1 Like

Really appreciate your support, I am able to setup the sensors now and ever thing is working perfectly.

1 Like

Sounds like your Samsung account is registered in a country where Smartthings isn’t sippprted yet. The new app restricts what devices it offers. The classic app has no such restriction.

I bought a home monitoring kit, hub version 2, I’m in contact with support over 2 weeks and still cant register hub, even after resets, the light stays solid blue, and if i try registering the welcome code it says already registered and needs to be invited by owner. Any one have an alternative solution this is taking too long.

Login to IDE at https://account.smartthings.com and look under My Locations to see how many locations you have? If more than one, report back.

Also solid blue means:
Blue (solid)

What it means: Attempting connection to the SmartThings cloud/servers

What to do: A solid blue light is expected during the normal setup process and when downloading firmware updates (in some cases). However, if the light remains solid blue for longer than 5 minutes, this indicates the Hub is unable to establish a connection with our servers. This problem can occur when outbound traffic from a local network is being blocked. Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, and 37. The Hub v1 also requires the NTP port (123)

Just 1, yes went through all the steps mentioned, even disabled firewall on modem, also service provider does not block any ports

Tried a different Ethernet cable and plugging into a different port on your router? Other than that, support is probably your only option in figuring out the issue. :frowning:

Yup tried that, also went to neighbors and use their modem, same prblem

Resolved: I kept getting “Registration Failed” over WiFi and with Ethernet plugged in I would get “Hub not found” error.
Solution: During initial setup, your mobile (on which you have installed the SmartThings app) should be connected to a 2.4Ghz WiFi network. It didn’t work on a 5GHz WiFi network. After the setup is done, you can then switch your mobile to a 5Ghz network.

Frustratingly, I tried switching to a 2.4MHz network. It made absolutely no difference. Any more suggestions other than flushing this crap down the toilet?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.