Code already registered: tried factory resetting 10+ times

I have a smartthings v2 hub. Recently I wanted to migrate to the new smartthings app. So, I removed the location and factory reseted my hub. However, when I try to add the hub to the new app: I see code already registered error.

I tried to add the hub in the old app. It gives me a “Code not valid” error. I tried emailing/calling customer support. However, every time they tell me to reset the hub. Last time (almost a week back) I could convince them that I had reseted the hub. So, they said that they would forward this to the devs.

However, yesterday I received another email with instructions on how to factory reset the hub! The customer support has turned out to be a joke. Anyone can give me any pointers or this hub is just a brick now?

Note that I have also tried to delete my smartthings account and tried setting up from scratch. Still no luck.

So, unfortunately I don’t see any hub listed in the IDE. Initially I had multiple locations there (which I could not delete). However, after I had deleted and created my account, that’s no longer an issue. Not sure what to do at this point.

It probably did not really get deleted. I had a similar issue a while back with some devices. @Brad_ST should be able to help you. I know that he fixed my issue.

I would advise users only delete their Samsung accounts if they absolutely must or are instructed to by support staff. The way the deletes cascade down to SmartThings can leave things in limbo which is what happened here.

3 Likes

Is that a bug or a feature? :thinking:

I would say there are two bugs. The first bug being that the factory reset failed to delete the original hub record. The second being that deleting a Samsung account should cascade down and delete the hub record in the event it wasn’t already deleted.

Maybe another suggestion?? I delete the samsung accounts and create a new, but persist issue.
I have opened a ticket #749018 to SmartThings Support but they do not give me an answer.

Thanks

I have the same problem. Deleted account the hub stayd linked to that account. Any solutions ?

I don’t know why you removed your hub to start with, as my hub works with both apps.

I am having same exact problem. I have reset my V2 hub with no success. I sent a message to Brad like you suggested and I’m awaiting a response.

Im having the same issue including the endless loop with texh support. Let me know if you find a solution

Eric,

I sent an email directly to Brad at samsung. He was very helpful and fixed my problem. He had to manually add my smarthings hub. When he did this, it appeared in my smarthings app again.

Brad_ST

Brad_ST

A community for everyone interesting in making their homes and lives smarter.

Carri,

Thank you for the reply. I will contact Brad as soon as I figure out what his email address is! I do not seem to see a way to message or email him directly

I think I had to go through the smarthings community to reach him.

Tagging @Brad_ST

Hi,

I’m having the same issue here. It’s a brand new v2 hub, which I had never registered before.

I used the new SmartThings app on Android and the first time I tried to register it it gave me some kind of network error, when I tried again I started getting the “code already registered” error, even after multiple factory resets. The classic app says the code is invalid. And the hub does not show up anywhere.

I opened a ticket with support, #849096, they asked for some pictures and screenshots which I sent. I would be wonderful if @Brad_ST or some other staff member could help me add it manually to my account.

Can you try registering the hub again?

It worked! Thanks so much!

1 Like

Hello, I have the same problem “Code already registered. Invitation from owner needed to use this hub.”

Hello, I have the same problem “Code already registered. Invitation from owner needed to use this hub

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.